WiFi connection issues

Since upgrading to Oreo, I'm having WiFi connection issues, where it slows or stops. I need to toggle WiFi on/off to get going again.

WiFi connection issues

Gareth Stevens Gareth Stevens
 /  edited September 2018
Since upgrading to Oreo, I'm having WiFi connection issues, where it slows or stops. I need to toggle WiFi on/off to get going again. Anyone one else have experiencing same, know how to resolve.

Comments

  • pepepez pepepez
    ✭✭  /  edited December 2017

     I have or had a similar problem: I set the phone to de-activate when in sleep mode. When activating the phone again, the Wifi didn't work. I had to restart the phone.

    Nokia Support recommended to to set the phone to have Wifi always active when in sleep mode.

    You find this setting here:

    Settings > Network & Internet > Wifi > Wifi settings > Advanced > Wifi in sleep mode

  • Tried that already. Still drops out. Getting very annoying.
  • Hey.. ur not alone, i have the exact same concern like what you have. Anyway, seems i cant find wifi settings on my unit, anyone here have issues finding wifi advanced settings or is it just me?
  • J444LH J444LH
    ✭✭  /  edited January 2018

    Network & Internet / Wi-Fi / Wi-Fi Preferences / Advanced

  • Just got Oreo on Nokia 8 today. Vodafone UK

    Not Perfect. Wireless is lagging and cuts off. Browsing is a nightmare on WiFi. Apps lag sending and refreshing data. Phone is absolutely fine in 4G. Anyone else?

  • Gareth Stevens Gareth Stevens
     /  edited January 2018
    Contacted Nokia, went through all the same "try this" etc. Then was advised to go back to retailer under warranty as might be hardware. Wake up Nokia. It's software. All worked fine under Nougat. Then on Oreo all the issues. Fix it!!!
  • PetePete PetePete
     /  edited January 2018

    Yep, clearly software. How are there so many issues coming up and they weren't caught on beta or in house testing?

  • user1515155292378 user1515155292378
     /  edited January 2018

    Same problem here! Disconnecting all the time and it seems to get worse.

  • saiyantimelord8 saiyantimelord8
     /  edited January 2018
    I've got the same problem here, only started after the latest update, not the one for the Oreo update, now my phone's acting up.
  • PetePete PetePete
     /  edited January 2018

    Sounds like I get a notification, so, unlock the phone to check and nothing there. Yep, thats the WiFi disconnected for 3 seconds and back on.

  • Getting the same issue. Browsing over WiFi very laggy and sometimes looses internet connection. Also getting the WiFi disconnected notification at regular intervals. Phone was fine before updating to Oreo.

  • user1507208628483 user1507208628483
    ✭✭✭  /  edited May 2018
    Check your router settings. Make sure you use WPA2-PSK security with AES encryption, if you have no legacy WiFi devices, do not use multi mode WiFi, use Wireless N / AC only. If you have to use muti mode WiFi disable Short GI as it causes problems in multi mode. Also download WiFi analyser from the play store and find the clearest channel. Remember with 2.4.ghz WiFi you can only use channels 1, 6 or 11. Do not use any other WiFi channel, they overlap and interfere with each other also do not set the channel width wider than 20mhz on 2.4ghz WiFi, as this then restricts you to either channels 1 & 6 or channels 6 & 11 and it's guaranteed that you will get interference from your neighbours and won't give you faster speeds. If you have a router that does both 2.4ghz and 5fhz WiFi make sure you set the same SSID and security for both frequencies. Your phone will then roam seamlessly between them choosing the one that will give you the best signal and speed.
  • Thanks for the info. Running wpa2-psk with AES in compatibility mode. Its set to detect and switch to channel with least congestion. Don't have option of disabling GI.  If I reboot my phone i get a good internet connection for nearly half a day then it starts playing up again. No other devices have same issue.  All I can think of is some sort of memory leakage in the WiFi driver / software. Didn't have the issue until Oreo update came down. Hoping someone has found a work around also logged a support call with Nokia.

  • I have seen the bug your describing occur but for me it usually takes a couple of weeks for this to happen. I've seen it on every firmware so far except the stable of 8.1. Not sure what else to suggest for you, I know their are some known issues with Oreo 8.1 with it roaming between 2.4ghz & 5ghz bands, it usually ends up getting stuck on 2.4ghz after while. This though is an issue with Oreo 8.1 as pixel devices also suffer with this problem. The soc in the Nokia 8 is basically the same as any other phone with the Snapdragon 835 so the driver would be the same, be interesting to know if any of those devices have this same issue as that would then suggest its a problem with Qualcomm's drivers.
  • I've just seen this happen on the 8.1 Oreo stable, was getting laggy performance then got a connection drop, so did a speed test and throughput was terrible. Rebooted and performed another speedtest and guess what back to normal. This is most certainly a bug which has plagued the Nokia 8 from the initial firmware release on Nougat. This is most likely Qualcomm's fault and the supplied WiFi driver for the 835 SOC.


    image

  • Nokia 8 after update oreo is slow signal
  • I believe that the only solution, is a factory reset… I've done on my phone and everything is acting very normal
Sign In or Register to comment.