Oreo 8.1 and Smart Lock

As I upgraded to 8.1, I noticed two days now that the Smart Lock menu does not work. is that a bug of the OS? Does anyone else has the same issue?

Oreo 8.1 and Smart Lock

Konstantinos Konstantinos
 /  edited February 2018
As I upgraded to 8.1, I noticed two days now that the Smart Lock menu does not work.
is that a bug of the OS? Does anyone else has the same issue?

Comments

  • Miikkelson Miikkelson
     /  edited February 2018

    For me it works. Can you point out what in the menu doesn't work, or is it the whole menu that's not working?

  •  When I enter the Smart lock menu with my pattern, all I get is a blanc white screen, with just the upper right menu for Help and About...

  • Miikkelson Miikkelson
     /  edited October 2018

    I had the exact same problem earlier on. I fixed it by doing this.

    -Go to Settings -> Security & location -> Trust agents

    -Disable Smart lock and enable it again

    -Reboot.

    Hope it works for you :)

  • Done!
    Thank you! Problem solved!
  • terminusaquo terminusaquo
    ✭✭✭  / 

    Only difference for me was to Disable Smart Lock, Reboot then Enable Smart Lock. I also opted out of the beta version of Google Play Services which didn't downgrade it anyway.

  • Migs Migs
    ✭✭  / 

    This is an Android bug which Google just seem to be ignoring. And, to make it worse, the May update has removed the Trusted Places option from Smart Lock altogether.

  • terminusaquo terminusaquo
    ✭✭✭  / 

    @Migs That's also a bug in Smart Lock as I have Trusted Places and I have the May update as well.

  • Migs Migs
    ✭✭  / 

     Really? Because that's when it disappeared for me. I assumed they'd removed it. I'll check if the Trust Agent- Reboot trick works later. I hadn't thought to try it, as the rest of Smart Lock is there

  • Migs Migs
    ✭✭  / 

    Well, quite bizarrely, Trusted Places has reappeared. No reboot, no toggling the Trust Agent, nothing. I realised that it hadn't asked for fingerprint or pattern to unlock, checked Smart Lock, and there it is.

  • I request you to please once follow below steps.
    1)set device lock to NONE

    2)settings>>security and location>>encryption and credentials>>clear credentials>>done.

    3)setting>>app and notification>>see all apps>>app info>> 3 vertical dots>>reset app preferences>> reset apps.

    4)perform force restart by pressing power and volume up key for 20 seconds. Device will restart.

    Problem solved!
  • mrbelter mrbelter
    ✭✭✭  / 

    Weirdly since the September update my Smart Lock keeps vanishing and requires the trusted agents trick to work, it had always been fine up to that.

  • Don't seem to work. I deactivated Smart lock, enabled it again, rebooted, and still I enter Smart Lock with a blank screen
  • Disable trust agents, reboot then enable
  • Migs Migs
    ✭✭  / 

    This bug has now been in Android through so many updates it just isn't funny any more.

    When it does work, Trusted Places just ignores the location as often as not.

  • Wow, Thanks bro it working...

  • Though all that works (disable smart lock, reboot, enable), it is easier to put my pin in than do that everytime.  It happens very frequently to me that the smart lock doesn't work.  Very annoying.  

  • Tried above options. After next reboot same issue occurs again.
    Is there any permanent fix or shall we wait till next upgrade.
  • Migs Migs
    ✭✭  / 

     You need to disable the Smart Lock Trust Agent before rebooting, and then enable it again after.


    Unless you reboot your phone all the time, it only takes a few seconds, although it shouldn't be necessary at all

Sign In or Register to comment.