Oreo 8.1 makes the tethering stop working

I've updated my Nokia 8 to Oreo 8.1 today and was trying to use my phone to share a hotspot for my laptop for gaming.

Oreo 8.1 makes the tethering stop working

user1518639782904 user1518639782904
 /  edited June 2018

I've updated my Nokia 8 to Oreo 8.1 today and was trying to use my phone to share a hotspot for my laptop for gaming. The tethering doesn't work properly, and no network is being shared to my laptop, tried with my other phone connecting to the hotspot and again, didn't work. 

I've been using the tethering to share a hotspot to my laptop in Oreo 8.0 as well and it worked completely fine. Is there a way to resolve this? or how can I reset my phone to oreo 8.0?


  • user1518748257295 user1518748257295
     /  edited February 2018
    I'm having the same issues, showing no internet access, I tried soft reset, network reset nothing worked so far
  • I recommend telling the customer support about that as well just to make sure they transfer that info to the developer team so they will hopefully resolve it in the next security patch.
  • I worked out a temporary work around. If you delete the apn type (just leave a dash or any character if it resets) under advanced settings on your network access point it will work but then you won't have internet on your phone!
  • Their is a better solution that doesn't involve editing the APN, you'll find it here:


    It involves enabling usb debugging and connecting your phone to your pc. You will also need to download adb so you can send a command to your phone.
  • alexkay alexkay
    ✭✭  / 
    Checked it with Oreo 8.1 (final) and works fine out of the box. No changes/workarounds made.
  • piphil piphil
    ✭✭  / 

    I'm going to nudge this up as I'm having this issue. I've tried two Windows 10 laptops and my girlfriend's Nokia 6 Android phone, and none are able to connect to the internet through my Nokia 8 hotspot. The Nokia 8 is running 8.1 and the latest February patch.

  • user1507208628483 user1507208628483
    ✭✭✭  /  edited October 2018

    Tethering is quite often controlled by your SIM card operator, it works for me without any issues on Oreo 8.1 but I do have to have a 3g or 4g data connection for it to work. Some people have managed to get operator restrictions with this by changing a setting with ADB. It's not really complicated if you follow the exact instructions, I've copied and pasted these from another post on these forums, it's worth trying it.

    1 - Put your phone in debugging mode

    Under Setting -> system -> about phone, tap repeatedly on Build Number, until the prompt asks if you want to enable developer mode

    2 - Enable USB debugging on your phone

    Under Setting -> system -> Developer options  turn on USB Debugging

    3 - plug your phone into USB, there may be a popup to allow remote debugging, allow this. 

    4 - Download the Android SDK - I highly recommend you get the official ones from Android, but I've zipped the exact ones I used and put them on my server here : sargunar.com/platform-tools.zip

    5 - Unzip the platform tools (either from Android - recommended - or me above)

    6 - Open a command window, and browse to the folder where you have the files.

    7 - Type the following and press the  [Enter] key

    adb shell


    This starts the Android shell (terminal where commands can be typed), which can work on your phone.

    Once in the shell, type this:

    settings put global tether_dun_required 0


    Press return.  To confirm it worked, type this and press return:


    settings get global tether_dun_required


    It should print out a zero.


    Then type either quit or exit


    And that's it

    Thank you to the original poster for this and I hope you don't mind me copying and pasting it here.

  • It is not an issue with the network, which I doubted anyway as I don't think the update and hotspot was a coincidence, I spoke to 3 who I'm with and they said they couldn't find any issues and is most likely to be a handset problem, as I'm on a sim only contract they advised me to contact Nokia support which I did, Nokia after alot of discussion said nothing to do with them and contact my network operator, but they did both say that they would escalate the issue and get back to me, that was over a month ago and none of them have! So for the time being I am changing the apn type whenever I need hotspot
  • piphil piphil
    ✭✭  / 

    I contacted support earlier today via chat, who said that it's a known issue and it would be sorted in an upcoming patch. They weren't able to say if it would be fixed by the March security update however, just in a future patch.

    I'm also on 3, and my data plan has no restrictions on tethering either. I haven't tried to use WiFi tethering for a while, but it would make sense if the Oreo update introduced a bug - I think it was working for me late last year.

  • jaffa jaffa


    The problem seems to be network/config (maybe SIM) related, the problem does appear for some people after the 8.1 update.

    I had this issue on UK THREE network, the solution posted by user1507208628483 above fixed it.

  • Thanks. Fix worked for me too.
  • jpo jpo

    I tried the proposed fix but did not help me :/

  • jpo jpo
     /  edited August 2018

    with the latest update USB tethering seems to work again! thanks!

  • Ciuch Ciuch
    ✭✭  / 

    Solution write by @user1507208628483 works fine with September security update

  • jaffa jaffa

    Shame it took so long, this and Oreo update related bluetooth issues mean I'm no longer a Nokia user, eventually nostalgia gave way to frustration.

    Clearly the new Nokia has no interest in customer service, they don't even read this forum.

  • piphil piphil
    ✭✭  / 

    This was fixed some time ago, in the March patch I think. So it was a bit slow, but not that bad!

  • I doubt it is related but I can't get USB tethering working on my Asus router with either the Nokia 8 or the 6.1 plus

    Should be really straightforward and works fine on a Sony z2 and HTC 10 running Oreo.

    No tether restrictions on the network and fails on both a dsl-n55u and rt-ac68u. I'm planning on using this on a boat, and just plugging my phone in on arrival to give internet to the boat network. I also use it (or did on the HTC) if our office internet goes down on the rt-ac68u.. the router can fail over to the USB... Not now with our Nokia's...

    Anyone seen this or could even test it if you have the hardware?

    Thanks 5teve
Sign In or Register to comment.