WiFi dropping out on Virgin Media (SuperHub2)

Hi,  I've had my new Nokia 8 (my first Android phone) since 17th March and overall am very happy with it, a massive upgrade over my iPhone 6.

WiFi dropping out on Virgin Media (SuperHub2)

System System
 /  edited March 28

Hi, 


I've had my new Nokia 8 (my first Android phone) since 17th March and overall am very happy with it, a massive upgrade over my iPhone 6.


I am however experiencing issues when connected to my home WiFi (Virgin Media), either on 2.4 GHz or 5 GHz bands. My phone will complain that its lost internet connection and have a X in the wifi bar at the top. Sometimes it rectifies itself a minute or two but usually a quick toggle of the WiFi off and on solves this until it does it again randomly. When it is connected I get great speeds and runs fine. 


However I have noticed that so far it is only doing this at home. When connected to my works BYOD WiFi it will stay connected all day and work flawlessly. This is on a 5 GHz band. 


Initially I thought it was the phone as my wife has a iPhone SE which works fine in our house connected to either band. 


However with it working at my office through WiFi fine I'm thinking its more VM related. 


I am running Oreo 8.1.0 1st February security patch.


Has anyone experienced anything like this or can provide any suggestions 


Thanks




Comments

  • Hi Gary, I have the same issue with VM2. Started with 8.1 update. I here march patch should fix it, but I'm not holding my breath. Camera auto focus not fixed yet and it's 7 month old. Only two faults I have. Love the phone. Camera pro is coming in April I hear.
  • I'm having the same problem on the Virgin Media Super Hub 2, it started when I first upgraded to Oreo 8.0, and it's not gotten any better since, I've had two Nokia 8 6GB RAM variants, and both of them had the same problem, the WiFi is fine for a while then it just hangs and nothing will load, only toggling it on and off will rectify it, but that's short-lived, I'm hoping the March security patch will fix it, but it's nearly April and I'm still waiting for it, I love my Nokia 8, and Nokia in general, but this is ridiculous, a flagship phone that can't connect to WiFi properly, and there's still not a fix for it. Ridiculous!
  • user1507208628483 user1507208628483
    ✭✭✭  / 
    Log in to the router and try disabling short gi, that is if you can find it anywhere. Some people have said this helps. If you can't find it and you have no need for mixed mode WiFi, try changing the settings to ac WiFi only.
  • Thanks for the replies..


    I couldn't find "short g" or "mixed mode WiFi" in the superhub 2 settings, however I did change the WiFi channels for both the 2.4 GHz and 5 GHz bands (2.4 GHz to 1, and 5 GHz to 102 (104). This does seem to of helped a little.


    Now I haven't had the phone get the x in the top. Android has only complained once about having no internet connection. The connection is still dropping pings every so often though, about 3 at a time then the pings continue. My WiFi signal has improved massively though going from "fair" to "good" or "Excellent" for both bands, with WiFi now showing a full bar. 



  • Gary, change 5ghz to auto performance 108-112. Did mine at 4.00 pm today been working fine alnight. Been waiting to reply but wanted to see if it worked. Getting 140 mbs no issue yet. 
  • user1507208628483 user1507208628483
    ✭✭✭  / 
    The other thing to remember with the 2.4ghz band is you can only actually use channels 1, 6 & 11 if you don't want them to overlap and clash with someone else's WiFi. To find the clearest channel you can use WiFi analyser from the play store. It's also a good idea to have the same SSID, password and security on both the 2.4ghz and 5ghz bands. This enables your devices to roam between them to get the best speeds and signal.
  • I've just changed a few settings...


    In Wireless Radio section I've set 2.4 GHz to be 300Mbps (best performance), Unchecked "Enable OBSS". 


    Greenfield mode "on"

    Channel 1+5


    5 GHz


    Upto 450 Mbps (best performance)


    Greenfield mode (on)


    Channel 108+112.


    Currently using 2.4 GHz band only 1 or 2 dropped ping now over a much longer time span.


    Haven't tried 5 GHz yet. 


    looking promising so far... Thanks for the help!


  • Quick update: WiFi still dropping pings (losing internet connection) on the phone, but doesn't seen to be as often on the 2.4 GHz band. 5 GHz band seems to be the best so far but still having little drops. 


    Hopefully the March security update will land soon, and that'll resolve the bug, as I'm sure its more software related. 



  • user389 user389
    ✭✭✭  / 

    On my phone, different network, different country, but similar lost Wi-Fi issue, it seems that turning off Wi-Fi calling helps.

    I haven't found a step-by-step way to reproduce the issue, and even if it helps here it may not help you, but maybe worth a try?


    Both of two 'known Wi-Fi' networks my phone is moving between is 2.4Ghz and the phone is on Android 8.1 with the March 2018 update.


    --
    Hans

  • Another update:

    No issues at one of my relatives house on a SuperHub 3.

    Everything set to Auto but I noticed there is different options to choose from.

    Still having dropped pings on my own connection even though I've changed settings a few times (WiFi channels etc)
  • I had a similar problem with superhub 2 and I couldn't be bothered to wait for a possible fix so i ended up getting the new superhub 3 router, which solved my problem
  • How easy is it to get the SuperHub 3 and goes it require any additional setup?

    Is it a case of ringing VM and ask them to send one out ?
  • Its easy just call them up and they will send you a superhub 3 for a small fee, you'll have to set up the new router yourself but it's literally just plug in wait for it to update itself and you are good to go
  • Does anyone think this issue is mainly down to the SuperHub 2 or a bug in Android Oreo 8.1.0 ?

    As all of my other wireless devices are not having any issues (iPhones, PC, amazon firetv sticks, and tablet running Fire OS).

    Hoping this is patched in next update when it arrives (still waiting on March security update).
  • Update:


    After some googling this afternoon on my lunch I have read that someone reported turning off NFC has fixed their issue so I am going to attempt this when I get home, not sure if it will help but I am willing to try anything at this point.

Sign In or Register to comment.