VoLTE/VoWiFi issues after upgrading to official Pie (Android 9)

Hi to Nokia community.

VoLTE/VoWiFi issues after upgrading to official Pie (Android 9)

lazarefa lazarefa
✭✭  / 
Hi to Nokia community.
3 days ago i officially upgraded my Nokia 8 device (TA1012, EU) to Android 9 Pie. 
After upgrade i noticed that VoLTE/VoWiFi has some issues/bugs. 
First of all, even if it was active on my phone since the previous OS, android 8.1 Oreo, and was properly working on my 4G+ network (Cosmote Greece), when installing Pie it didnt function initially and had to deactivate/activate function on device menu and then restart device to operate. Since then, VoLTE/VoWiFi is deactivating randomly sometimes when i explore device menus even if i dont deactivate this function. Each time  VoLTE/VoWiFi is deactivating, i have to restart/reboot device to activate it.
Second issue i found on Pie, is that when device is on airplane mode, when i activate Wifi, although   VoLTE/VoWiFi was previously active, i cannot make calls with VoWifi, although that capability was enabled with previous version of Android 8.1 on my device and was operating perfectly.
Many other Nokia 8 users in my country (Greece) who got Pie, are also facing these issues.
So, please Nokia Support bear in mind those VoLTE/VoWiFi issues and fix them on the next Nokia 8 software update.

Comments

  • potemkin potemkin
    ✭✭✭  / 
    I don't think Nokia Support reads these forums.
  • i have the same issue after the pie update. It' s just luck that i have another VoWifi enabled phone in my possession (sony xz1, cosmote firmware pie 9) so i ll stay with that phone until Nokia become again serious. I was a beta tester and i have send a message to Nokia support about the VoWifi issue too, before around 1 month. 

  • lazarefa lazarefa
    ✭✭  / 
    Lets hope that someone from Nokia team will take under consideration these VoWiFi issues and fix them on next device firmware update.
    In any case, a shame that although at least one beta tester has informed them about this bug they did nothing to fix it before official release of Pie for Nokia 8 (TA-1012).
  • user1508928527225 user1508928527225
    ✭✭✭  / 
    As an additional data point, I haven't seen issues with my TA-1004 and VoLTE or WiFi calls on Pie. My service provider is Elisa at Finland. However, considering that HMD has acknowledged similar issues at India, it does sound like some checking in advance might be a good idea if one's about to upgrade to Pie and uses VoLTE or WiFi calling.
  • Konstantinos Palialexis Konstantinos Palialexis
    ✭✭  /  edited January 31
    After a lot of research its seems like a wifi calling issue (VoWIFI) and has something to do with IMS registration status:Non registered after the update to pie (the phone was correctly IMS registered at 8.1 oreo OTA firmware). After contacting my carrier (COSMOTE, Greece) they informed me that this is a well know issue. No solution atm. Seems we have to wait more for a pie 2 update to fix this issues. 


  • singhnsk singhnsk
    ✭✭✭✭✭  / 
    All I know is that they did postpone the Pie update to Nokia 8 in India and stated the reason to be related to "VoLTE functionality". So, maybe they have overlooked that users in other regions also need VoLTE services and the service is just broken in whatever Android Pie build they have rolled out.
    I believe we will have to wait for a software update.
  • Konstantinos Palialexis Konstantinos Palialexis
    ✭✭  /  edited February 21
    At last the new update (pie v5.140 came yestarday OTA to Greece).
    I didnt complain for any bugs or properties that was missing (ex. the camera app, or addaptive battery). I only complained about the absence of the voWIFI feature (wificalling service).
    But now guess what.. after the update voWIFI still not working..
    Back to my backup device (SONY xz1 with pie voWIFI and voLTE enabled) until they fix it. 

  • At last the new update (pie v5.140 came yestarday OTA to Greece).
    I didnt complain for any bugs or properties that was missing (ex. the camera app, or addaptive battery). I only complained about the absence of the voWIFI feature (wificalling service).
    But now guess what.. after the update voWIFI still not working..
    Back to my backup device (SONY xz1 with pie voWIFI and voLTE enabled) until they fix it. 

    Adaptive battery feature is there
    So no need to complaint about that

  • At last the new update (pie v5.140 came yestarday OTA to Greece).
    I didnt complain for any bugs or properties that was missing (ex. the camera app, or addaptive battery). I only complained about the absence of the voWIFI feature (wificalling service).
    But now guess what.. after the update voWIFI still not working..
    Back to my backup device (SONY xz1 with pie voWIFI and voLTE enabled) until they fix it. 

    Adaptive battery feature is there
    So no need to complaint about that

    I said before and i repeat myself that i didnt complain about adaptive battery. Its not important for me that feature. Thanks
  • madbilly madbilly
    ✭✭✭✭✭  / 
    Anyone who has network compatibility problems like these must report them to support directly: https://www.nokia.com/phones/locale/support

    These kind of bugs should be top priority for HMD because they can potentially be symptoms of more serious bugs which affect network stability, and this would really annoy the network operators, whom HMD need to keep happy.

    So, report the bugs.
  • Konstantinos Palialexis Konstantinos Palialexis
    ✭✭  /  edited February 21
    madbilly said:
    Anyone who has network compatibility problems like these must report them to support directly: https://www.nokia.com/phones/locale/support

    These kind of bugs should be top priority for HMD because they can potentially be symptoms of more serious bugs which affect network stability, and this would really annoy the network operators, whom HMD need to keep happy.

    So, report the bugs.
    I was a beta tester (v5.110 beta) at December and i reported this issue to Nokia support. Thanks anyway. I really liked my Nokia 8 but at the moment with this bug i cant use it at all. I have really bad signal at home and at work. I hope Nokia will find the answer...
  • madbilly madbilly
    ✭✭✭✭✭  / 
    @Konstantinos Palialexis great! However, due to the way they will prioritise bugs internally, if it's not fixed after an update then we need to tell them again, otherwise they will think that it was fixed by the update (even if they didn't intend to fix it!).
  • Gnisios Gnisios
    ✭✭  / 
    Same issue here! It's unbelievable that they are not able to fix such a very important issue ASAP !!! The question should be: How they managed to destroy WiFi Calling feature ???!!! 
  • madbilly madbilly
    ✭✭✭✭✭  / 
    @Gnisios did you report it to support directly? https://www.nokia.com/phones/locale/support

  • Gnisios Gnisios
    ✭✭  / 
    Not yet. Via email? 
  • Gnisios Gnisios
    ✭✭  / 
    Gnisios said:
    Not yet. Via email? 
    Done!!! 
  • madbilly madbilly
    ✭✭✭✭✭  / 
    Gnisios said:
    Gnisios said:
    Not yet. Via email? 
    Done!!! 
    Good work :smiley:
  • Konstantinos Palialexis Konstantinos Palialexis
    ✭✭  /  edited April 18
    At last the march update came before 3 days. I did the update and then a hard reset in any case. And guess again. No voWIFI feature, no camera app and no compass fix and .... 4 months without my beloved smartphone. Thanks good work.
  • Ok with the last update 5.150 they fixed the voWIFI issue. Some reports that they fixed the compass and the Google issue too. Thanks Nokia. 
Sign In or Register to comment.