My TA-1099 is now TA-1083! warranty is no longer ok and i have problems with charge

I am in france, i bought ta-1099 on gearbest in august, warranty was ok with nokia mobile care app and now i just saw the model have changed to ta-1083 in about phone!!!

My TA-1099 is now TA-1083! warranty is no longer ok and i have problems with charge

heyoka07 heyoka07
✭✭  /  edited February 4
I am in france, i bought ta-1099 on gearbest in august, warranty was ok with nokia mobile care app and now i just saw the model have changed to ta-1083 in about phone!!! (it was before ta-1099, i have screenshots of it!) and the warranty is now not ok!!! how is it possible, are you facing this problem? any solutions? is it due to updates? i have now like a lot of people problems while charging....it stops, or discharge while charging and when its charging it is very slow and takes many hours, i bought a quickcharger but it s the same problem

Comments

  • i have a same problem and service center also not slove that problem. 
  • heyoka07 heyoka07
    ✭✭  / 
    I Found this ( "The charging port was poorly soldered at the factory") see the link below :
    https://forum.xda-developers.com/nokia-6-1-plus/help/charging-port-loose-t3875887/page2
  • singhnsk singhnsk
    ✭✭✭✭  / 
    @heyoka07 The TA-1099 is made for sale in China. And as you'd know, Nokia's warranty is not available internationally. It is only valid in the region that the device is purchased.
    Initially there was a bug in the support app which showed the warranty to be active in other regions too, but that is not the case anymore. So, for warranty, you will have to contact gearbest (if they offer any after-sales support), else visit a 3rd party repair shop and see if they can repair the device for you.
  • heyoka07 heyoka07
    ✭✭  / 
    Thanks for your answer, i didn't know warranty was only in china, it s the first phone i pay (i had nokia N8 since nov 2010 for 0 euro with my operator offer before this one) i've just contacted gearbest but i have no hope of good news in return...
  • heyoka07 heyoka07
    ✭✭  / 
    do you have an explanation concerning the change in about phone? (TA-1099 which is now TA-1083)
  • singhnsk singhnsk
    ✭✭✭✭  / 
    heyoka07 said:
    do you have an explanation concerning the change in about phone? (TA-1099 which is now TA-1083)
    Yes. Actually, the TA-1099 is supposed to run on the Chinese ROM. If you flash the Chinese ROM today, the phone will change back to TA-1099.
    It is TA-1083 now because with Android Pie update, the ROM does not recognize TA-1099. There's no mention of TA-1099 in the software. So, the device is falling back to one of the TA- variants of the global models. Don't worry about that though.

    I think Apple is the only OEM which gives international warranty, that too in some cases. For all others the warranty is only applicable in the country in which the device was actually sold.
  • heyoka07 heyoka07
    ✭✭  / 
    Ok i understand, thank you!
  • Hello, I got same problem :

    I've just received a TA-1099 labeled model from gearbest and after upgrading settings says is a TA-1083.

    The difference seems to be that the TA-1083 has NOT the B7 band (2600)

    This is the band we use in spain for 4G speed.

    Does it mean that after upgrading my phone does not support the 2600mhz band ?

    I am really worried about it

    thanks for your help !
  • singhnsk singhnsk
    ✭✭✭✭  / 
    Hello @calterras , did it already support the band 7 before the upgrade? Did you try to use 4G and it worked?
    The bands should not change with update because they are likely encoded in the CPUs read only memory. Do a fastboot oem getversions and see what it shows for the allowed bands.

    The X6 is intended for the Chinese market. And it might not support the required bands for Spain at the first place.
Sign In or Register to comment.