Restarting & power off after Android 9 upgrade

Ever since the upgrade to Android 9 last week my Nokia 8 has started randomly rebooting or powering off.

Restarting & power off after Android 9 upgrade

Robin CM Robin CM
✭✭  / 
Ever since the upgrade to Android 9 last week my Nokia 8 has started randomly rebooting or powering off.

It's never done it whilst I've been using it.
But maybe around once a day I'll take the phone out of my pocket and it'll either be off or will have rebooted and be at the post-reboot unlock screen.

Because both things it's doing are actions from the power button menu I wonder if the behaviour of this has changed from v8 to v9 and maybe random button presses in my pocket that had no effect on v8 are now causing spurious behaviour.

I just wondered if anyone else has been getting this behaviour?

Comments

  • potemkin potemkin
    ✭✭  / 
    Reset phone to factory settings. If after that phone continues randomly rebooting, it's most likely some kind of hardware failure.
  • Hugh Matthews Hugh Matthews
    ✭✭  / 
    Mine randomly rebooted a couple of times after upgrading to Pie but has not done it once since I did a factory reset.
  • jdan jdan
    ✭✭✭  / 
    If you use an sd-card, remove it to see if that is the culprit. I had to remove mine after similar behaviour and I haven't installed it again because I don' t really need it.
  • Robin CM Robin CM
    ✭✭  / 
    Interestingly, in the last few days it seems to have stopped doing it all by itself. I've not changed anything. I'll keep monitoring the situation and update this thread with any changes.

    To respond to the above though: there's no SD card, and no hint of any hardware problems before the upgrade from 8 to 9.
  • jdan jdan
    ✭✭✭  / 
    Suddenl6 my Nokia 8 was off when I took it out of my pocket on Wednesday evening. I had to try several times to restart it. I don't know why it had suddenly powered itself off. I was quite worried of course. But after reading an article on this site I hope it merely was some software bug. Fingers crossed.
  • motabahm motabahm
    ✭✭  / 
    It seems you guys have it pretty good

    I downloaded the OTA update and installed it... Phone went into boot and 4 hours later it was still stuck with a boot loop on the "android" flash screen

    Had to.get into the bootloader menu and reset the phone to factory... Lost all my data but the phone did boot up...

    Now...every few hours the phone just randomly freezes up and restarts.. . And I lose my fingerprints...when i tryyto add the fingerprints again it asks me to use different fingers.
    And sometimes it does allow me to add my fingerprints again.


    In addition to bluetooth issues... Wifi Wif 4G data comneconne loss issues..
    Apps just craah wothout warning.... 
    My phone is utterly broken now.
  • jdan jdan
    ✭✭✭  / 
    Did you do a reset like described here?
    https://www.hardreset.info/devices/nokia/nokia-8/hardreset/first-method/
    According to this site this really helps (but you lose all your data!)
    https://forum.xda-developers.com/nokia-8/help/nokia-8-stuck-boot-loop-camera-update-t3803059
  • Robin CM said:
    Interestingly, in the last few days it seems to have stopped doing it all by itself. I've not changed anything. I'll keep monitoring the situation and update this thread with any changes.

    To respond to the above though: there's no SD card, and no hint of any hardware problems before the upgrade from 8 to 9.
    My previous phone was a nexus 5x (Oreo) and it had the same issue, I just put it down to when you hold the power button down for a while it will trigger a restart (this is a feature desihdes for when your phone freezes). In regards to hardwear problems, I may be wrong about this but, there was a time when nexus 5x phones would bootloop soon after android 8 update and I think they said the update caused the hardware to fail (they just replaced the motherboard and fixed). Just thought you should be aware it is posible for software to break hardwear
  • motabahm motabahm
    ✭✭  / 
    I tried the reset

    Still acts up.... This is not a hardware problem


Sign In or Register to comment.