Nokia 6.1 no mobile service

I've got a Nokia 6.1 (TA-1043) running Android 9, On EE in the UK. I was abroad in Canada, working quite happily on the Rogers provider until last Tuesday.

Nokia 6.1 no mobile service

IanB IanB
✭✭  / 
I've got a Nokia 6.1 (TA-1043) running Android 9, On EE in the UK.
I was abroad in Canada, working quite happily on the Rogers provider until last Tuesday. The phone had an Android security update and after the restart of the phone, I've got no mobile service at all. It's still the same now I'm back in the UK.
Tried everything I can think of, but no luck. Also done 2 hard resets (restore to factory).

In the settings, If I go to the Mobile network section, it shows no networks at all and will not allow me to change from automatic to manual. If I try, it switches back to automatic and has a popup saying “No networks found”.

Using
*#*#4643#*#*  in the dialler to get into the test screen.
In Phone Information,
Voice Service shows "Radio Off"  rather than "In Service"
Mobile Radio Power toggle switch is Off
If I turn it on then go out of and back into Phone Information, its turned off again.
So, it appears to be a hardware / firmware issue, as the modem wont turn on??

Any help / suggestions on a fix would be greatly received!

Cheers!

Comments

  • IanB IanB
    ✭✭  / 
    FYI, forgot to update the forum at the time. Issue was a hardware problem. As it was still in warranty, shipped it back for repair and they replaced the system board.
Sign In or Register to comment.