Apps not receiving notifications unless I open them after feb 2019 update

After the feb update the apps on my Nokia 5.1 plus like outlook, whatsapp, hangouts Do Not get notifications unless I open them.

Apps not receiving notifications unless I open them after feb 2019 update

user1537860480422 user1537860480422
✭✭✭  / 
After the feb update the apps on my Nokia 5.1 plus like outlook, whatsapp, hangouts Do Not get notifications unless I open them. This is frustrating, Nokia pls resolve this asap. 

Comments

  • wyk wyk
    ✭✭✭✭  / 
    check notification settings from digital wellbeing of those apps. all toggles should be ticked as per your preference. If doesn't work clear cache of them. 
  • user1537860480422 user1537860480422
    ✭✭✭  / 
    @wyk thanks for the comment but you did see i wrote after feb update right? Do you mean the update changed my notification preferences after the update? That couldn't be possible right? I would suggest reading the question 2 times before commenting, no hard feelings  :)
  • RiazJS RiazJS
    ✭✭  / 
    Same issue here. It's because of adaptive battery settings
  • wyk wyk
    ✭✭✭✭  / 
    @wyk thanks for the comment but you did see i wrote after feb update right? Do you mean the update changed my notification preferences after the update? That couldn't be possible right? I would suggest reading the question 2 times before commenting, no hard feelings  :)
    Thanks for the suggestion.... :)  ..for your kind information ...I have read very clearly ..& suggested you to do that to be sure; ..notification settings shouldn't have changed but may be factor differs as android apps get optimized after every update ...sometimes clearing cache or uninstalling & reinstalling solves.
  • user1537860480422 user1537860480422
    ✭✭✭  / 
    Go to settings - > apps and notification - >  special app access - > battery optimization - >  all apps from thebdropdown above and then from the list below select the apps which you need to keep in ram like whatsapp and other. A pop up will appear selct don't optimize.  Worked for me 
  • Jannis Jannis
    ✭✭✭  /  edited February 22
    Go to settings - > apps and notification - >  special app access - > battery optimization - >  all apps from thebdropdown above and then from the list below select the apps which you need to keep in ram like whatsapp and other. A pop up will appear selct don't optimize.  Worked for me 
    Is that enough, or do you have to disable "adaptive battery" too?
  • user1537860480422 user1537860480422
    ✭✭✭  / 
    Jannis said:
    Go to settings - > apps and notification - >  special app access - > battery optimization - >  all apps from thebdropdown above and then from the list below select the apps which you need to keep in ram like whatsapp and other. A pop up will appear selct don't optimize.  Worked for me 
    Is that enough, or do you have to disable "adaptive battery" too?
    No it does not work, it worked for me for 1 day and then reverted back to not working  Nokia is bullshit, the phone was working fine for there was no need to give a new update 
  • Jannis said:
    Go to settings - > apps and notification - >  special app access - > battery optimization - >  all apps from thebdropdown above and then from the list below select the apps which you need to keep in ram like whatsapp and other. A pop up will appear selct don't optimize.  Worked for me 
    Is that enough, or do you have to disable "adaptive battery" too?
    No it does not work, it worked for me for 1 day and then reverted back to not working  Nokia is bullshit, the phone was working fine for there was no need to give a new update 
    Match my experience that the background apps still be killed even I disabled the "adaptive battery". But I decide to give "adaptive battery" a chance that turn it on more days to see if it can get optimized.
  • user1537860480422 user1537860480422
    ✭✭✭  / 
    how many users are facing this problem does any one know?
  • Yes me tooo facing this same issue

  • user1537860480422 user1537860480422
    ✭✭✭  / 
    Uninstalking and installing back whatsapp solved my problem with whatsapp but my mail behaves as before  
  • user1537860480422 user1537860480422
    ✭✭✭  / 
    Uninstalking and installing back whatsapp solved my problem with whatsapp but my mail behaves as before  
    Ok this is not working, today my whatsapp got disabled.. Does anyone else got any work around this issue ? 
  • user1537860480422 user1537860480422
    ✭✭✭  / 
    I've tried the nuclear option now. I've factory resetted my phone and installed all the apps again. Will update after 2 - 3 days if this thing works. Wish me luck 
  • user1537860480422 user1537860480422
    ✭✭✭  / 
    I've tried the nuclear option now. I've factory resetted my phone and installed all the apps again. Will update after 2 - 3 days if this thing works. Wish me luck 
    Ok after factory resetting also I'm not getting notifications unless i open apps. I hate Nokia. Do we even know if Nokia knows about this problem and is working in on  ? it??? 
  • sobinone sobinone
    ✭✭  / 
    hi every one .. new battery optimisation   will force close all back ground apps  after feb update...
     i hav a solution for that
    goto - setting- apps and notification--see all apps.. click on 3 dots on top rit corner click -show system- then scrol down and find power saver.. and force to stop it..then ur prblm wil solve. it wil work until ur next reboot
  • sobinone sobinone
    ✭✭  / 
    After the feb update the apps on my Nokia 5.1 plus like outlook, whatsapp, hangouts Do Not get notifications unless I open them. This is frustrating, Nokia pls resolve this asap. 
    if ur phone screen turn off  20 mnts above  batery optimisation wil close ur background  working apps... here is a solution ... go to setting then apps and notification then see all apps, then click d 3 dots on top rit side corner. click on  show system. then find power saver app.. then force to stop it.... now ur all backgroud apps wrks fine until ur nest reboot of ur phone.
  • sobinone sobinone
    ✭✭  / 
    Yes me tooo facing this same issue

    if ur phone screen turn off  20 mnts above  batery optimisation wil close ur background  working apps... here is a solution ... go to setting then apps and notification then see all apps, then click d 3 dots on top rit side corner. click on  show system. then find power saver app.. then force to stop it.... now ur all backgroud apps wrks fine until ur nest reboot of ur phone.
  • user1537860480422 user1537860480422
    ✭✭✭  / 
    sobinone said:
    Yes me tooo facing this same issue

    if ur phone screen turn off  20 mnts above  batery optimisation wil close ur background  working apps... here is a solution ... go to setting then apps and notification then see all apps, then click d 3 dots on top rit side corner. click on  show system. then find power saver app.. then force to stop it.... now ur all backgroud apps wrks fine until ur nest reboot of ur phone.
    Have u I u tried this thing yourselves I have tried and this does not work 
  • Bogomips said:
    Jannis said:
    Go to settings - > apps and notification - >  special app access - > battery optimization - >  all apps from thebdropdown above and then from the list below select the apps which you need to keep in ram like whatsapp and other. A pop up will appear selct don't optimize.  Worked for me 
    Is that enough, or do you have to disable "adaptive battery" too?
    No it does not work, it worked for me for 1 day and then reverted back to not working  Nokia is bullshit, the phone was working fine for there was no need to give a new update 
    Match my experience that the background apps still be killed even I disabled the "adaptive battery". But I decide to give "adaptive battery" a chance that turn it on more days to see if it can get optimized.
    After using "adaptive battery" many days, my instant message app and email app work fine. I can receive notification messages. The battery drain situation become okay or better as before.
  • Volte not working properly after Feb 2 update 
  • user1537860480422 user1537860480422
    ✭✭✭  / 
    I've changed the launcher to nova, just a stupid idea to check whether it will solve the issue  Will keep you guys posted 
  • I live in Pakistan and I bought today Nokia 5.1. Android's update should I update Android pie because I've heard the battery drain too fast.After update android from Oreo to Pie

  • Bogomips said:
    Bogomips said:
    Match my experience that the background apps still be killed even I disabled the "adaptive battery". But I decide to give "adaptive battery" a chance that turn it on more days to see if it can get optimized.
    After using "adaptive battery" many days, my instant message app and email app work fine. I can receive notification messages. The battery drain situation become okay or better as before.
    Bad news. More days passed, my email apps be killed and cannot receive new mails and notifications on the background. :'(
  • user1537860480422 user1537860480422
    ✭✭✭  / 
    When will  be the next update coming ? 
  • user1537860480422 user1537860480422
    ✭✭✭  / 
    When will  be the next update coming ? 
    I think in April, as Nokia gives security update every 2 months. Hope it solves this Android pie update issue soon rather than  later
  • The Neeraj The Neeraj
    ✭✭  / 
    has anyone found a solution for this issue???...all apps are closing in background fed-up of this.
Sign In or Register to comment.