Apps closing themselves in the background

After February Update, apps such as Chrome, Twitter or any other app, are refreshing themselves automatically after they are put in the background.

Apps closing themselves in the background

After February Update, apps such as Chrome, Twitter or any other app, are refreshing themselves automatically after they are put in the background. If I am using Chrome then switch to other app and use it for a while then go back again to Chrome, it starts again and the page which I was surfing will refresh. This has happened many times and sometimes I lost importance transactions due to this. 

Does anybody else face this issue?

Comments

  • yes  i  am  also  having problem  with whatsapp  
  • after  recent  update  it's  not  working
  • user1537860480422 user1537860480422
    ✭✭✭  / 
    Go to settings - > apps and notification - >  special app access - > battery optimization - >  all apps from thebdropdown above and then from the list below select the apps which you need to keep in ram like whatsapp and other. A pop up will appear selct don't optimize.  Also try disabling adaptive battery if it is on in settings-- battery - adaptive battery 
  • > @user1537860480422 said:
    > Go to settings - > apps and notification - >  special app access - > battery optimization - >  all apps from thebdropdown above and then from the list below select the apps which you need to keep in ram like whatsapp and other. A pop up will appear selct don't optimize.  Also try disabling adaptive battery if it is on in settings-- battery - adaptive battery 

    Can I have a question that the adaptive battery claims it can learn the user usages about the apps, and how long it(adaptive battery) will take to learn and have a obvious optimization ?
  • yuvaraj2305 yuvaraj2305
    ✭✭  / 
    Internet speed meter , mifit which rins in background never gets close in other devices but in Nokia 5.1 plus it closes automatically.
    yeah bro  me too face that issue i have been using mi band 3 and mi fit app since oreo but after pie its terrible band disconnects and mifit closes 
  • legendjabir legendjabir
    ✭✭  / 
    Go to settings - > apps and notification - >  special app access - > battery optimization - >  all apps from thebdropdown above and then from the list below select the apps which you need to keep in ram like whatsapp and other. A pop up will appear selct don't optimize.  Also try disabling adaptive battery if it is on in settings-- battery - adaptive battery 
    I try these options many times but not working
  • Jannis Jannis
    ✭✭✭  /  edited February 23
    Bogomips said:


    Can I have a question that the adaptive battery claims it can learn the user usages about the apps, and how long it(adaptive battery) will take to learn and have a obvious optimization ?
    Forget that. Google claims it's AI, but it just closes apps which uses much battery. It's actually embarrasing for all the phone producers (not just Nokia), that they simply don't invest in new battery technologies, instead waste resources in some stupid things like "adaptive battery". Really, for what do you need a smartphone, if you even don't get simple notifications from apps because Android 9 is closing them? You even can't use a smart watch or fitness tracker, because the app is constantly closing. In that case it's maybe better just to buy a feature phone for some 20 dollars.
  • nitin kachare nitin kachare
    ✭✭✭✭  /  edited February 23
    You have to set your favourite application battery setting as not optimized and not restricted in adaptive battery then it will work in background all the time 24 hours which consume battery.Mine is working i.e.trucaller,call recording,applock,etc.
    if you have bluetooth device then set Bluetooth i.e.System App battery Optimization settings as not optimized.if you want to work all of them then disable adaptive battery.
  • sobinone sobinone
    ✭✭  / 
    i tried but not working.. back ground apps closing..
  • abbott xie abbott xie
    ✭✭  / 
    Me too, I hope Nokia can solve it as soon as possible.
  • Jannis Jannis
    ✭✭✭  /  edited February 23
    I really doubt that Nokia is interested in solving this problem. This problem exists now already with so many Nokia phones for over a year. Just read this page for more information: https://dontkillmyapp.com/ . Of course Google is not innocent, as with every new Android version, the problem of closed apps is getting worse.
    I think Nokia rather fears users will complain about the battery without this closing-apps software. Once again, as long phone producers don't invest in new battery technologies, nothing will change. And the other "solution" to produce batteries with 4000 or 5000 mAh capacity is also not a good one.
  • nitin kachare nitin kachare
    ✭✭✭✭  / 

    Check Here Everyone...
  • user1537860480422 user1537860480422
    ✭✭✭  / 

    Check Here Everyone...
    And what should i check here ? 
  • nitin kachare nitin kachare
    ✭✭✭✭  /  edited February 27

    Check Here Everyone...
    And what should i check here ? 
    check its active time in background.call recording running in background from 15 hours 51 minutes not closed by adaptive battery.Someone says that none of application work in background.So I decide to show my priority application is working in background without any issues.
  • sobinone sobinone
    ✭✭  /  edited February 27
    hi nithin.. if ur phone screen turn off  20 mnts above  batery optimisation wil close ur background  working apps... here is a solution ... go to setting then apps and notification then see all apps, then click d 3 dots on top rit side corner. click on  show system. then find power saver app.. then force to stop it.... now ur all backgroud apps wrks fine until ur nest reboot of ur phone.
  • nitin kachare nitin kachare
    ✭✭✭✭  / 
    sobinone said:
    hi nithin.. if ur phone screen turn off  20 mnts above  batery optimisation wil close ur background  working apps... here is a solution ... go to setting then apps and notification then see all apps, then click d 3 dots on top rit side corner. click on  show system. then find power saver app.. then force to stop it.... now ur all backgroud apps wrks fine until ur nest reboot of ur phone.
    I have set it 30 Seconds time for screen turn off.All of my application which are important running in background.
  • I am really fed up... I updated my OS as sent, now every time I minimize my apps, it automatically closes it on its own and it's still shows in the multitasking section as a minimised app. And my fiverr app needs to be online all the time. This update is destroying my means of income. This is terrible

  • twomm twomm
    ✭✭  / 
    Hi,

    I can only recommend https://dontkillmyapp.com/nokia , too.
    With that evenwell powersaver running, apps are killed, regardless of any other settings that might have been made in Android settings places.

    So Nokia/HMD, what about your "pure" Android? All these evenwell apps mess up a lot of things.
  • Ambarish Ghosh Ambarish Ghosh
    ✭✭  /  edited May 12
    Guys, Got a fully functional solution to this issue. Found it on dontkillmyapp/nokia.
    No need for disabling adaptive battery or disabling optimisation. This is can be fixed with the  adb commands.

    Get it at https://dontkillmyapp.com/nokia

  • Rajeel Rajeel
    ✭✭  / 
    Issue resolved:


    Fix for app killing problem

    Before you begin-




    (((((1. Make sure you have all adb/usb Vcom drivers installed before you start otherwise your phone won't be detected

    2. Open the folder where you have adb drivers and do a right click and press shift key with it and click on open command window here.
     Enable usb debugging in your device Then connect your phone to pc  and run command " adb devices " to make sure that your phone is connected))))))

    _Then run the commands given below to fix app killing _

    solution 1

    Command 1
    adb shell
    pm disable-user com.evenwell.powersaving.g3

    Command 2
    adb shell settings put global setting.duraspeed.enabled 0


    Note - if you reboot your device then you have to run commands given below everytime you reboot
     
    Command 3
    adb shell settings put global setting.duraspeed.enabled 1

    Command 4
    adb shell settings put global setting.duraspeed.enabled 0




    solution 2 (after doing this you dont need to run the above commands after every boot.)



    Feel free to post any doubts..

    Thank me later.
  • himanshus211 himanshus211
    ✭✭  / 
    The above adv comman works like a charm..thank you so much everyone.
    (All notification including Truecaller, WhatsApp,mi fit etc are being duly received)
    But two new issues creep in...battery drianage it became worst and when switching b/w apps it is not able to hold the page/app even for one second.
    Kindly help!
Sign In or Register to comment.