Unable to switch sim to be used for phone calls

On Nokia 8 (probably same on other models too) if you go to    Settings / Network and Internet / SIM-Cards, you can choose which SIM to be used for

Unable to switch sim to be used for phone calls

System System
 /  edited June 18

On Nokia 8 (probably same on other models too) if you go to    Settings / Network and Internet / SIM-Cards, you can choose which SIM to be used for


Mobile Data

Phone Calls

Text messages



Well, you used to be able to do that before Anrdoid Oreo 8.1 update.

It basically gave a choice between SIM 1 and SIM 2.


Now after Android Oreo 8.1 it gives me choices "DNA" and "Telia", i.e. how I have named the sim cards.


And it allows me to choose between them for Text messages  & Mobile Data.

For phone calls it allows to choices ASK ALWAYS / DNA / TELIA  but it always stays on the DNA on my case.


This bug came on Oreo 8.1 and I have verified the issue with another Nokia 8 owned by somebody else.


Swithing physical location of SIMS does not change situation. It is stuck onto the "sim" I had chosen default before upgrade.


If I turn off the "DNA sim" then phone calls will be done using the other remaining sim.

And there are number of other ways to make phone calls using the other sim also so I am not totally burned because of this bug.


I have tried rebooting, soft reset, not hard reset though. Note that I have verified this issue on another NOKIA 8 having the latest Oreo 8.1 also.


_veli


Comments

  • Same problem here...
  • AlexKay AlexKay
    ✭✭  / 
    Same here. Looks like a bug which came with Pro camera update. There are 2 workarounds: 1) go to contacts app and choose a SIM for every single number one by one 2) use Qualcomm SIM settings activity dialog instead of buggy Nokia dialog: com.qualcomm.qti.simsettiings.SimSettingActivity.
  • pasoderb pasoderb
     /  edited June 19
    I have the same problem, but it can be changed in the Phone app under settings and call account.
  • user1529139627007 user1529139627007
     /  edited July 10

    "I have the same problem, but it can be changed in the Phone app under settings and call account."

    Can you please elaborate a bit? Unable to do so... Would be grateful for your help.

  • Unknown
     /  edited July 7

     It works for me. go to the PHONE CALLS APP, then SETTINGS, then CALL ACCOUNTS. It is kind of weird use interface but just touch "Phone Calls" or what ever it is in English  and change the setting. Works for me fine


    _veli

  • Thanks user1529133098201 for accurately describing the problem and user1508924578314 for providing a solution. Hopefully a future update will make it good again.

Sign In or Register to comment.