Quick charge not working after manual rollback

I was on the 8.1 May Patch with my Nokia 7 Plus, Quick charge was working fine then. Then I enrolled in the P beta, quick charge worked there as well.

Quick charge not working after manual rollback

user1525809453378 user1525809453378
 /  edited June 19

I was on the 8.1 May Patch with my Nokia 7 Plus, Quick charge was working fine then. Then I enrolled in the P beta, quick charge worked there as well. Then they messed up the timestamp on the patches so my P beta got corrupted, I wasn't aware of the solution then (deleting Google Play Service cache) so I factory reset my phone, now I am on 8.1 June Patch and Quick charge doesn't seem to be working with the charger they provided, whenever I plug it in it shows "Charging rapidly" for a brief then goes back to charging and sometimes it doesn't show at all. My experience with it is that it's not a visual bug, it's actually charging slowly.


Is this affecting all devices on the newest patch or is this some other bug? What can I do to resolve this as Quick Charging is fairly important to me?


About the phone:

TA-1046

Version: 8.1.0 (June 1, 2018 security patch)

Kernel: 4.4.78-perf+ (2018 Jun 1 18:32:11)

Build number: 00WW_2_22A_SP01

Comments

  • I figured it out, since an update to the 8.1 branch Quick Charge will only work as long as the screen is turned off. This didn't apply to the P beta branch.


    The reasoning being to avoid harming the user when using the device while charging, I don't know if it's very effective cause the device will still stay warm long after you first turn on the screen, but whatever.

Sign In or Register to comment.