Nokia 6.1 looses 4G Data and Call function on turning off data. APN Settings auto deleting.

Hello everyone, I am new to this forum. I purchased the Nokia 6.1 a couple of days ago. I am happy with it except for one problem.

Nokia 6.1 looses 4G Data and Call function on turning off data. APN Settings auto deleting.

droidone droidone
 / 

Hello everyone, I am new to this forum. I purchased the Nokia 6.1 a couple of days ago. I am happy with it except for one problem. Okay, so this post is gonna be a bit long because I want to mention the necessary details incase it helps to solve the issue better. I'll divide the post in parts to make it more readable.


The Problem:

I have 2 SIM Cards, one is by JIO and another by TATA DOCOMO. I use the JIO SIM as prefered SIM for Data, Calling and SMS. When I put the JIO SIM in SIM Slot 1 and start the phone, it works uptil I turn off Data. Once I turn off Data and let the phone sit for a few mins, the next time I turn on Data the phone doesn't latch onto 4G connection and I don't get internet connection. Also, I cannot place any calls via the same SIM. When I try to place a call, I get a popup saying "Mobile network not available". Although I can receive calls for some reason.


Possible cause:

While trying to find the cause of the issue I found out that when the problem occurs, the APN settings are automatically deleted from settings. If I try to manually add APN Profile with the correct values and try to save it, the profile doesn't get saved at all. Also, resetting the APN does nothing.


What I have tried so far:

I tried resetting the network but the problem persists.


Just to be sure, I check whether the phone supports the Frequency Bands required by my Carrier JIO. And yes, it does. JIO works on Band 3, 5 and 40 and the phone supports these bands.


I contacted the Nokia customer service as well. They asked me to follow some steps to verify Network Settings which I had already checked. And asked me to factory reset, which I have done now and it didn't fix anything. They also asked me to contact the network operator, citing that they will help me better. So I went and got a replacement SIM from my Carrier today and the same problem occurs with this new SIM.


Furthermore, I tried my friend's Idea 4G SIM in SIM Slot 1. After turning off Data and letting the phone sit for a while, the phone couldn't latch onto 4G. At least now I guess we can conclude that the problem is not with the carrier.


Temporary Solutions:

1. Restarting the phone.


2. Deactivate the SIM via Settings>Network & Internet>SIM Cards. This revives the Data and Calling capability and restores the necessary APN settings. But its such a hassle to do this every time it happens.


These 2 solutions fix it only until I turn off Data again. And then the problem returns.


3.Surprisingly when I put the JIO SIM in SIM Slot 2, it worked flawlessly for a day of testing. I tried to replicate the bug multiple times but couldn't with SIM Slot 2. Now this kind of is a semi-permanent fix. But I don't wanna settle for it considering that Mobile Networks in India are moving onto 4G VOLTE service. And very soon I might have to use 4G VOLTE enabled SIM Cards without 2G/3G support like JIO in both my SIM Slots.



I would be so grateful to any ADMIN or Moderator who forwards this issue to the Developers. If there is a solution to this issue please help me out here. If there is anyone facing the same issue then please post here and let us all know.


My network settings:

Under Settings>Network & Internet>Mobile Network, my network setting for the JIO SIM are set to:

-Enhanced 4G LTE Mode- Enabled.

-Preferred network type- 4G

-Automatically select network- Enabled (I did try with this setting disabled and selecting JIO manually but that didn't solve it)

-Access point names (APN)- Had all the default settings from JIO.

Comments

  • user1531124044468 user1531124044468
     /  edited October 17

     the same problem i am facing now, unable to trace the solution and disappointed very much

  • droidone droidone
     / 

    Which SIM cards are you using? Also, are you on 4G and 3G for SIM 1 and 2 respectively like me?

  • Endeavor Endeavor
     / 
    Woah. I'm facing the same issue too. I have Vodafone in SIM SLOT 1, and it's the exact same issue in my Nokia 7 Plus. Haven't tried in SIM SLOT 2 yet. But if you find a solution please reply me.
  • droidone droidone
     /  edited July 18

    If I find a solution I will post it here for sure. Considering that it is not just limited to Nokia 6.1, it might be a common bug in Nokia Android One ROMs. I am just hoping its not a hardware issue.


    BTW I tried a couple other SIMs in place of the Tata Docomo SIM, while keeping the Jio SIM in SIM slot 1 and didn't face the issue. So, it might be carrier related, or might have something to do with UMTS Network the SIM uses, or the combination of UMTS and 4G between the two SIMs.

  • I am having the same problem, no network, sim slots are not working, every possible method have been used, bad experience with Nokia 6.1 plus.
Sign In or Register to comment.