After updated to android Pie, APPs are killed in background

After i update to android 9, i found my 3.1plus kills all the apps which should run in background.

After updated to android Pie, APPs are killed in background

Ken Ching Ken Ching
 /  edited April 14
After i update to android 9, i found my 3.1plus kills all the apps which should run in background.

So i followed the website, and go for adb uninstall the com.evenwell.powersaving.g3. it may helps the apps last longer, but not at all. Background Apps still get killed when ram usage going high. Then i clean nearly all the evenwell packages but situation has no change.

Did anyone get solutions for this?

Btw, i found nokia trys to kill me. 3.1plus close the hiking trail alert apps in background last week. I may get lost in jungle for that. Im not going to forgive nokia anyway.

Best Answers

  • Ken Ching Ken Ching
     /  Accepted Answer
    There is a post said nokia3.1(not plus) can turn off the task killer with command adb shell settings put global setting.duraspeed.enabled 0.

    I clean the cache of settings app and reboot with vol+ and power button. Im testing it with heavy loads. Hope that will works.
  • Ken Ching Ken Ching
     /  Accepted Answer
    I think it is okay for this solution. I tried different games and video player, and no background apps was killed. Reminds that there is no response like success or fail words when enter this command at adb.
  • Ken Ching Ken Ching
     /  Accepted Answer
    New Edit: A customer service told me to turn on "Unrestricted Data Usage" at apps info>app data usage. It notice for data saver, but it actually affect power saver. Now, I had run the apps for a hour normally. But i used the adb command before. Hope someone try this option and replys the results here. Thank you.

Answers

  • Swapnil Raj Swapnil Raj
    ✭✭✭  /  edited April 14
    @""Ken Ching"
     Go to RAM management and see the amount of free RAM and see which apps are using more RAM.

    Enable developer options.
    Scroll down to Apps.
    Disable the option " Don't Keep Activities " Also Check the "Background Process limit" and "Background Check"

    If that doesn't help make sure battery saver is turned off.
    Next make sure you haven't installed any 3rd party app killer, ram cleaner or storage cleaner.

    If you don't find any success then don't try to uninstall system apps starting with com.xxxx.****.
    Rather try restarting the phone or perform a hard reset.
    If it doesn't help then go to service center..

    Remember that such an issue hasn't been found with anybody else so it is an exclusive problem with you.
  • geauxnutz geauxnutz
     /  edited April 15
    @""Ken Ching"
     Go to RAM management and see the amount of free RAM and see which apps are using more RAM.

    Enable developer options.
    Scroll down to Apps.
    Disable the option " Don't Keep Activities " Also Check the "Background Process limit" and "Background Check"

    If that doesn't help make sure battery saver is turned off.
    Next make sure you haven't installed any 3rd party app killer, ram cleaner or storage cleaner.

    If you don't find any success then don't try to uninstall system apps starting with com.xxxx.****.
    Rather try restarting the phone or perform a hard reset.
    If it doesn't help then go to service center..

    Remember that such an issue hasn't been found with anybody else so it is an exclusive problem with you.
    I have same problem on my 6.1 after the March Update,
  • @""Ken Ching"
     Go to RAM management and see the amount of free RAM and see which apps are using more RAM.

    Enable developer options.
    Scroll down to Apps.
    Disable the option " Don't Keep Activities " Also Check the "Background Process limit" and "Background Check"

    If that doesn't help make sure battery saver is turned off.
    Next make sure you haven't installed any 3rd party app killer, ram cleaner or storage cleaner.

    If you don't find any success then don't try to uninstall system apps starting with com.xxxx.****.
    Rather try restarting the phone or perform a hard reset.
    If it doesn't help then go to service center..

    Remember that such an issue hasn't been found with anybody else so it is an exclusive problem with you.
    Thanks for your reply.

    For this problem, i had factory reset my 3.1plus. Because i had already bother online customer service operators for a week and have no change.

    In last week, i tried battery not optimised/ optimised with no restriction. And check the options as you said.

    After factory reset, I did not install any apps but what i want to use in background which is whatsapp, mi fit, a ad call blocker, this 3 apps. And found they were killed as before.

    Im so sorry to hear about the next reply that means im not alone. And i found the Background check option does not showing the whatsapp / mi fit / ad call blocker on the list, that may be the reason. They never join the background apps group, but how?
  • I just bought 3.1 plus with Android Pie.
    Need a kind of white listing. Already try
    1. Not optimized
    2. Unrestricted data.
    3. Standby apps as Active
    But still background app killed.
    Any other suggestion? Like allow auto start
  • Loces Loces
    ✭✭  / 
    Yep same prob after update to Pie, I always need to enter apps every 30-40mins to make sure that I will get notifications if someone text me and sometimes even that doesnt help. Which is kinda sad thats the most normal and regular action even **** devices can do it with less ram lol
  • Khanahad Khanahad
    ✭✭  / 
    Same problem bro..
  • Same problem for me.
    keeping the ambient display on for new notifications only helped a little but it drains battery much faster and if i didn't receive any notifications for more than an hour the problem is back.
    More over when i turn off mobile data or WIFI over night, when i turn it back on in the morning apps are not aware that the internet connection is back, I have to open apps such as whatsapp, messenger, ...etc manually to receive messages.
    The option " Don't Keep Activities " is disabled, while  "Background Process limit" max apps allowed are only 4.
    my partner has a galaxy A70 with android pie, she has much more background apps running and no such problem.

  • SauliusG SauliusG
     / 
    The problem is due to a lack of free RAM.
    There are only two way to solve problem:
    1. Settings -> Device care -> Battery -> Settings -> Sleeping apps -> Add -> here you need to mark as many applications as you don't need in the background -> Add -> Restart phone
    (This is a menu from my phone. I hope Android 9 Pie menu is the same everywhere.)
    or
    2. Buy a new phone with more RAM.
    There is no other way.
  • muneebqadar muneebqadar
     / 
    Every Nokia smart mobile user got stuck when they upgrade their mobiles to Android Pie. The background apps are not working properly, it seems weird for everyone. Nokia should hire expert mobile app developers to get it to fix ASAP.
    Thanks and Regards,
    Muneeb Qadar - Branex - https://www.branex.co.uk/mobile-app-development/
Sign In or Register to comment.