Charging problems with Nokia 8

Hey guys, i am using Nokia 8 with the battery adapter model AD-18WE which support QC3.0 but the charging time is very long.

Charging problems with Nokia 8

Khuê Tạ Khuê Tạ
 /  edited April 2019
Hey guys, i am using Nokia 8 with the battery adapter model AD-18WE which support QC3.0 but the charging time is very long. In 30 minutes ít only goes from 20% to 40%. And it takes almost 2 hours to reach 100% from 20%, i think it's not right for the 3090mAH capacity. My friend's Nokia 8.1 has 3500mAh battery but only takes 1h30 to get a full charge. Is there anything wrong with my nokia? Does it lose the ability to fast charge guys? My Nokia is updated to Pie now

Answers

  • MrBelter MrBelter
    ✭✭✭✭  / 
    About 2 hours from 20% to 100% doesn't sound that bad to be honest, the fast bit of the charge for QC is around the first 50% and then it starts to slow down to normal speeds.

    That said my Nokia 8.1 also charges faster then my Nokia 8 unless you have the screen on and then it only charges at 1amp and takes a dogs age, my Nokia 8 doesn't drop anywhere near as far so i do wonder if one is QC3.0 and one is QC4.0 because they exhibit very different behaviours when the screen is on.
  • Khuê Tạ Khuê Tạ
     /  edited April 2019
    mrbelter said:
    About 2 hours from 20% to 100% doesn't sound that bad to be honest, the fast bit of the charge for QC is around the first 50% and then it starts to slow down to normal speeds.

    That said my Nokia 8.1 also charges faster then my Nokia 8 unless you have the screen on and then it only charges at 1amp and takes a dogs age, my Nokia 8 doesn't drop anywhere near as far so i do wonder if one is QC3.0 and one is QC4.0 because they exhibit very different behaviours when the screen is on.
    While charging, when I tap the screen to let it on, it only shows that :" charging" not "fast charging". Is it normal too?
  • MrBelter MrBelter
    ✭✭✭✭  / 
    I suppose it depends where about it is in the charging cycle. Have you cleaned the charging port out and tried a different lead etc?
  • mrbelter said:
    I suppose it depends where about it is in the charging cycle. Have you cleaned the charging port out and tried a different lead etc?
    Yes, i have done it. But the situation doesn't seem to improve. My phone also run out of the warranty so I just don't know exactly what's wtohw with it
  • MrBelter MrBelter
    ✭✭✭✭  / 
    Nowt you can do i guess mate. If you let it go flat and charge it up and if it hits 45 to 55% in 30 minutes though it is working fine.
  • mrbelter said:
    Nowt you can do i guess mate. If you let it go flat and charge it up and if it hits 45 to 55% in 30 minutes though it is working fine.
    I just did it bro, from 7% to 30% in 30 min. And what should I do now?
  • arjun.dhir arjun.dhir
    ✭✭  / 
    Could be signs of a failing battery. Try playing a heavy game on full brightness at low battery, about 5-10%, or recording 4k video at full brightness for few minutes. If the phone restarts, then definitely the battery. If not, then try cleaning the port or checking the phone temperature while charging. If it is high then charging would be slow.
Sign In or Register to comment.