Can't disable mobile data in Roaming after update to Pie

I have problem with mobile data while in roaming - it can be disabled completely.

Can't disable mobile data in Roaming after update to Pie

valyo_bg valyo_bg
✭✭  / 
I have problem with mobile data while in roaming - it can be disabled completely. Mobile data is stopped directly from icon and "when in roaming - OFF" is choose. I can't surf in Internet via browser or Messengers, but still my phone consume randomly 10-20kb of data from time to time and this cost big expenses in foreign countries. I check with mobile provider in my country Bulgaria and they show me that my phone do more than 20 times connection to the internet for 1-2 seconds per 24 hours during my business trip even at night. For 5 days trip my phone download 400KB, but my provider A1 charge me 50 Euro for this.

Only way to avoid this is to use "Airplane mode" or to delete completely all APNs. Same problems I see on other forums, so seems that problem is not only on my phone.

With Android 8 everything works perfectly, I never had such problem with mobile data consuming when mobile data is stopped when in roaming. 

This problem happen after update to Android 9 Pie.

I can't find which process do this when mobile data is disabled, but suspect that this is Google process that work in background and have permissions to enable data connection even when mobile data is OFF (disabled).

My phone is Nokia 8 Sirocco with Android 9 Pie.

Comments

  • San.Phu San.Phu
    ✭✭✭  / 
    This is really not good. Hmd should solve this type of issue as soon as possible. 
  • I have same issue with both Android 8 and Android 9 with Sirocco from start of usage. Everytime while in roaming I have to choose fake APN and switch mobile data to 2G.
  • cquence cquence
    ✭✭  / 

    I have the same problem with the update to Android 10.(Nokia 9) I had mobile data turned off and roaming off and my data connection worked as usual...

  • valyo_bg valyo_bg
    ✭✭  / 

    Disable LTE while in roaming (choose 3G instead) and then disable mobile data. This should stop mobile data completely.

  • colin4 colin4
    ✭✭  / 

    I have the same problem with my Android 10 phone. I've set it to 2G (in Japan, which retired its 2G network) to avoid data charges.

    1. where do I find the "disable LTE" option?
    2. is there still a "data roaming" option (separate from the "mobile data" an "roaming" options, which I've already disabled)?
    3. does using 3G (with disabled LTE) ensure that I won't be further charged?
  • valyo_bg valyo_bg
    ✭✭  / 

    If you set to 2G then no problem - this mean that you already disable LTE/4G. With 2G and 3G you can completely disable data in roaming.

Sign In or Register to comment.