Does anyone have this camera issue when trying to record a video?

When trying to record a video I'm getting this message every time.

Does anyone have this camera issue when trying to record a video?

ste260989 ste260989
✭✭  / 
When trying to record a video I'm getting this message every time.
I've cleared out the cache and data for the camera app and removed all apps that use the camera and it still does it. 
I've started to phone in safe mode and had no issues with it then. Does anyone have this issue/ have a fix for it?

Answers

  • petrus petrus
    ✭✭✭✭  / 
    Hi, are you using another camera app too?  I had a similar problem with one Gcam.  I had to uninstall it and then in the HDM camera application, I had reset the settings and restarted the phone.
  • ste260989 ste260989
    ✭✭  / 
    Hi, no I'm just using the one that's on the phone. I've reset the settings and restarted the phone and still have the issue a few minutes after its back on again.
  • user389 user389
    ✭✭✭✭  / 
    A defective SD memory card, maybe?
  • ste260989 ste260989
    ✭✭  / 
    There's no SD card in it. Could it worth trying one and setting it as the default storage to see if this helps?
  • user389 user389
    ✭✭✭✭  / 
    No, that was just a wild guess, it must work when saving to phone memory.
    Instead, please try:
    Long press the camera icon
    Tap (i) app info pop-up
    Tap Force stop
    Select Storage
    Tap Clear cache
    Tap Clear storage
    Do a soft reset by press and hold the volume-up and power button until the phone restarts and the Nokia logo is displayed on the screen (~10 seconds).
    Start the camera, accept the prompt regarding location access, and check it works before making any adjustments to your preferences?
    I take it the phone is fully updated, and the HMD camera app you use is the official one that is built in.
  • ste260989 ste260989
    ✭✭  / 
    I've just tried this and it works fine after the phone loads up. Once you've been into another app and go back to it the same issue starts again.
    The phone is up to date and the camera app is the one that comes as standard with the phone
  • user389 user389
    ✭✭✭✭  /  edited June 2019
    I'm puzzled why it works in safe mode but fails otherwise. - Only you know what is or was installed that may interfere with the HMD camera app.

    I can provoke the same error message only in still photo P-i-P mode, when the rear camera is set to 16:9 format and the front camera to 4:3 format (old bug).

    A mechanical issue is also possible. Does the camera switch smoothly between rear and front camera and dual mode?
    Does all still photo modes work - colour B/W and both, and pro mode?
    Edit: Plenty of free space on the phone?

    I hesitate to suggest a factory reset and fresh setup, because it's a lot of work, but the phone should not behave like that.
Sign In or Register to comment.