Notification sounds occasionally cut off or inaudible

Is anyone else experiencing a weird issue where notification sounds sometimes only play partially? I've noticed it happening with Whatsapp most often.

Notification sounds occasionally cut off or inaudible

Is anyone else experiencing a weird issue where notification sounds sometimes only play partially? I've noticed it happening with Whatsapp most often. The sound might be completely inaudible, play only the very end or cut off before the end. Vibration still works every time. I haven't noticed a pattern and but it seems to happen only if the screen is off. 

I don't think i ever noticed it happening before updating to Pie and haven't had any other sound related problems.
Tagged:

Comments

  • abecedario abecedario
    ✭✭  / 
    I've this issue since pie was released (December 2018): no sound notification when I receive an image in WhatsApp, but sound works properly only when I receive a simple message with only text.
    I'm sure I'll throw the phone in the dump with the problem still unresolved...
  • MrBelter MrBelter
    ✭✭✭✭  / 
    It is Whatsapp that is at fault i suspect because it is just as bad on a Nokia 8.1 as it is on a Nokia 8.
  • Mick1965 Mick1965
    ✭✭✭  / 
    As above, it's an issue with WhatsApp.
    It does this on my nokia 8 my youngests nokia 5 , my daughter's boyfriend has a Sony zx3 which does this also.
    Talk to WhatsApp support, the more people complain about it the better.
  • Thanks for confirming it's not just me. 

    I noticed just now that it indeed happens when photos are received on Whatsapp.

    Gotta go nag to Whatsapp people then.
  • abecedario abecedario
    ✭✭  / 
    I wrote them today, fee minutes later they told me "will be fixed with a future update".
    Maybe the guy who wrote me, works for Nokia too...
  • Mick1965 Mick1965
    ✭✭✭  / 
    This has been going on a long long time.
    So I wouldn't hold your breath.
  • abecedario abecedario
    ✭✭  /  edited August 24
    With the latest version of WhatsApp released a couple of days ago, the app starts to sound properly how it should be when I receive an image or a photo.
    Fingers crossed...
  • I think i might have solved the issue by turning off "Silent notifications" for Whatsapp. My Android is in Finnish so the English options might translated a little differently.

    -Go to Android settings and select "Apps and notifications"
    -Select Whatsapp from the list
    -Select "Notifications"
    -You'll see a list of different notification types and in the bottom is "Silent notifications", uncheck it.

  • Mick1965 Mick1965
    ✭✭✭  / 
    Yeah the last update of WhatsApp sorted out the issue.
    I new it'd be soon when I  said don't hold your breath 😜  sods law
  • Salion Salion
    ✭✭  / 
    The error still occurs. It happens randomly. I just got a GIF and there was no sound but I'm not sure because I was far from the phone. I didn't know about him so I didn't read it. Then I got the link to the page and it came only with vibration without sound.

  • Mick1965 Mick1965
    ✭✭✭  / 
    As said this has been going on since Dec 2018 and prior to that 6months or so it only played half of the notifation sound.

    But Since WhatsApp ver 2.19.230 last week it seems to have sorted it for me.
    Check see if you have the latest version of WhatsApp if not update from the playstore but if you do, your best bet is to contact WhatsApp support. It's not your phones problem.
  • Salion Salion
    ✭✭  / 
    I also thought that they fixed the problem but it turned out that it was not completely. It may happen more often but it will still occur. WhatsApp ver 2.19.244
  • Mick1965 Mick1965
    ✭✭✭  / 
    Yeah, updated again, today to 2.19.244.
    Hope they haven't, broken it again.
  • MrBelter MrBelter
    ✭✭✭✭  /  edited September 7
    Apps & Notifications
    WhatsApp
    Notifications
    Silent Notifications (uncheck)

    EDIT:
    Just seen someone has already posted the fix, sorry about that.
  • Mick1965 Mick1965
    ✭✭✭  / 
    @mrbelter that wasn't the problem anyway.
    The problem was with recieving media with in the message,then the sound notification would not play, worked fine with when receiving text only message.

    @Salion still seems to be working fine for me with this even later update.(2.19.244)
  • MrBelter MrBelter
    ✭✭✭✭  / 
    Mick1965 said:
    @mrbelter that wasn't the problem anyway.
    The problem was with recieving media with in the message,then the sound notification would not play, worked fine with when receiving text only message.

    @Salion still seems to be working fine for me with this even later update.(2.19.244)
    You have exactly described the problem i was having (Nokia 8.1) and my wife was having (Nokia 8) and what i posted fixed it for us. I initially found the fix on the OnePlus forums a few weeks ago after much googling and ripping my hair out.
  • Mick1965 Mick1965
    ✭✭✭  / 
    Hmmmm.
    As said this has been going on for over about a year.
    Sure I tried that back then, to no avail. Besides it's still checked, and working ok after the update a couple of weeks ago.
    Hey ho, all works now anyway👍
Sign In or Register to comment.