No mobile data after July security update

Hi, just installed the july security update on my TA-1054 in Austria and i am facing the same problems as after the may security update:

No mobile data after July security update

Hi,
just installed the july security update on my TA-1054 in Austria and i am facing the same problems as after the may security update: No mobile data and no connection to the google servers (also with wifi). The bug was fixed with the june update. Nokia , are you kidding me?

Comments

  • CJP CJP
     / 

     I am not sure whether I had mobile data to begin with, because I set up my phone with WiFi and immediately ran the software updates. I too do not have any connection to my mobile data service provider, Maxis, here in Malaysia with a TA-1054 purchased in Malaysia. The build number shows 00CN_2_24B_SP02 which I fear to mean I was sold a model that was meant for the market in China instead.


    What's your build number?

  • Hi,
    my build number is the same: 00CN_2_24B_SP02
  • CJP CJP
     / 

     I ended up returning it because I just recently bought it and there was still time to do so. Getting an X6 instead because the shop showed me that it worked. But really really giving HMD's Nokia a last chance here to prove themselves.

  • After the July update on a Nokia 6.1, TA-1045, USA version the data connection is continuously turning on and off at a rate of something around a second or so.  The software that I'm using will show it CONNECTED and disconnected very rapidly and I can get very little data speed at all.  3 Mbps down and 0.2 Mbps up.  This needs to be fixed rapidly like now.  Using a MVNO of T-Mobile and have tested the data connection with my Nexus 5 and data is fine, stays CONNECTED.

  • Hello user1527011066020, I have a same problem with u with TA-1054 and I live in Vietnam and until now, after a update in June I still can't use mobile network, does your phone get a fixed for this?

  • Hi,
    I am also having the same problem but the problem got solved when I removed on of the sim,Then it started working with proper speed as usual.
  • Whoever confirmed that mobile data is working in US version of Nokia 6.1, can you please confirm if T-mobile works on it and that too with 4G speed.


    Thanks

  • Data does work on the Nokia 6.1 US version on T-Mobile. T-Mobile has a problem overloading band 12 causing slow speeds. Band 12 has longer range covering more people, but inherently has less bandwidth.
  • So basically it is a problem with t mobile in general and nothing to do with Nokia 6.1, right
  • Correct,  T-Mobile focuses on saying you are covered if you get a signal, doesn't matter if it works or not.  And then tries to use WIFI calling to fill in the blanks.  Where at&t builds a network that covers everyone and then might use WIFI calling if needed.  T-Mobile can't get 4G LTE which is not 4G to work so now they are moving on to 5G which will be a mess if it's like 4G has been.

Sign In or Register to comment.