^.1 not working with USA SIM card

I traveled to the US with my Nokia 6.1 TA-1089 purchased in India. I also purchased a SIM card for the US from SG Telecom in India.

^.1 not working with USA SIM card

mmjoshi mmjoshi
✭✭  / 
I traveled to the US with my Nokia 6.1 TA-1089 purchased in India. I also purchased a SIM card for the US from SG Telecom in India. The local provider for this SIM card is Lycamobile. When I inserted the SIM card in my Nokia 6.1 it was correctly detected as a Lycamobile card. However, I am unable to make or receive any calls nor is the mobile data activated. Anyone else faced this problem? Any special settings required? Any workaround? The phone worked perfectly in India.

When I put this SIM card in an unlocked AT&T Samsung S4 mobile it works great. This indicates that the problem is with the Nokia. Is this phone not compatible with the US telecom providers?

mj

Comments

  • tudor georgescu tudor georgescu
    ✭✭✭  / 
    US use other standard than India and EU. So, each smartphone is built for a certain world region.
  • singhnsk singhnsk
    ✭✭✭✭  /  edited October 7
    Probably due to the fact that the Indian edition does not have all the bands enabled. And also that the Indian edition didn't pass the FCC.
  • mmjoshi mmjoshi
    ✭✭  / 
    US use other standard than India and EU. So, each smartphone is built for a certain world region.
    Thanks! That explains it. US has to be different than the rest of the world!
Sign In or Register to comment.