Cannot add Google Calendar account - because there is no SAVE button.

Hello, I enter the Calendar app, and choose to add an account. I click Google to add a Google Calendar account

Cannot add Google Calendar account - because there is no SAVE button.

user1532439434920 user1532439434920
 /  edited September 4

Hello,


I enter the Calendar app, and choose to add an account.


I click Google to add a Google Calendar account


I add the username, and the password, but there is NO SAVE BUTTON. How do I save these new calendar details? There is only a BACK button, which does not save the details.


Please could you tell me how to save my new added Google login details?

Comments

  • user1532066359708 user1532066359708
     /  edited September 4

    I had the same issue, because I have gmail account on my own domain. The login must end with @gmail.com. IMO it is a bug, should be fixed.

    On the other hand, I have set up email client with my account. I have 2FA enabled and had to create app password. Email works.

    But when I try to log into the contacts import with my custom domain and password, it does not work. Only a basic gmail account without 2FA and you have to enable "Less secure apps" in the Google account menu.

    Can anybody from Nokia confirm it is a known bug and being worked on?

  • abbas abbas
    ✭✭✭  / 

     user1532439434920


    The first box says username but it's really your "email address"of your Google account, not merely your "username". I have no difficulty whatsoever..

  • Of course, the username is an email address, like for Google login. I entered an email address. It still did not work.

  • user1532439434920 user1532439434920
     /  edited July 25

    Yes, this seems to be the answer, the email address must end gmail.com. I agree with you, this is a bug. I have two Google accounts, work and personal, and neither end with gmail.com. So, this is quite normal and should work. I wonder if anyone from Nokia is able to confirm if they understand this to be a bug or not? I have reported to KaiOS also.


  • baklawa baklawa
     / 

    I was able to setup my Google Calendar account using my @gmail.com address as a username and an application password generated for this.

  • keith keith
    ✭✭✭  / 
    When I signed in it kept saying wrong password. Then I had an email on my Android phone stating the Google had blocked the Nokia because the software wasn't secure enough. I had to alter a setting to allow less secure apps.
  • mrded mrded
     / 

     The topic is marked as "answered", in fact, the problem is still there.

  • Actually, I think you are right. I did mark an answer as answer, because it did identify the cause of the problem. However, it is still a problem, so I have unmarked the answer, to leave this open.


    For NOKIA:


    Where one adds Gmail accounts (for calendar sync, for email, for contacts) your software will only accept addresses which end ...@gmail.com. Clearly this is wrong, since many gmail accounts use personal or business domains so do not end with @gmail.com. This should be changed. Simple change, please implement.

  • lroguet lroguet
     / 

    I asked the question to the KaiOS support a while and here's their answer on how to add Google calendar for a "non-Google" address.


    To sync your Calendar app with your Google calendar, please start the Calendar app, then go to Options -> Settings -> Add Account and choose CalDav. Please enter your email address and the password from your Google account. After that please enter the link https://www.google.com/calendar/dav/<emailaddress>/events  where <emailaddress> is the Google email address, and press Save. If you see an error message and have a problem logging in, please check your email inbox, as you may receive an email that the sign-in was blocked. In that case, please allow access to less secure apps in your account settings and after that, you will be able to sync your calendar to the Calendar app on your device.

    Please note that if you have a 2-factor authentication enabled for your account, it is not possible to toggle the less secure apps access in the Google account, so the calendar account on your device won't be added. To fix that, please disable the 2-factor authentication and follow the steps above.

  • Yes, I am aware of the CalDav shortcut. But (1) it is a pain to add all the CalDav details instead of just being able to add username and password and (2) for me it did not work anyway - and yes, I have allowed less secure apps.


    IMHO the restriction to @gmail.com is a bug and should be fixed.

Sign In or Register to comment.