GPS Problems

Hi all, after the upgrade to version the GPS of my 8110 cannot locate my position. Anyone else?

GPS Problems

Hi all, after the upgrade to version the GPS of my 8110 cannot locate my position. Anyone else?


  • abbas abbas
    ✭✭✭  / 

    Mine is fine. Suggestions:

    1. Do a reboot by pulling out the battery and check your GPS. If this fails:

    2. I don't know whether it is possible you donwloaded a corrupt version as sometimes the line could be unstable (I have experience this while downloading my desktop computer updates). In that case, I would do a factory reset and try again, of course need to back up important data.

    Best of luck

  • Thank you! By the way I've searched online and I'm not the only one with this problem, this weekend I'l try an hard reset.

  • Ok, I've done a factory reset, but the OS version didn't change, is stil the ver 12. Now I can't use the internet too, because the "add APN" button doesn't show anymore so I can't say if the GPS work again. I'm a little angry.

  • I also has a same problem after update phone. I tried everything you said, but still nothing. Any another solutinons? Thanks!
  • user389 user389
    ✭✭✭✭  / 

    Please note the first GPS fix after a factory reset or an OS upgrade may take longer than usual. Did you already try take the phone outdoors, open Maps and wait for a few minutes?

  • After few days of trials I've (sadly) choose to return the phone to Amazon. 

  • eskerahn eskerahn
    ✭✭  /  edited August 2018

    I have the same issue.

    In Maps it shows during a couple of minutes attempt to get "your location"

    "Getting location"

    "Still getting location"

    "Getting location"


    And it does not find the location, and turns off the GPS icon,

    I tried outdoor and let it time out.

    I suspect there is some time out on a GPS request, that times out and turns the GPS off as unused before it actually get the location.

    Similar result if I try a "Drive" to somewhere and request from as "Your location"

  • eskerahn eskerahn
    ✭✭  /  edited August 2018

    I accidentally stumbled on a what could be a work-a-round!!

    It seems that the net credentials must be given AFTER the "geolocation" is turned on.

    After in vain to have tested it again after a couple of hours, I gave up and browsed through the menus and then I accidentally entered the "Known networks" (Settings, Wifi, Advanced settings, manage network)

    And as other have reported this list does not work (, and kills the current connection(!)

    But after re-entering the WiFi credentials (Available networks, select and connect)

    I took a wild guess an retried. And look and behold now the GPS works!! :-)

    (NOTE that I'm currently playing with the device without any sim - this could make a difference)

  • eskerahn eskerahn
    ✭✭  / 

    The work-a-round is slightly more than the above (just retried as problem re-occurred after power down)

    1) Enter "Known networks" (Settings, WiFi, Advanced settings, manage network). Due to a bug this kills the current connection(!). 

    2) Enter Maps, ignore "no internet" warning, and select "Your location". And you (might) get it.

    3) Exit maps

    4) Reconnect net (Settings, WiFi, Available networks, select and connect)

    5) Enter maps, and now it works!!

    (Tested without a sim only)

    Turning WiFi temporary off does unfortunately NOT seem to work as an alternative in step 1 !!

    My GUESS why this hack works is that that not all WiFi networks are known geocoded, and IF the GeoLocation seeds the GPS with the position of the current WiFi -and this isn't geocoded- location could fail with a time out as being very far from the seed. But if you disconnect it might silently scan for in range WiFi-networks for a valid seed.

  • dorian liszcz dorian liszcz
    ✭✭  / 

    Thanks for help.
    My localization in googlemaps works only if wi-fi is on.
    Very, very funny... and still no software update. Amazing.

    Next problem... no navigation in googlemas, Crazy people...

  • dorian liszcz dorian liszcz
    ✭✭  / 

    hahaha... after few times of wifi on/of - now, my localization in googlemaps works correctly...  :):):) 

  • eskerahn eskerahn
    ✭✭  / 

    @Dorian Liszcz, Great that you got it working. :)

    Odd that it works with WiFi on/off for you. Here it only works with disconnect/connect.

    At first it does indeed seem odd that no real-time sat-nav is offered, but my guess is that the chipset simply might be too slow, or that it would overheat if it tried to do it for more than a few minutes.

    Note that when showing "your location" while moving, it moves the 'dot', and not the map - again this could be a cpu issue?

  • Marcosss Marcosss
    ✭✭  / 

    Dec 3 2020 after a recent OS update my GPS stopped working.

    I tried everything in the thread to fix the issue, I also contacted Nokia online assistance & went through a bunch of assorted resets. Nothing worked.

    So, I took the sim out of my 7.2 & put it in my old 7.1.

    I updated all of my apps & OS on the 7.1 & it is rock solid.

    On my way to the gym, I thought I'd take the 7.2 just in case my workout app had not updated.

    On the way to the gym I turned on the navigation on the 7.2 just to see if it worked, to my surprise it worked perfectly.

    Happy that this was the case I put the sim back in the 7.2, as soon as I did that, no GPS.

    I informed Nokia that this had happened, they said put another sim in the phone & see what happens.

    I put a spare data sim that I had & it did the same thing, the moment it went in, it killed the GPS, took it out, GPS was working again.

    I have reported this in detail to Nokia along with screen shots of the app GPS test with & without sim.

    They advised that I should wait for the next update from Nokia, they had no idea when that will be.

    Meanwhile, if your having issues with the GPS on your 7.2 try removing the sim then run either GPS test or a Navigation app

    The app I used to test the GPS is called GPS Status

  • abbas abbas
    ✭✭✭  / 

    Interesting. What do you think was the cause of your problem?

Sign In or Register to comment.