After Android 10 update WiFi is not working anymore ?

Hi, I got update this morning. Now I cannot connect to WiFi at home or at office. "connection to network failed" Restarted, resetted WiFi options etc.

After Android 10 update WiFi is not working anymore ?

Förre Förre
✭✭  / 

Hi,

I got update this morning.

Now I cannot connect to WiFi at home or at office.

"connection to network failed"

Restarted, resetted WiFi options etc. done.

Has someone else seen this same issue ?

Tagged:

Answers

  • Förre Förre
    ✭✭  / 

    Modified security settings all the way to none, no help.

    Seems to be that WIFI settings cannot be saved (says so in very short time when trying to connect).

    Could it be that some setting prevents settings to be saved to filesystem ?

  • Noah R Noah R
    ✭✭  / 

    Same here. Had to make a temporary, new network at my house in order to use WiFi at all. I seem to lose signal easily both at my house and while on other networks.


    I wish Nokia would address these issues. I contacted support but all they told me to do was send my phone in for repairs. Not helpful.

  • After upgrade I did factory rest as a best practice. All is working fine expect losin wifi now and then, very frequently.

  • Förre Förre
    ✭✭  / 

    Hi,

    I made some debugging more, deleting caches, soft resets, resettinh, deleting files etc.

    Nothing helped so last option was to have Factory Reset.

    That finally helped to problem but now it takes time to setup all things again (those hundreds of useraccounts and "trusted devices")..

    So issue has a workaround, but I would not expect such an issues with tested and released SW.

  • FinnCoding FinnCoding
    ✭✭  / 

    Hey there,


    I had this issue a few months ago.

    Everything I tried didn't work, however when I waited 1/2 days, the WiFi started to work.


    This probally happened cause the Network Card in your Phone is overloaded.

    What could help is turning your Phone off for a few hours, then booting up and trying it carefully again without spamming.


    Goodluck!

  • MatthiasR MatthiasR
    ✭✭  / 

    The same problem existed with a Nokia 8.1 even after the Android 10 update was installed.


    No more connection to the router at home, with well-known ones the WLAN ran flawlessly.


    The following was the problem, an Arcadyan router.


    Interim solution would be:

    Switching WLAN from WPA + WPA2 to WPA should solve the problem first or wait for an update from the router manufacturer so that it is Android 10 compatible.


    We opted for a different router where it ran immediately after the update.


    When the update for Nokia 7.1 came, everything went smoothly with WiFi and the new router.

  • Kimble303 Kimble303
    ✭✭  / 

    I didn't do factory reset. And I can connect to the wi-fi of my router as usual.

    But just yesterday when I was listening music with Deezer, my Nokia 7.1 wi-fi suddenly dropped connection and it only came back after restarting the phone. First I thought the problem might be with my router wi-fi because I just updated the firmware. But checking the wi-fi connection with another phone revealed that router wi-fi was up and running just fine. Only Nokia wi-fi had failed.

  • Kerles Kerles
    ✭✭  /  edited December 2019

    I've got exactly the same problem on my Nokia 7.1. Meanwhile i've tried everything: deleting cache, changing settings, soft reboot, rebooting wifi, bluetooth etc. While the phone connects to hotspots from other phones, it seems to not save my wifi password and also doesn't give me any feedback when i press the wrong wifi password (simply says my code is "saved"). Is there anything I can do at this point? Even a factory reset did not do the trick...

    This problem emerged after the latest software update i did this morning.

  • I too faced the same issue with my Nokia 7.1 which is one week old. If you update to Android 10 you will face the issue, it's not your router problem nor network problem nor mobile device problem. I have reset network/wifi settings in my device, performed factory reset but wifi will connect for the first time and after that if you switch off and on wifi, it will not connect, just show you the status as Saved or no internet connection. Finally i went to Nokia authorized service center and they told the issue is because of updating to Android 10 as Nokia hasn't released complete version and this is causing the issue. They took 4 hours and returned my mobile and it is working fine without having any issues. I thought for sometime how these guys figured out the issue and as i have some technical skills and found that they took back my device to Android 9 August 2019 Security update from Android 10 November 2019 security update. Lol..they are really genius :P. Now i am waiting whether Nokia resolves the issue in December 2019 security update or not. If they do, then i will update my mobile to Android 10. That's it.....

  • leodavesne leodavesne
    ✭✭  /  edited January 18

    Same problem here with a Nokia 7.1 on Android 10: all other devices in the house connect to the new network (Fiber Salt Box) except this one.

    Reduced the security protocols from WPA2 to WPA on the router and it works now. Not ideal for sure in terms of security.

    My assumption is that it was broken with Android 10 and that Nokia has to fix it to keep the Wi-Fi trademark: "WPA2 certification is mandatory for all new devices to bear the Wi-Fi trademark." from https://en.wikipedia.org/wiki/Wi-Fi_Protected_Access#WPA2

    Looking forward to a patch!

  • Obscura Obscura
     / 

    My Nokia 6.1 just updated from 9 to android 10. WIFI on this phone has ceased to connect to my home router. Has any anybody got a solution yet?

  • Ditto: Nokia 6.1 updated android from 9 to 10 today, and all the wi-fi became unavailable (at work), except the guest network, which has no password but is portal protected.

    The SSIDs are present/selectable in the Network & internet -> Wi-Fi menu, but the WiFiAnalyzer app reports only the guest network.

    I have a wifi sniffer available, and it seems the phone exchanges probe requests/responses, but does not associate (are any wifi professionals at Nokia listening?)

  • Farivan Farivan
     / 

    I tried numerous other methods to fix this. Ultimately the only thing that worked was performing a factory reset. I can confirm everything works fine now

    The good news is that I was able to restore from an Android backup that was made during the update process, so lost basically nothing.

  • Smgmax Smgmax
    ✭✭  / 

    I have found that turning off the Bluetooth fixes the WiFi connection

  • Hi there,

    After yesterday's update, my phone cannot start. After the Android One logo, I get a black screen with the following message at the bottom of the screen: "Boot Reason: enablefilecrypto_failed" , which prompts me either to try again, or perform a factory reset. I already tried the second option, but again after updating the OS (I don't get an option to skip the update), the same thing occurs. 

    Is there something wrong with the latest update + Nokia 7.1?

  • AQT AQT
    ✭✭  / 

    I'm also having problem unable to connect to WiFi in the last few weeks. Tried reset settings and soft reset, tried with or without Bluetooth on, no luck. My WiFi is shown as Saved" with a padlock, but won't connect after correct password entered. Have turned phone off for a few hours and then back on, still no luck. Strangely however, successfully connects to Telstra Air in a nearby street! Why?


    Andrew from Sydney, Australia

  • AQT AQT
    ✭✭  / 

    My previous comment relates to Nokia 7.1.


    Andrew, Sydney Australia

  • I solved same problem with setting of Wi-Fi on router site.

    Wifi on my router was defined as WPA2 and after change to WPA, Nokia is connected well.

  • ChusTM ChusTM
     / 

    You can find the solution in this blog:

    It is not only happening with Cisco APs but with some other Wi-Fi routers.

  • nimazar nimazar
    ✭✭  / 

    i believe i have found a permanent fix!

    for any body having any kind of wifi issues just login to ur router settings and change your security option from WPA2-PSK to WPA-PSK!

    DONE!

    after that if u get stuck on obtaining ip address, just forget the network and when u try to connect back go to advanced tab (in the menu that asks u for ur password to connect) and switch from DHCP to STATIC, enter the pre-written stuff ur good to go!

    no more issues!

Sign In or Register to comment.