headphone plugged in but audio played by loud speaker

I have an issue with my Nokia 7 Plus when sometimes when i plug in headphone the audio plays in speaker and when i plug out there is no audio playing at all, i have to restart my phone to fix it but the issue keeps happening after a while.

headphone plugged in but audio played by loud speaker

nr_anup nr_anup
 /  edited August 5

I have an issue with my Nokia 7 Plus when sometimes when i plug in headphone the audio plays in speaker and when i plug out there is no audio playing at all, i have to restart my phone to fix it but the issue keeps happening after a while. Is there a way to fix this?

Comments

  • user1528310508222 user1528310508222
     /  edited August 5

    Oh man the exact same thing happens to me aswell... I normally try these two things and sometimes it comes right.

    1. First I start playing something with sound (usually youtube) through the phone speakers and then plug in the headphones. It then takes a few seconds then it starts playing through the headphones.

    2. The other way, which is a very crappy thing, is to plug in the headphones 3/4 way and for some reason it sometimes switches playing between the headphones and phone speaker. Then I trial and error it until it plays correctly through the headphones.


    Not the most ideal solution for now, but at least I do not need to restart my phone.

  • omissis omissis
     /  edited August 24

    Hello 

    I tried this myself so can we try to reproduce the issue?

    What I experience:


    • Plug the headphones (my old fellows Nokia WH-208), pressing then firmly into the jack until I hear the spring click

    • Start a music app (tried with Soundcloud, YouTube, VLC)

    • Audio routes correctly to headphones for less than 10 seconds

    • At that point the playback stops

    • When resuming playback the audio is routed to the speaker until plugging headphones out then in >>> the issue persists and loops back to point number 3

    Well, this looks to me like a plain software issue , audio service is not managing correctly the audio i/o. Now I understand this is a discussion forum but it would be useful to me to know how to report and what's the best way to do it .

    It's not that I do not trust the customer service but I know the kind of environment it is and to file a bug report is not something coming as priority while working on fixing urgent issues; or sometimes it may happen that agents do not properly care (not specifically hmd ones)


    Also, moderators, could we try to begin placing a sticky here if is there no way to report the bug?


    (PS, even this post window has a bug too! after closing the list the writing starts from the right end :D )

  • omissis omissis
     / 

    Temporary workaround is reported here:


    https://forum.xda-developers.com/nokia-7-plus/help/music-calls-playing-speaker-instead-t3820462


    Have the headphones plugged in , press Power button, choose "Restart", keeps the headphones in while restarting.


    I will report here if issue subsides itself with one restart or to restart is needed every time the headphones are plugged out and put in after some time


  • omissis omissis
     / 

    Please Star and comment here


    https://issuetracker.google.com/issues/111659724


    and please, PLEASE follow the guidelines and do not open any other report

  • user1528310508222 user1528310508222
     /  edited August 6

    Yip @omissis


    Your 5 points you mentioned is exactly what happens to me, down the the 10 seconds.


    What I do though, that sometimes helps me to get it to work is to basically instead of plugging in the headphones first. I first start playing the music app through the phone speakers, thereafter I firmly plug in the headphones. after a few seconds then usually the playback stops and the the audio plays through the headphones. 

    It does not always work and sometimes its a hit and a miss and I need to attempt it 2 or 3 times.

  • omissis omissis
     / 

    Hi 

    issue is escalated to Google issue tracker with ID 111659724

    If you want you can star the issue so developers are more aware. Please do not create more entries and use this one.


    On the other side testing on the software on N7+ needs more attention and quality assurance by HMD engineers and QAs.

Sign In or Register to comment.