Nokia 7.2 | Android 10 | Security Update: 1 August 2020 | UI Lags and Freeze

It's been about 2 weeks now using my new Nokia 7.2 (4GB/64GB) and there are some serious UI Lags and Freezes even after updating it to the latest software update available with having Android One 10 and with security update of 1 August 2020.

Nokia 7.2 | Android 10 | Security Update: 1 August 2020 | UI Lags and Freeze

It's been about 2 weeks now using my new Nokia 7.2 (4GB/64GB) and there are some serious UI Lags and Freezes even after updating it to the latest software update available with having Android One 10 and with security update of 1 August 2020. I am experiencing the lags and freezes at the following general interactions:

  1. While pulling down the notification bar
  2. Tapping on any tile from the notification bar
  3. While entering the unlock PIN at the lock screen
  4. Clearing out the email/text messages notifications with horizontal swipe
  5. Adjusting volume through the volume buttons
  6. Navigating to back within any app (with gesture navigation set from the system navigation settings)

Had a chat with Nokia Support and shared the issues with them, followed the instructions which says:

  1. Force stop and Clear Cache for the system app System UI
  2. Force stop the system app Android System
  3. Force restart device by pressing Volume Up + Power key for 20 Seconds
  4. Check device on safe mode for 2-3 hours
  5. If above three steps do not resolve the issue, do a factory reset

But didn't work for me. And when I tried to reach the Support again, I was suggested to visit a nearby Nokia Service Center.

I think we are in a loop. This is not a hardware issue, not even related to the third party apps as I can confirm that there's no CPU heavy or RAM consuming (Usually I have 2GB+ RAM free) or No major battery draining issue. Also, none of the user installed App running actively or in the background.

Most of the google searches points to the default launcher it comes with - Quickstep which may be causing an issue. I would like to request Nokia team to look into it as it is mostly I believe related to the default software combination with the Android One 10. I am really looking forward to get it fixed in the upcoming software updates.

Comments

Sign In or Register to comment.