SMS receiving issues - Page 4

Changing the SMS app doesn't always work and shouldn't be a solution to a problem created by what is clearly Google's fault at the core level and HMD's fault at the OEM level.

SMS receiving issues

Comments

  • dbs dbs
    ✭✭  / 

    Changing the SMS app doesn't always work and shouldn't be a solution to a problem created by what is clearly Google's fault at the core level and HMD's fault at the OEM level.


    Since they like stock Android so much, they should have already issued a patch for this.

  • Hey my phone is fixed now after i get support chat with Nokia team. Find below step to fix the issue.
    Please go to:Play Store> update the message app.
    Go to setting>app>show system app>message> force stop. Again enable. Restart the phone. It's fixed for my Nokia 5 phone.
  • adbenj adbenj
    ✭✭  / 

    How are people doing on the Orea beta? I seem to be getting all my messages so far, although there's obviously no way to be certain.

  • mr. nokia mr. nokia
    ✭✭  / 
    When it comes to SMS, it seems that everything is OK on Oreo Beta. On the other hand, the issie with background apps is not fixed.
  • Jm1983 Jm1983
     / 
    I also seem to be getting all my messages ever since I updated to Oreo. Let's keep our fingers crossed!
  • adbenj adbenj
    ✭✭  / 
    Unfortunately I can confirm some messages are still being missed by the stock SMS app on the Oreo beta. Don't know about other apps as I didn't have any installed at the time – just added Textra to fetch the messages I was missing, but that's not to say it would have been pushed the messages had it already been on my phone. It's extremely disappointing. I know we're only in beta and some problems can be expected, but none of the existing problems have been solved, and frankly, I don't hold out much hope for the stable release being a whole lot better.
  • I've also noticed missing text messages on both 7.1.2 and on the Oreo beta. Some of the missing messages appeared after installing Textra to replace the default app. I shouldn't have to do that though, SMS is a very basic feature which should be a priority for HMD.
  • Use Zero SMS. It works perfectly. I am responding after watching for 1 week.
  • Hey, after upgrade to newer oreo beta lab version yesterday, the SMS issue is gone, try it

  • @user1513092690090

    The issue is still present on my phone on Oreo Beta
  • @user1510406824432, I use second beta version V5.160, what's your version?

  • @user1513092690090 I see, I was using the original build, not the 2nd build (V5.160). I've since updated, so I'll give it a bit of time to test it to see if the issue has been fixed.
  • I'm now using Textra for SMS with Ghostly SMS as a backup. Zero SMS did NOT work for me.

  • The support from Nokia is pathetic. I dare say most of us have chosen a 5 for its dual sim capability, one for personal and one for business. No good if not receiving business sms's. :-(


  • Guys i found solution for that
    Disable that existing message app and install Zero sms app from play store i tried different apps but only this Zero sms app is working fine and after installing please go into settings of battery and allow Zero sms app in white list
  • As I said before;
    I'm now using Textra for SMS with Ghostly SMS as a backup. Zero SMS did NOT work for me.

  • Krishna Krishna
     / 

    I am using NOKIA6, After NOV monthly security update, we are facing this issue. Even NOKIA support team doesn't have proper info about the fix and ETA. Try this work around: disable and force stop the default 'messages' app and download any third party sms app ( i am using 'sms organizer' of Microsoft) and make this as a defult message app. Then in the battery setting --> activity manager --> white list your sms app. This is working for me. 

  • JPJ JPJ
     / 

    While many workarounds (like installing 3rd party SMS apps) have been suggested for the issue being faced by Nokia users after the upgrade to 7.1.2, the real reason behind the problem (and solution) has been identified by a User (Nishanth) in his post here:


    https://community.phones.nokia.com/support/discussions/topics/7000012536


    The 7.1.2 update introduced a new setting under Battery called Background Activity Manager.  Opening this Background Activity Manager gives you a list of all the apps on the phone which are Allowed (whitelisted) or Not Allowed (blacklisted) to run in the background.  For some reason, all apps (and services) including basic ones like SMS, IM (WhatsApp, Messenger etc.) and Mail (Gmail, Yahoo, Outlook etc.) are all disabled (i.e turned off) by default.  In effect, they cannot run in the background unless & until you manually launch the app, and let it keep running - and don't close it manually.


    In case you close an app (like SMS, IM etc.) then you will not receive any SMS or Chat notifications, till the time you launch the app manually.  Now, this is fine for IM or Mail apps, as you can afford to not have the Chat message or Mail delivered instantly.  When you launch the IM or Mail app, you will get the chats/mails that were queued up at the IM/Mail server.


    However, that model cannot work for SMS, as they need to be delivered instantly.  Carrier networks cannot indefinitely hold SMS in the network queue, and so messages sent to you when you SMS app was not active, will be treated similar to when your phone is switched off - and may not get delivered at all.


    By design, Google (or Nokia) should have ensured that at least basic communication services (like SMS) are always turned on to run in the background.  Per se, this Background Activity Manager is a great utility, as it allows us to turn off those apps that we don't need real-time updates for.  But leaving something as basic as SMS in turned-off state by default - was well nothing short of stupid!


    To cut a long story short, the solution is this - Go to the Background Activity Manager, and turn ON "Messages" from the list of apps; which in effect puts the app into the "Whitelist".


    You will start getting SMS now.


    Do the same for all other social & communication apps (like WhatsApp, Hangouts, Messenger, Gmail, Yahoo! Mail, Outlook etc.) also - as otherwise - you will not get notifications from those apps till the time you manually launch the app.


    Once an app is launched, you will get notifications till the time you don't manually close the app.  But once an app is closed, it will not run in the background - and you will not get any further notifications - till you once again manually start it.


    Therefore; turn those apps from whom you want real-time notitfications - to the ON position - in the Background Activity Manager.  That is the real solution.



  • dbs dbs
    ✭✭  / 

    That would be a valid explanation EXCEPT it runs into a problem: if it was it, then people wouldn't be receiving SMS's at all when the app is not running.


    The problem is that people were receiving some messages and others didn't come through, both when the app wasn't running.


    At any rate, Juho Sarvikas said they fixed the issue on the 2nd Beta of Oreo so let's test that one instead of trying to come up with "the solution" that it's never really within the user's grasp to solve ;)

  • dbs dbs
    ✭✭  / 

    Not "wait and hope". HMD has issued a fix for it on the 2nd Oreo Beta. The only people who currently are still "wait and hope" are the ones not on it. It's not a solution for normal consumers, no. But it's not like we're still in the dark in regards to what's happening ;)

  • adbenj adbenj
    ✭✭  / 

    When did Juho say they'd fixed the issue? I'm pretty sure I've continued to have problems since updating to the second beta, but I can barely keep up anymore.

  • dbs dbs
    ✭✭  /  edited January 2018

    @adbenj

    I got the info from him on the 5th of January. I'm currently testing it and so far I haven't faced the issue again. 

    I did NOT follow any of the "disable this" and "uninstall that" tips that were made here. If you did, try reverting those things first and see how it then works out for you.

    The way I got to find out was taking the SIMs to the previous phone, see what messages I got, then put then back on the 5, erase all messages and start fresh. Since then, I've received them all.


  • JPJ JPJ
     /  edited January 2018

    It was tather presumptuous of me to say that what worked for me, was indeed "the solution" for everyone ... for it clearly isn't.  Having said that, it's too fundamental an issue to be ignored, and I'm sure a fully baked update will fix it ... hopefully soon!

  • Unknown
     /  edited January 2018

    Hi,

     

    I needed to delete
    and moderate some posts due to not following the house rules. Please keep the
    discussion relevant to the topic.


    Mike

  • I also have this issues since 2 months now. I wanted to upgrade to a nokia 6 but this poor handling of this important problem shows me to wait how hmd will develop. When will it be fixed?
  • Hatter Hatter
    ✭✭  / 
    Hi. My wife uses mood messenger and it works well on her Nokia 5.
  • I have the same problem. I can't receive sms and it is very annoying. I went to Vodafone and they said they couldn't help me because is a problem from you software. Please solve this
  • Krishna Krishna
     / 
    I am using NOKIA6, After NOV monthly security update, we are facing this issue. Even NOKIA support team doesn't have proper info about the fix and ETA. Try this work around: disable and force stop the default 'messages' app and download any third party sms app ( i am using 'sms organizer' of Microsoft) and make this as a defult message app. Then in the battery setting --> activity manager --> white list your sms app. Try this guys.. its worked for others...
  • adbenj adbenj
    ✭✭  / 

    Thanks DBS!


    Has anyone had any problems with the latest Oreo beta? I don't think I have, but I'm still wary of deleting Ghostly SMS, which I use as a back-up.

  • user1516607085374 user1516607085374
     /  edited January 2018
    First turn off auto updates, then from settings > apps > Messages, disable it then again enable it, it should work. Do the same if you have problem with alarm
Sign In or Register to comment.