Do Not Disturb is activated automatically?

My Nokia 7.2 Dual SIM has just started to do the weirdest thing:

Do Not Disturb is activated automatically?

Tiigritriip Tiigritriip
✭✭  / 

My Nokia 7.2 Dual SIM has just started to do the weirdest thing: during a phone call the Do Not Disturb option is activated and that's how it stays also after the call is finished. Basically I have to switch it off manually after every call. If I don't notice and forget, guess what, I'm missing all the next calls because the phone is in silent mode. What the... what??? Why does it do that? It's been about a week, there was no such issue earlier. I haven't changed any settings. What should I do to make this go away?

Answers

  • singhnsk singhnsk
    Super User  / 

    Hi, just for a odd check, can you double check if the proximity sensor is working fine and the screen gets blacked out during the call when your phone is next to your ear?

    In the past I have had my ear cause the mistaken activation of DND mode because the screen failed to turn off during a call and the touches from ear would cause random clicks, one of which enabled the DND function.

  • Tiigritriip Tiigritriip
    ✭✭  / 

    I thought of that, but that cannot really be the cause for every time. I put most of my calls on the speaker and the phone never goes near my ear. Still it's in silent mode afterwards.

    Thanks for the suggestion though.

  • PhoneGuy PhoneGuy
    ✭✭  / 

    I have the same problem. No idea how to get it fixed.

  • munnasharma munnasharma
    ✭✭✭  / 

    Any fix, I also getting same problem

  • Vysakhan Nair Vysakhan Nair
    ✭✭  / 

    My new 5.4 also showing the same problem.Each and every time I need to off the dnd mode manually and sometimes if I forget to off,I cannot see the next call is ringing.any solution for this..Really frustrated with this issue

Sign In or Register to comment.