Android 11: wifi network marked "saved" and won't connect automatically

Just like it says on the discussion title.

Android 11: wifi network marked "saved" and won't connect automatically

NMG NMG
✭✭  / 

Just like it says on the discussion title.

My phone was upgraded to Android 11 last week and, since then, it will not automatically connect to my Wifi networks (I have two separate access points with different SSIDs).

A typical scenario is when I get back home: the stays connected to mobile data and won't connect automatically to my Wifi network. If I look in the Wifi network list, I see my SSIDs marked "saved" but the phone is seemingly ignoring them.

All was well with wifi access using Android 10.

I have tried re-adding the wifi details ("forgetting" the network and then adding it back). I have also reset the network settings. I have not yet done was to do a full factory reset because it's a major pain and without a guarantee it will do anything, I just don't to go through setting all up again.

This phone was my first Nokia after my good, old N95. The 4.2 hardware is fine for what I need but the software qualify is pretty horrible. Very disappointed.

Comments

  • Tyfomir Tyfomir
    ✭✭  / 

    The same here. You may be right. It seems that this problem was introduced with A11. The other Nokia (3.4 with A10) has no problems with reconnecting to the same network.

    Is your network in WPA3 (or WPA2/WPA3) mode?

  • NMG NMG
    ✭✭  / 

    WPA2.

  • santoscleto santoscleto
    ✭✭  / 

    Same here, WPA/WPA2 and with android 11 (on 10 worked perfectly, even if with BT enabled the speed dropped to an appalling 10% of the usual speed) the damn phone does not auto-connect anymore (shows wifi enabled but my network shows as "saved", and I also have the auto-connect enabled. It seem wifi on nokias is disregarding completely the settings (nokia 2.2 also seems to have mac randomization issues; here it is the auto-connect).

    I hope nokia is paying attention to these threads, because, again, we are full of issues and just shows, again, their lack of testing newer versions. Android one has been a joke up to now, not up to the expectations, sad realization that we need to move to another brand/version to get decent software...

  • Tyfomir Tyfomir
    ✭✭  / 

    As far as decent software is concerned, our choice is very limited.

  • Walter Sparbier Walter Sparbier
    ✭✭  / 

    I found this thread because I have just the same problem. Even when at home, over time it looses the Wifi and then stays on mobile data. :-(

    Is anyone from Nokia listening in here?

  • Tyfomir Tyfomir
    ✭✭  / 

    If anyone gives a damn about comments here is yet to be discovered. I believe that we may be disappointed.

  • Anil99 Anil99
    ✭✭  / 

    Anyone gets HD streaming in nokia 4.2


    No HD streaming in my nokia 4.2

  • StuLgaR StuLgaR
     / 

    Same problem here. Found a possible work around:

    "try turn off this setting

    Settings > Location > Google Location Accuracy Off"

    Please test and leave feedback. Best whishes!

    Reference: Solved: S20 Ultra WiFi issues with Android 11 - Samsung Community - 1604719

  • santoscleto santoscleto
    ✭✭  / 

    Turning the "Google Location Accuracy" off solved nothing, the nokia 4.2 has not the same issue as that particular samsung.

  • WalterNL WalterNL
     / 

    Same problem here.

    Was a nice update.. lost all my media stored on my SD card incl photos and videos and now my phone refuses to connect automatically to my wifi.

    My other phone (Sony) with android 11 has no issues so it's not likely to be the wifi.

  • santoscleto santoscleto
    ✭✭  / 

    You should rant in the nokia 8.1 forun, sadly here we only rant for the nokia 4.2.

  • santoscleto santoscleto
    ✭✭  /  edited June 16

    I tried everything and I still do not understand what triggers this since I tried all possible combinations (with BT on or off, with mobile data on or off, ...). Basically on each 5 times I come back home, on 4 of them it does not auto-connect and I have to disable/enable the wifi to get it connected. But when it is connected it is fine, it does not disconnect anymore (until next time I leave home).

  • Johannes Rehm Johannes Rehm
    ✭✭  / 

    Is there any update or any feedback on this issue?

    It actually cost me a lot of money, because I assume that I am connected to my WiFi at home but actually I am using mobile data till I get a message from my mobile provider that I used 80% of my data.

    If there is no update, I guess I have to throw away the phone as it will be cheaper to buy a new one than constantly paying for new mobile data.

  • bmwiedemann bmwiedemann
     / 

    I have the same problem on my Nokia 4.2

    However https://www.reddit.com/r/GooglePixel/comments/jpnzkf/wifi_wont_autoreconnect_android_11/ indicates that it was also a problem for several other phones.


    There was also this new feature to decide which networks to auto-connect

    https://www.androidpolice.com/2020/07/08/android-11-lets-you-not-automatically-connect-to-specific-wi-fi-networks/ but it is already on by default.

Sign In or Register to comment.