WiFi connection issues with Nokia T10

Hi!

I got my new Nokia T10 just yesterday and in my 1 day use, I found that the WiFi stops to work after I put my tab to sleep for 4-5 mins. Basically, if I keep my tab idle for 4-5 mins with screen locked (display off) and then when I wake my tab, the WiFi simply shows "No internet connection". I have to restart my tab to get the WiFi working again.

Has someone faced a similar issue?

Comments

  • yes, just received my T10 4g but have no sim. initially connected to wifi and was streaming fine. now shows connected but can't provide internet, so is now useless. have powered off and on reset router and switched from random to device MAC, but still won't connect.

  • quick update. did full power off and on rather than restart and now to have reset and worked

  • Same here, Nokia T10 4G without a SIM atm. The Wifi stops working after the tablet is put to sleep for a few minutes. Everything works fine after Restart, or Power off -> Power on.

    Doesn't matter if you are using 2.4GHz or 5GHz, happens with the both of them. I've checked that the router uses Beacon Interval: 100, no help. I've set the tablet to use the device's own MAC address, no help. I've set the router to give static IP address to the tablet, no help.

    I hope they will sort this out soon, I would like to keep my tablet powered on, and not start/restart it when I want to use it.

  • DanielG
    DanielG
    edited August 18

    I'm having the same problem. I've had mine for one week now and I'm starting to lose patience with this device.

    I can see, when doing a search online, that for instance the T20 has got the same problem and it seems like Nokia haven't done anything about it the last couple of months. It's really depressing knowing that, was this just a waste of money? :(

    How can Nokia release this tablet knowing about the wifi connection problem?

  • It seems that there is now a software update out, at least here in Finland, let's see if it helps.

  • Hopefully the update fixes this issue. My problem at present is that I've been trying to get online for more than hour without success :( So I haven't been able to find out if there's any update here in Sweden as well.

  • For me it always fixed the issue when I restarted, or powered off -> on the device.

  • It doesn't. I don't know how many times I've deon that now. I've resetted the wifi settings a couple of times to no avail.

  • Unfortunately, the Wifi re-connect after sleep still doesn't work after Android 12 v1.100 software update. The Wifi worked after the software update & restart was done. Then I put the tablet on sleep for 10min, and after that the Wifi connection doesn't work. I tried with 2.4GHz and 5GHz, no luck.

    The situation actually got worse, and now the Wifi connection doesn't even work after restart, or power off -> on. WTF HDM Global 🤬

  • After doing a network connection reset, and powering off the device for 5min, then starting the device again, the Wifi connection worked. Then I put the device on sleep for 5min, and it doesn't work anymore. So no solution yet, not at least for me.

  • If your Android phone won't connect to Wi-Fi, you should first make sure that your phone isn't on Airplane Mode, and that Wi-Fi is enabled on your phone. If your Android phone claims it's connected to Wi-Fi but nothing will load, you can try forgetting the Wi-Fi network and then connecting to it again


    Regards,

    Will

  • The problem is that after the device is put to sleep for few minutes the Wifi connection doesn't work anymore, unless you restart or power off -> on the device. I'm a network engineer, so the problem is not the network, router or the device settings, it's a software bug or something, which does something when the device goes to sleep, and doesn't wake up anymore. Similar problems with the T20 tablet.

  • Got LTE Version today. Says No Internet but WLAN connected after a few minutes Standby. Only restart helps.

  • Guys, I am new here. I don't find a way to make a post here. How to make a new post on this community?

  • I am also having this issue with my T10. I have to turn the tablet off and on again to restore wifi.

  • Danielz
    Danielz ✭✭
    edited September 4

    Message deleted.

  • FYI, I've contacted their support about this and I'm going through this issue, I've done everything they have asked, even restored the tablet to factory settings, and this problem still persists.

    I also noticed, that it doesn't happen when the device is connected to a charger:

    - Tablet connected to a charger, set the device to sleep for 5min, wake up the device -> Wifi still works normally after that

    - Tablet using the battery, set the device to sleep for 5min, wake up the device -> Wifi doesn't work anymore

    I will let you know how this goes.

  • This issue has been flagged and is under investigation.

    So, we will have to wait for the next software update.

    The main find seems to be that when connected to a charger, there are no Wifi issues if the device is sleeping ~30min or less, after 1 hour the situation is the same as after 5min on battery, and only restart/power off->on fixes that situation.

    My guess is that there is some deeper sleep, which causes this, and when connected to a charger it just takes more time to get there, than when using the battery.

  • Hi, I have the same issue and also, my T10 reboots when it's sleeping.

    I tried much things, the standard solutions (soft and hard reset... And also tried many settings on developers options, don't activate the face unlock and many things, but I still have the same issue...

    I thing the firmware have bad datas, because just after the hard reset, wifi usage shows much hours of use...

    I'll wait above 2 weeks, if there's no updates, I'll send it back to be refundy..

  • The tablet being connected to a bluetooth device seems to prevent this bug too.