Netflix app doesn't work when a WiFi connection is used

I'm facing an issue with using Netflix app on Nokia 7 plus that I bought last week. The app doesn't work when the phone is connected to my WiFi network.

Netflix app doesn't work when a WiFi connection is used

berloo berloo
 / 
I'm facing an issue with using Netflix app on Nokia 7 plus that I bought last week. The app doesn't work when the phone is connected to my WiFi network. I looks like the app cannot connect to internet - it doesn't show any errors but signing in, starting a video streaming/downloading or running app's internal connection test lasts indefinitely. There is no such problem when the phone uses LTE connection. What's more, it also works correctly when the phone is connected to a WiFi network "tethered" by my other smartphone.

I'm pretty sure of my ISP and home network configuration since two other phones (Sony Xperia XZ with Android 8, LG Spirit 4G with Android 7), two laptops and a Chromecast Ultra device all work correctly with Netflix.

I'm confused because I've tried everything to solve the issue, including restoring the phone's factory settings and experimenting with different DNS services in my home network. Nothing has helped. Netflix's customer care hasn't provide any useful suggestion too.

I've found several similar issue reports on this forum which were submitted in last weeks. These reports are mainly related to Android Pie on Nokia 6.1 and 7 plus. Unfortunately, no response from Nokia.

Can anyone confirm the Netflix app issue described above? Maybe someone have an idea what the problem reason is or can suggest any solution?

Comments

  • ajbe ajbe
     / 
    The last couple of updates to Netflix have been rather buggy. I have had problems with the Chromecast icon disappearing. One option to fix this (for a while) is to uninstall and reinstall Netflix. Perhaps you could try that. When you run Netflix's inbuilt network test it gives a 404 error for internet connection but it doesn't seem to prevent it from playing movies.
  • berloo berloo
     / 

    I've tried to clean app data and reinstall it many times - it doesn't work. As I mentioned playing movies is not possible in my case (the app shows a loading circle and all the time).

  •  Same here on a nokia 6.1 just upgraded to android pie!

  • Kostas Georgiou Kostas Georgiou
     /  edited January 4
    Same problem also here on Nokia 7 plus. Netflix, yahoo and linkedin not working under wifi. On the other hand, under 4g they seem to work fine. I would like an official answer on this issue.
  • wyk wyk
     / 
    Is only netflix app not working?  Is youtube working ?
  • This would be down to netfix and nokia to work out and i see there is no help....WOw..
  • See also thread "WiFi issues after pie update"
    I am facing this issue also, cannot find a fix
  • Go to your router configuration page, then edit the internet settings. Look for MTU and put the value more than default but not more than default. Example MTU by default is between 1400-1499. Then put value 1450 and then save/apply the settings. Then restart your router. 
  • wyk wyk
     / 
    wifi issue is known issue..  may be fixed on upcoming updates. 
  • I think I fixed it, see the other thread "WiFi issues after pie update", MTU setting didn't fix, at least not by itself, had to turn on MSS Clamping in router.
Sign In or Register to comment.