Time Zone Bug

I'm in Hawaii - GMT-10. If time zone set to automatic it works correctly until losing internet connection, then jumps to U.S. East Coast time GMT-5.

Time Zone Bug

Islehopper Islehopper
✭✭  / 
I'm in Hawaii - GMT-10. If time zone set to automatic it works correctly until losing internet connection, then jumps to U.S. East Coast time GMT-5. The problem occurred twice in past week, both times when no data (wifi or 4g) connection available (e.g., Honolulu airport).

Setting to manually select time zone is the only solution.

This was not a problem on Oreo 8.1

Cheers

Comments

  • Hello. You can resolve that problem by doing a factory reset. I had this same kind of problem with Pie update and factory reset solved it.
  • maxh maxh
    ✭✭✭  / 
    I am on my way from the Philippines to the Netherlands at the moment and will come back on this issue.
  • maxh maxh
    ✭✭✭  / 
    As promised, back in the Netherlands. As soon as I turned on the phone the correct local time was displayed. Make sure Location, Automatic time and date, Auto timezone are on.
  • I have the exact same problem. I'm in Phoenix GMT-7. The phone is constantly resetting the time zone to GMT-5. It happens when coming out of airplane mode or when leaving WiFi . I have tried a factory reset and that has not fixed the issue. 
  • I have the exact same problem. I'm in Phoenix GMT-7. The phone is constantly resetting the time zone to GMT-5. It happens when coming out of airplane mode or when leaving WiFi . I have tried a factory reset and that has not fixed the issue. 
    Thats weird. My time zone was also jumping around, but factory reset resolved that issue permanently. Did you set up your phone as a new phone after factory reset?
  • I am having the same issue. Phone always reverts to EST. Will try factory reset and report back.
  • So did the factory reset at work, but no luck. As soon as I left building WiFi, the default time zone jumped back to EST.
  • I have the same issue.  Should be PST, keeps jumping 3 hours ahead to EST.  Please fix.  Thank you!



  • maxh maxh
    ✭✭✭  / 
    When you go back one menu, is your 'Own timezone' correct? 
  • Same issue here, changed time setting to manual for now.
  • maxh said:
    When you go back one menu, is your 'Own timezone' correct? 
    Going back one screen has wrong timezone also.  Just happened again.  :(

  • Mine keeps going back to EST too. If I toggle it to manual then back to auto, it picks up my correct time zone. Within a few minutes it reverts back to EST. 
  • akbrian akbrian
    ✭✭  / 
    Same exact issue. Setting the time zone by network results in phone setting itself to US Eastern standard Time sooner or later. This has happened in Pacific, Alaska, and Hawaii time zones. I'm now using manual mode to avoid the problem.
  • Nokes Nokes
     / 
    Add me to the list of people not happy.
    I've got 4 of these phones and all 4 of them are doing it.  Ridiculous
  • Well, it's not big deal. Set it manually and when boarding a plane switch it back to automatic. Not hard to remember.
  • Same issue on 2 different phones.  The option to pick a timezone manually is garbage.  These are modern smart phones, not dumb mid-90's technology.  Nokia, please fix what can't be a hard bug.
  • Niksoj Niksoj
    ✭✭  / 
    I have the same issue.  Should be PST, keeps jumping 3 hours ahead to EST.  Please fix.  Thank you!
  • Islehopper Islehopper
    ✭✭  / 
    searching this bug on google just now, appears to be an android pie bug affecting OP and others. setting manually isn't a big deal and actually how I prefer to travel (set destination time zone before falling asleep on flights), but the issue still is a bug in need of a fix. cheers and happy new year, y'all.
  • srvks srvks
    ✭✭  / 
    Yes I too it. I resolve it by toggling the Automatic date and time option.
  • waded waded
    ✭✭  /  edited January 8
    Same issue (time unexpectedly changes to Eastern US) here with two different Nokia 6.1 phones. Restarting the phone or waiting a few hours seems to correct the time, but the problem recurs. Location is shown correctly in Google Maps even while time is not.

    I haven't pinned misbehavior trigger on network availability as a few of you have. That seems possible though.

    Setting timezone manually is not a viable workaround for us since we use Google Family Link, which locks time/zone to automatic.

    We upgraded both phones OTA to Pie, and then December 2018 update, right out of the box, so I'm disinclined to try factory reset as a workaround.

    I'd like to see this addressed in an update.
  • Mat Melton Mat Melton
    ✭✭  / 
    Same issue for me
  • waded waded
    ✭✭  /  edited January 11
    Because this screws up use of Google Family Link bedtimes/screen-time on the Nokia 6.1 pretty throughly (phone locks at some irrelevant time, rather than actual lights-out time) I passed this thread on to Google for Families support. Hopefully that lights a fire somewhere leading to a fix.
  • I am seeing this too, it did not happen until I returned from a trip to Europe. 
  • KevinW KevinW
    ✭✭  / 
    same problem with Nokia 7.1, I noticed it when using Family Link.
    my post
  • It's an Android bug that had been around for a while, or at least it was an issue that was fixed and now has returned. Could be a different cause. I had this issue as well, but on 8.1. It would keep setting it to the next time zone over based on location. The next time zone over is few hundred kilometres in a drect line, I'm not living on a time zone border! 
  • KevinW KevinW
    ✭✭  / 
    same problem with Nokia 7.1, I noticed it when using Family Link. My post
  • A few months passed, and obviously still no fix.
  • waded waded
    ✭✭  /  edited March 23
    Still an issue as of last week. Both our Nokia 6.1s temporarily get two timezones off (from Mountain US to Eastern US) in specific situations, e.g. when leaving Wi-Fi. This time it happened repeatedly when we were out of town but still supposed to be in Mountain zone, so it's not just our neighborhood cell. Turning off auto time zone continues to not be a viable workaround if using Google's Family Link.
Sign In or Register to comment.