Camera now records in mono only with Android 10

Anyone else noticed the Ozo recording is now mono since the update? The Sound Recorder app (Google: sound recorder xda nokia) is also mono now.

Camera now records in mono only with Android 10

Mark Coley Mark Coley
✭✭✭  / 
Anyone else noticed the Ozo recording is now mono since the update? The Sound Recorder app (Google: sound recorder xda nokia) is also mono now. Both recorded in Ozo stereo before the update.

Comments

  • seanetta seanetta
    ✭✭✭  / 
    You are correct as i just tested mine and it is definitely mono  :/  
  • Mark Coley Mark Coley
    ✭✭✭  / 
    Can anyone else confirm/refute this?
  • xavito83 xavito83
    ✭✭  /  edited October 2019
    the ozo audio is loaded, I imagine they will solve it in the next updates
  • seanetta seanetta
    ✭✭✭  / 
    xavito83 said:
    the ozo audio is loaded, I imagine they will solve it in the next updates
    Loaded?  
  • Mark Coley Mark Coley
    ✭✭✭  / 
    I've sent an 'e-mail' via the link at the bottom of https://www.nokia.com/phones/en_gb/support/topics/camera-and-photos reporting this fault.
  • Mark Coley Mark Coley
    ✭✭✭  / 
    Standard reply from Nokia that they are looking into the issue. Can I suggest others contact them using above link?
  • Mark Coley Mark Coley
    ✭✭✭  / 
    Nokia asking if I can try safe mode... Press power button to bring up menu then press and hold off icon till it asks about safe mode. I have no way of checking at work as I have no headphones so it'll have to wait.
  • Mark Coley Mark Coley
    ✭✭✭  / 
    In safe mode it records in stereo again! But reverts to mono on rebooting. What's going on?
  • Anton P Anton P
    ✭✭  / 
    @mark coley, can you share samples of mono and stereo video recordings of the same source in order to see the difference? Also, please post it in the pinned thread for Android 10 post update problems that @HMDLaura posted.
  • Mark Coley Mark Coley
    ✭✭✭  / 
    Just do a five second recording moving the phone as you speak then listen to it with headphones in.  You should be able to tell it is mono. You can rub each of the mics in turn, then rub both at the same time. If recording  is in Ozo stereo an individual microphone rub will be placed in the centre of the stereo field, but if both rubbed at the same time you should get some artificial stereo separation as the Ozo algorithm gets confused.

    Reboot to safe mode and repeat and you should see the difference.
  • Mark Coley Mark Coley
    ✭✭✭  / 
    https://photos.app.goo.gl/QDYt76aqMZWAiNji6

    Two videos, phone on ironing board and I banged a cup as I was moving it left and right. Only the one done in safe mode has stereo separation.
  • Mark Coley Mark Coley
    ✭✭✭  / 
    Nokia/HMD has replied saying they will inform the developers and have given me the option of having my phone sent off so the operating system can be reinstalled...
  • Strvr Strvr
    ✭✭  / 
    Yes me too, exactly same issue here... On safe mode it works fine but not in normal mode
  • Turvamies Turvamies
    ✭✭  / 
    [{"insert":"Hi!\nI have two identical (down to hardware firmware level) Nokia 8.1 phones. One of them has the \"audio recorded in mono only, unless running in safe mode\" issue while the other one is working perfectly.\nI've checked and double-checked everything, and the audio really is recorded in mono -- it's not about the audio output settings, the recording really is mono. Unless the phone is booted to safe mode.\nI tried sending e-mail to Nokia but I'm not sure if the form worked; I didn't get any confirmation that the message would have been sent. And yes, the ReCaptcha was filled properly.\nI think the issue may have to do with some app, since in safe mode (when any third party apps are not running) the audio is just fine.\nCan I please ask everyone with the mono only issue to share a list of all the apps you have installed, so we can try finding out if some specific app is present in all of the phones experiencing this problem. Thanks!\n"}]
  • Mark Coley Mark Coley
    ✭✭✭  / 

    Camera still records in mono after today's security update. You can get stereo recording if you boot into safe mode first.

  • manna manna
    ✭✭✭  / 

    Nokia forget the software importance of mobile phones...still no updates for camara UI....do something like Samsung....

  • Praveen.b Praveen.b
    ✭✭✭  / 

    Iam getting stereo output after the last update.

  • Mark Coley Mark Coley
    ✭✭✭  / 

    There is output on both channels but the signal is identical on each. There is no stereo separation.

  • Jason624766 Jason624766
    ✭✭  / 

    I was hoping the update will get the problem fixed, unfortunately it's still unraveled...

  • dray78 dray78
    ✭✭✭  / 

    I noticed the same. The mic at the bottom isn't recording. In Safe mode it does.

    I'm going to report this.

  • dray78 dray78
    ✭✭✭  / 


    @Mark Coley

    Today i got this mail from Nokia (read below). I tested video shooting after i deleted the rights of the third-party apps such as FB and even the android messages app etc. And to my suprise it was recording it correctly. So for me this is a bug. My phone must be able to shoot video with ozo giving other apps the mic rights.

    Greetings from Nokia Mobile Care.


    Thank you for your feedback and for the information you have provided us, but in order to proceed with further analysis and to reproduce this issue on our device we would be grateful for some additional information:


    For your information, we have already tested on our Nokia 8.1 devices and we were not able to reproduce the issue, as all our cameras were able to record stereo without any issue in both normal and safe mode.


    In Safe Mode, only the built-in applications will be running: Safe Mode strips the operating system to its core functions, preventing you from running anything that didn’t come preinstalled on your phone. In this way, we can make sure the issue is or isn’t related to one or several applications you have installed later on.


    In this case, if your device works normally, it is able to record Stereo audio while recording video but in normal mode only Stereo, the reason causes this issue might come from the third-party apps or widget that you have installed in your phone that in Safe Mode has been temporarily disabled.


    Do you have any third-party applications installed that have access to your microphone beside the built-in camera app? If you do please try to uninstall it or disable it temporarily and check again if you are able to record Stereo audio while recording video?


    May I know how do you confirm the audio of the video recorded in Stereo or Mono? Could you please transfer the video to your PC and check again if it's with stereo audio?


    When you start recording a video, do you notice any notification on the screen like "OZO audio"?


    Please try the trouble shootings below and give us feedback if they work or not:


    Settings > Apps and notifications > See all apps > Camera > Storage > Clear data and Clear Cache

    Camera > Options(3 lines on the upper left corner) > Reset settings

    Settings > Apps and notifications > See all apps > Google Play Services > Storage > Clear data and Clear Cache


    After that, please do a Soft reset:


    First, unplug it from the charger if it's charging.

    Then hold the Power Button + Button Volume UP for 10 seconds until your phone will switch OFF - release the keys.

    Then hold the Power Button to turn it ON again.


    If still is the same issue, please uninstall Camera app update: Settings > Apps and notifications > See all apps > Camera > Options(3 dots on the upper right corner) > Uninstall update


    Remember that you are important to us and we're looking forward to your response.


    Wish you all the best.


    Best regards,

    Nokia Mobile Care

    Lee


  • Mark Coley Mark Coley
    ✭✭✭  / 

    I tried removing all permissions from other apps except Camera to use the microphone and I still only get mono recording.

  • Mark Coley Mark Coley
    ✭✭✭  / 

    Solution found!

    Go to:

    Settings / Apps & Notifications / Advanced / Permission manager / Microphone / Three-dot-menu at the top right / Show system / Google / Deny

    and you get stereo back! You also get stereo recording back in the Sound recorder program that's on the XDA website.

    I have also discovered (thanks to Hans who posted a comment on my shared videos) that if you start the camera app in portrait mode it will only record a mono signal (but sent to left and right channels). If it is landscape mode when you press record then you get a stereo field.

  • Mark Coley Mark Coley
    ✭✭✭  / 

    The above fix stops 'OK Google' working. The problem seems to be that the 'OK Google' service is grabbing the audio and passing a mono version to any running app. If you have it set to 'Allow' instead (see above) you can say 'OK Google' whilst recording a video and it'll stop, which clearly it shouldn't do.

  • dray78 dray78
    ✭✭✭  /  edited December 2019

    @Mark Coley

    I denied the rights for Google to and yes seems to work. To use "ok Google" again i tapped the mic in the Google bar and gave back the rights.

    Then i recorded a video and scratched both mics and that worked.


    Edit: In my native language i cannot use all options such as "voice match". That why "ok Google" doesn't work while recording a video.

  • dray78 dray78
    ✭✭✭  /  edited December 2019
  • Mark Coley Mark Coley
    ✭✭✭  / 

    The Google app was updated 2nd January. I seem to be able to have OK Google turned on (with appropriate microphone permissions to allow this) now and get stereo recording with the camera app, which was not possible before. Can others check if this bug has been resolved for them as well? The recorder app (from the XDA website) is also recording in stereo. I'm still on the November security update too for the phone.

  • Mark Coley Mark Coley
    ✭✭✭  / 

    I have tried it again and it seems back to the old behaviour so I'm not sure what was going on. I had tried it out in my car whilst connected to the in car audio via bluetooth. I had given audio permission to the Google app, checked OK Google worked, which it did, then I did a test video recording and a test audio recording and they both then played back in stereo via the car audio. OK Google was still responding. Now it seems to be back to mono recording if OK Google has permission to use the microphone.

  • gonsvq gonsvq
    ✭✭  /  edited January 5

    Seriously, I'm disappointed with Nokia. Did they test the update before sending it over to us >:(

Sign In or Register to comment.