My Nokia 7.2 randomly stops making and receiving calls, Nokia won't repair it or give a solution

Since I bought my Nokia 7.2 it has an issue with phone calls.

My Nokia 7.2 randomly stops making and receiving calls, Nokia won't repair it or give a solution

Spitfire Spitfire
✭✭  / 

Since I bought my Nokia 7.2 it has an issue with phone calls. Randomly, it stops being able to receive phone calls (it just appears as off or out of coverage for the other person) and to make them (it keeps trying to establish connection for a while and then it hangs itself).

As I didn't have any alternative, I just lived with it until I recently bought a new phone. I sent it to the Nokia Mobile Care service to repair it, because I was planning to give it to a relative, and they returned it unrepaired because "No Fault Found".

I contacted Nokia customer support via email, just in case I could do something to fix it or for them to acknowledge that it was faulty, and they told me to send it again for repair. This time I even recorded several videos proving the issue and explaining everything as detailed as possible.

Well, yesterday I received another email stating that the phone would be returned again unrepaired because no fault was found.

I honestly regret buying this device on Nokia's online store. Now have a faulty phone that won't be repaired and a meaningless 3 years extended warranty.

By the way, after little more than a year the battery has degraded awfully, not to mention how much it is left to be desired these last months regarding security updates and the Android 11 upgrade. This was my third Nokia smartphone and it may be the last, at least for a long time.

Tagged:

Comments

  • Spitfire Spitfire
    ✭✭  / 

    I will try that once I get back the phone, but I'm fairly sure it shouldn't be because of the filters because it happens with any phone number for both incoming and outgoing calls.

  • Spitfire Spitfire
    ✭✭  / 

    I have already performed several factory resets and the issue is still present with no apps installed besides the default ones. I have asked for a SIM replacement to my company and used a SIM from a relative, but with the same results (although currently I have no way of trying it with a SIM from another company).

    It shouldn't be a reception problem since it happens everywhere and both my previous phone (Nokia 7.1) and my new phone (not a Nokia) don't have this issue.

    I have zero problems with internet reception. I have noticed that it switches from 4G to 3G/H+ when it tries to establish a call although right now I can't remember if it does it every time or only the times when it actually works. I will check once I get my phone back.


    And hey, thank you very much for the help. 👍️ Just with that post you already have dedicated much more attention to my issue than Nokia's official customer service.

  • RazzSahani RazzSahani
    ✭✭✭  / 

    You should contact your SIM operator once

  • Spitfire Spitfire
    ✭✭  / 

    Already did, according to them nothing is wrong on their side.

  • Spitfire Spitfire
    ✭✭  / 

    @Lior Levi

    After receiving the phone and doing some tests I think I have narrowed down the cause of the issue.

    If you set the phone to only use 3G/2G networks, it works well 100% of the time. If you activate 4G, it should automatically switch to 3G/H+ to establish the call. However, half of the time it seems like the network module crashes in the process (switches to 3G, then it completely loses network coverage, it recovers it again without data and finally recovers 3G, but at some point in that process either my phone or the other one gives up trying to establish the call).

    How this phone was supposedly inspected twice and both times Nokia determined that nothing was wrong with it is beyond me.

  • Spitfire Spitfire
    ✭✭  / 

    The exact same SIM card works perfectly well with a Nokia 6, a Nokia 7.1 and a brand new phone from another company, so I don't have any reason to think that this is related to the cellular network...

  • hksenadeera hksenadeera
    ✭✭  / 

    I have Nokia 7.2. From June 01st 2021, when I try to take a call or do internet transactions in 4G settings, the signal bars/ network goes blank and wi-fi disappear with the message " No network found " I spoke to chat support and did everything except a factory rest and it did not solve the issue. Later when I changed the network settings to 3G there is no issue, info I gathered in this support group. As of now I am using the phone in 3G mode to overcome the problem.

    Nokia support advised me to update Android 11 and check but I did not receive the update as of last quarter as promised by Nokia.

    I still have to use 3G network setting on my 7.2 to overcome the problem.

  • Hi @Spitfire , when forcing the 3G mode only, did you also turn off the "Enhanced 4G LTE Mode" option right above the preferred network type? 🤔

    Anyway, it was good to read you post as I have been facing the same problem with my Nokia 7.2 and this is becoming very annoying.

    Hope it does work well on my phone too! 🤞

  • Spitfire Spitfire
    ✭✭  / 

    Hi,

    that setting doesn't show up for me, maybe it depends on the carrier.

    Anyway, I tried forcing 3G and I discovered that in that mode after a while it randomly loses coverage completely until I turn on and off airplane mode 🙃

    So yeah, unless Android 11 somehow fixes this we are screwed.

Sign In or Register to comment.