My Nokia G50 (5g)won't update to the latest google security patch

Lamis Douglas
Lamis Douglas ✭✭
edited October 2022 in Nokia G50

Hello everyone 🤝

I have a Nokia g50 and for some reason it won't update to the latest google security patch. Which is the September 9th version. I was wondering do you guys have any suggestions on how to fix this ?

I tried removing the sim and updating and it didn't work.I also did a factory reset and that didn't work.


I'm hoping to fix this 🥺

Tagged:
«1

Comments

  • singhnsk
    singhnsk Super User

    Hi, where exactly does the problem happen? Did you not receive an update? Or the update just fails to install and gives out an error message?

  • ngoma01
    ngoma01 ✭✭

    Same thing with mine.

    Here some screenshots ( sorry they are in french ^^).


  • bisp
    bisp ✭✭

    Hi. I have the same problem with my G50. I've tried the update several times. Most times it won't even make it to the "downloading" page before failing, but twice it made it most of the way through the download before returning the "couldn't update, installation problem" screen.

    The phone was restarted prior to attempting the update and has no other known update issues, so this appears to be related only to the 2022-09 security patch update.

  • Lamis Douglas
    Lamis Douglas ✭✭
    edited October 2022

    Thank you for your responses

    With regards to your first question, the update fails to install.

    There are times where it tries to load but then it's as if something inhibits it from downloading.

    This is actually my first time owning a Nokia phone, I was really happy when I got it but now, I am worried I won't receive any further updates. In addition to that, I would like to ask do you guys know any Nokia care centres where you currently reside?

    If you do, could you inquire about this issue.

    Also, if there are any further updates on your situation's please don't hesitate to contact me :)

  • bisp
    bisp ✭✭

    To close the loop on this issue, at some point during the past week or so the system update completed without any additional intervention so someone behind the scenes must have corrected the problem.

    My phone is once again up-to-date so many thanks to whoever resolved the issue.

  • Lamis Douglas
    Lamis Douglas ✭✭
    edited November 2022

    Yes thankfully the issue has been solved with the recent October update.👍🏽

  • cyberquake
    cyberquake ✭✭

    I'm having the same issue with November patch. Fails to install even on safe mode.

  • hossthemover
    hossthemover ✭✭

    My phone still has not updated and is running very slow with program interruptions, ie; disconnect/wait/etc.

  • motionseverywhere
    motionseverywhere ✭✭
    edited March 11

    I basically have the same problem with my G50 now. Another G50 in the family updated fine.

    But mine it showing the update over and over again and trying to install it, fails in the same way.

    actual configuration: Android 13 Build-Number 00WW_3_200

    missing update: Google security patch 2023-02

    error says (translated): error on updating - installation problem

    Any idea to get the patch installed?

    Or any idea to get more details on the installation failure (like an error log) to find the root cause of the problem?

  • Orlando Guggiari
    Orlando Guggiari ✭✭

    Hello,

    I have the same problem here and my last google security patch is from octobre 2022. It constantly fail to install the new one.

    Any solutions would be appreciated.

    Thanks

  • actually my phone stopped complaining about the missing 2023-02 patch.

    Latest installed is 5th Nov. 2022 and no new updates are detected.

    Did Nokia canceled the feb.2023 update until a new release?

  • Farmerbubba67
    Farmerbubba67 ✭✭

    G50 owner here, having the same issue, constant errors, fails to download period. It will sometimes act like it's downloading but then give the installation problem error.


  • AMJITH
    AMJITH ✭✭✭

    Have you tried with different network providers.factory reset or without sim.earlier times nokia phones tend to work on updates like this.

  • klightspeed
    klightspeed ✭✭

    On my phone, after attempting to install the 2023-03 update, then restarting after getting the Installation Problem error a couple of times:

    • The wifi is broken (Device Wi-Fi MAC address shows "Unavailable", no networks are found, and the wifi switch doesn't stay on)
    • The fingerprint sensor no longer seems to be detected (Searching fingerprint in settings gives nothing, and one of the apps that allowed using biometrics to unlock it was no longer giving that option)
    • The 4G connection keeps dropping every couple of minutes
    • The device is often unresponsive (even in Android Setup after doing a factory reset)
  • I'm having the same exact problems like klightspeed describes. I just spend 20 minutes with Nokia Support, who informed me that the problem is known and an update will be provided in the future that should fix it.

    I have doubts that it will work because of the dropping 4G connection but I will give it another week before taking further action.

    A broken update pushed by Nokia should qualify for a replacement under EU law.

  • klightspeed
    klightspeed ✭✭

    I did find it funny that the 4G didn't drop for about 5-10 minutes while I had the camera active, but dropped within about 30 seconds of the screen going to sleep (popping up the notification to connect to a network for app updates)

    I also find it funny that the Nokia SmartService site that support directed me to is currently getting an "Server Error in '/' Application" after clicking Next on the Terms of Service page, and that it is not https

  • Mark Sunico
    Mark Sunico ✭✭

    Mine is still stucked on Nov update. I tried sideloading the ptch thru adb. But gave an error. Manifest parse error.

  • amfh9088747
    amfh9088747 ✭✭
    edited May 8

    Mine is still on the Nov update too-tried different network providers-both a Vodafone and Telstra SIM inserted into my G50 and without a SIM inserted and mine is still showing "your system is up to date".

    Tried the usual tricks (VPN, etc) still on the Nov update.

    My G50 is TA-1361, 4/128GB ANZO in Ocean Blue and have yet to receive the latest securuty update.

    Build currently on mine is 00WW_3_200.

    Has anyone in Australia received the most recent security update on the G50 yet?

  • AMJITH
    AMJITH ✭✭✭

    Do you have nokia care services there,like shops

  • Lamis Douglas
    Lamis Douglas ✭✭

    Sadly where I live there aren't any

  • amfh9088747
    amfh9088747 ✭✭

    The 2023-04 partrch came through on my TA-1361 after removing my Telstra SIM card.

  • motionseverywhere
    motionseverywhere ✭✭

    The security update 2023-04 was shown today.

    Just installed it without any issues. So it seems the 2023-02 (revoked) was just badly created.

  • mihi
    mihi ✭✭

    Now having the same issue with the 2023-07 update (current version is 2023-06 build 00WW_3_320)

    Screens look like in the thread already posted (only in German :D)

    Adb logcat shows an "Unrecoverable source hash mismatch error."

    Will probably have to wait for a corrected update.

  • Oplossine??????

  • NOKIA: Komt er een verbeterde update????

  • thorstencoordes
    thorstencoordes ✭✭

    I have two G50. One has updated and one doesn't want to install 3.320 with the above error.

  • Same problem here...


  • I have the same issue with the version Android 13 V3.320, security patch 2023-06. Couldn't upgrade, installation problem.

  • I had a similar problem in October 2022 which was resolved in November when something changed behind the scenes -- I did nothing additional to enable the update to load properly.

    I now have the exact same problem and error message appearing with the Android 13 V3.320 update (which includes the 2023-06 Google Security Patch). This has been a problem for more than one month though and it continues to fail each time I try to load the update.

  • My NOkia g50 phone is not allowing the software to download the new version of the software and it keep sending me reminders it annoys me now how can I resolve this .