33 W PD3.0 fast charging issue

Has anyone what found an issue where the phone pauses charging for a couple of seconds then reconnects when fast charging? It's more noticeable in bedtime mode where the green goes monochrome as it goes back to colour due to the 'disconnect'. It only seems to happen when the phone is quick charging, not when it's slower charging.

Many people may be using an existing Nokia charger or anther charger that doesn't charge as fast, so the problem may not present itself. I'm using a good quality 5 amp USB cable and an Australian version of the Anker nano II 65 W charger.

I've tried multiple cables. It only happens with this and other chargers that support the full 33 W charging via PD 3.0. Normal 18W charging I haven't seen it yet.

I believe it's a software issue, but want to know if others have come across this. It may have gone unidentified simply because many may only have a charger that supports a lower charging rate.


  • The new build doesn't have the issue, as it now limits me to what I believe is 10 W charging. Either it is a faulty phone or they realised there is an issue and disabled it.

    Many people may not notice as they may not be using a charger capable of the full 33 W charging this phone supports.

    You can see the mAH of charging by using Ampere from the Google Play store.

  • I am only getting circa 8watts using a 30w charger and a cable rated for 66watts. This is measured via accubattery

  • I use a 100w charge, also no 33w output

  • singhnsk
    singhnsk Super User

    Those 100W BBK Electronics (OPPO family) or Xiaomi chargers will not be compatible with Nokia.

    Nokia will only support charging via QuickCharge standard or USB Power Delivery (PD). So, please retry with a PD charger.

    Although the fast charging bug doesn't seem to be fixed yet, your issue will not be fixed anyways due to an incompatible standard adopted by the charger maker.

    AMJITH ✭✭✭

    I bought a new 33w fast charger from nokia to charge my phone x20 (18w) faster i thought.but i was wrong,that thing charges with its minimum 15w.

  • Sorry but this isn't why there's a charging issue. To get the full 33 W charging you need a PD 3.0 charger that supports PPS. My charger fully supports this. Even the genuine Nokia charger specifically released for this device charges at less than half rate.

    The issue is a firmware bug where the battery type is not being detected. Without this, all chargers will default back to standard charging.

    Full PPS charging has never worked properly on these phones as originally it would disconnect them reconnect when running at close to maximum charging rate (even with the genuine charger). There's Akzo a battery drain bug where even not using the device the battery will drop more than it should over the day. The new Samsung's put it to shame.

    It's quite possibly why Android 13 is taking so long to become available for it. In any case it's the phones firmware, NOT the chargers at fault.

  • singhnsk
    singhnsk Super User
    edited April 21

    Hi @user1529883076460, I did not deny that the phone is not its fault. I just said that BBK's and Xiaomi's chargers would not work on the Nokia anyways, even when (and if) Nokia fixes the issue on the device. BBK uses a different (proprietary) method to transfer high-voltage charge and it only works on VOOC-enabled devices.

  • I understand that, those systems are not part of the USB standard. but PPS is. Nokia claims the X30 supports it, so if it doesn't it should be removed from the specifications. If you have a PPS charger you should get PPS charging. The only method of charging this phone at the maximum 33 W is with PPS. I believe otherwise it's around 18×W via QC 3.0. With the current Android build you are limited to ariund 10-12 W basic charging.

    Either they disabled it deliberately due to PPS issues, or they tried to fix it and stuffed it up. The issue has absolutely nothing whatsoever to do with the charger. It's probably not doing the phone any good on the most basic of charging. They may have fixed it in Android 13, and if not the phone is a bit of a dud. There is no way around this.

    People even using the genuine Nokia 33 W charger, which is a PPS charger, are limited to basic charging. The charger would support any device that supports PPS, but currently as the X30 is the only Nokia device to ever support it so far, it's a waste of money. Particularly true when there are other good brand options out there.

    Check under 'Battery and Charging': https://www.nokia.com/phones/en_au/nokia-x-30/specs?sku=VMA751S9FI1AL0

    Clearly stated 33 W and PPS.

  • It appears that you are experiencing an issue with your phone while using a 33 W PD3.0 fast charger. Specifically, you have noticed that the phone pauses charging for a few seconds and then reconnects when fast charging, which is more noticeable in bedtime mode. This issue does not occur when the phone is charging at a slower rate.

    You mentioned that you are using a good quality 5 amp USB cable and an Australian version of the Anker nano II 65 W charger. You have also tried multiple cables and noticed that the issue only occurs with chargers that support the full 33 W charging via PD 3.0.

    Based on your observations, you believe that this may be a software issue, and you are curious if others have experienced this problem.

    While I am not aware of any specific reports of this issue, it is possible that others may have encountered a similar problem. If this is a software issue, it may be helpful to check for any available updates for your phone and charger.

    It is also possible that the issue could be related to the compatibility between your phone and the charger. You may want to check the specifications of your phone and the charger to ensure that they are fully compatible with each other.

    In any case, it may be helpful to contact the manufacturer of your phone and charger for further assistance with troubleshooting the issue.

  • The battery type ever since that Android 12 build update is listed as 'unknown' in CPU-Z, Ampere, and other apps. Previously it was detected correctly. I believe this is the root cause of the issue.

    Most people may not have a PPS charger, and even with a QC 3.0 compatible charger the issue may not be noticed apart from slow charge times.

    Please note this phone should charge very quickly. How long does it take for yours to charge from say, 40 percent? What does Ampere, CPU-Z etc show as your battery type?

  • I invested time and diligence in ensuring that the charger I bought meets the requirements for fast charging my X30. The fact that my phone never exceeds 11w charging is definitely an issue with the phone. HMD continue to market the X30 as being capable of charging at 33W. It blatantly doesn't. I bought the X30 with fast charging a requirement. I won't make the same mistake again.

  • Yes, it's possible that other people have experienced the same issue with their phones pausing charging for a couple of seconds and then reconnecting when fast charging. This issue may not be noticeable for those who are using a slower charging method or a different charger that doesn't support fast charging.

    Based on the information provided, it seems that you have already tried using multiple cables and chargers that support the full 33W charging via PD 3.0. If the issue only occurs with these types of chargers, it's possible that it could be a software issue.

    To determine if others have experienced this issue, you could try searching online forums or contacting the manufacturer of your phone to see if they are aware of any similar issues. It's also possible that there could be a firmware update available that may help resolve the issue.

  • Hi All

    Any recommend a make of wall socket for faster charge on my X30



  • You literally will not get faster charging if there is an issue with the software as discussed. If Ampere, CPU-z etc report battery type as unknown, you will be limited to only basic legacy charging of around 10 W. Charging via QC 3.0, or the full 33 W charging via PPS, won't be available.

    This is the charger I'm using:

    It's a variation of the 715 available in the US. I like to reiterate, as it stands you will not get any faster than around 10W maximum or so regardless of the charger or cable used, until such time the battery reporting issue is resolved.

    If Ampere or CPU-Z correctly retorts the battery type than any decent PPS charger of 33 W or more will charge your device at design speed (33 W). This is of course is maximum rate, it will drop as battery charge approaches full. Currently it's only 10 W or so that also drops off to a mere trickle near full charge.

  • mr. nokia
    mr. nokia ✭✭

    If it helps, I have bought the Nokia Fast Wall Charger 33W EU - Black official charger and maximun I can get is 24W.

  • user1529883076460
    user1529883076460 ✭✭✭
    edited May 13

    Do Ampere, CPU-z, etc show the battery type correctly on your device? What build number do you have installed?

  • mr. nokia
    mr. nokia ✭✭

    Here is what Ampere shows.

  • oliver05
    oliver05 ✭✭

    If you are experiencing issues with 33W PD3.0 fast charging, here are some troubleshooting steps you can try:

    1. Check your cable: Make sure that you are using a cable that is compatible with 33W PD3.0 fast charging. If your cable is damaged or not the correct type, it can cause issues with charging.
    2. Check your charger: Make sure that your charger is compatible with 33W PD3.0 fast charging and that it is working properly. If your charger is not functioning correctly, it can cause issues with charging.
    3. Check your device: Make sure that your device is compatible with 33W PD3.0 fast charging and that it is working properly. If there are any software issues with your device, it can cause issues with charging.
    4. Restart your device: Sometimes a simple restart can fix the problem. Turn off your device completely, wait a few seconds, and then turn it back on.
    5. Update your device: If your device is not up to date, it may be causing issues with charging. Check for any available software updates for your device.
    6. Contact the manufacturer: If none of the above steps work, it's possible that there is an issue with your device or charger. Contact the manufacturer for assistance with troubleshooting the problem or for warranty support if necessary.

    In general, it's important to use only compatible cables and chargers with your device to avoid any potential issues with charging. If you continue to experience issues with 33W PD3.0 fast charging, it may be helpful to consult with a technical expert or a qualified repair technician.

  • Apologies for my late reply 🙂.

    Yes, that's exactly the issue. Fast charging has been unavailable every since that changed from the correct lithium battery type to 'unknown'. It's definitely a firmware issue.

  • user1529883076460
    user1529883076460 ✭✭✭
    edited May 21

    Good advice in general, Horace it is not the issue with the X30. As mr. nokia posted above, the battery type is unknown (as reported in any app). Fast charging only became unavailable when this changed from the actual type to 'unknown'. You simply won't GET the full 33W PPS or a bit less with QC 3.0 as a result. You are limited to standard USB charging only.

    It's definitely a firmware issue that is either deliberate (as there's an issue with fast charging, or an issue with certain devices), or they stuffed up and overlooked it for a couple of builds. I'm beginning to think it's deliberate and hoping nobody would notice. You would only notice it if you have a PPS charger, and may notice it if you have a QC 3.0 charger without PPS (PPS is more advanced and faster).

  • Still an issue even now. Anyone what experiencing it?

    I reiterate, it's NOT the charger, cable, etc. It's definitely the phone's software, caused by the battery type not being reported. Without this reporting, only standard USB ~10 Watt charging is available, instead of quick charge or the advertised 33 Watt PPS charging. PPS charging is supposedly also better for battery life. This only happened after an update, and others have reported it as well. I'm not sure whether it's widespread though.