WiFi issues after Pie update

edited November 2018 in Nokia 7 plus
After the Pie update on my Nokia 7 Plus, several apps can no longer connect to the internet over WiFi. I initially thought it was an issue with the broadband connection and after a lot of back and forth with my ISP, I realised that the issue is with my phone. The same apps work perfectly fine as over mobile data. Some of the apps that can't connect via WiFi include Netflix, Google search app and Twitter. The same apps also work on other devices so I know for sure it's not my ISP. I tried factory reset and the issue still persists. This is a very serious issue that Nokia need to investigate. My phone is disfunctional if my apps don't work. Is anybody also facing the same issue after the Pie update?


  • user1536216355668
    edited October 2018

    I am facing the same problem in Nokia 6.1+ with sony liv, amazon and phone pe in my wifi.  They work good in wifi of some ISP and and does not for some. I am really confused and cannot blame the ISP for this as well since it is working fine in other mobile phones.. 

  • petzorton
    edited October 2018
    I have the same problem in Spain with Movistar at home, problems with Firefox, Facebook, Google.Play, etc. In the same house there are LG G6, iphone, Moto G, and W10 laptop and no problems, only my Nokia 7+ with Android P, all works fine with 4G
  • user1527768874830
    edited October 2018
    I got a 6.1 (that released a few weeks ago) and even her phone has the same issues. It's surprising that Nokia would send such patchy software to its phones. I must admit, clean software was the reason I got a Nokia. But now I'm having my doubts.

    7 plus and 6.1 are affected
  • user1527768874830
    edited November 2018
    Nokia can you please acknowledge that you are investigating this issue?
  • Using VPN will help for time being.
  • The wifi issue i mentioned earlier has been resolved in Pie Update. It is working fine now.

  • I am also facing wifi issues after the update, pubg dont run smoothly due to the internet problem, my wifi and cellular both works fine so the problem is in my phone. To even load Instagram images, send images videos or even a link, i need to disconnect and reconnect my wifi and cellular to work it properly again and after few time I just need to do the same procedure over and over. Is there anyone who is facing the same issues? I think it's after pie update.
  • my nokia 6.1 plus suffer from problem of wifi after update of pie
  • I'm still experiencing this issue with my Nokia 8 after the December update to Pie. I can't use Netflix and Amazon music. Does somebody have news?
  • wyk
    wyk ✭✭✭✭
    Is it only effecting specific apps? ? 
  • wyk said:
    Is it only effecting specific apps? ? 
    Yes. I tested a few ones and this is happening only with Amazon Music and Netflix. That's really weird. As soon as I disconnect the wifi connection and connect to 4G, they load the content properly.
  • My Nokia 6.1 has this issue, latest Netflix app works 4G only. Other phones in my house work fine on either 2.4ghz or 5ghz. I have tried:
    - latest neflix beta and older versions
    - full phone reset
    - different WiFi channels

  • IanG
    edited January 2019
    E-mailed Nokia support who said that this should be fixed in future update but unfortunately it is forbidden to downgrade, Nokia Service people cannot do this. Further if it were done warranty is invalidated. I bought lesser specc'd UK model at much reduced value than APAC dual sim higher spec model to get a warranty, now I wish I had gone the other route and then i'd be tempted to try and find a way to downgrade. Due to this issue and no current solution I feel like I'm locked in as a kind of Beta tester, not sure if this sits with Nokia really or Google. I doubt it is really a Netflix issue since other apps have similar issues - I'd really like to know what functionality these apps use which is actually broken now.
  • IanG
    edited January 2019
    Followed this link, set MTU size on router and I set the time zone as described. BUT, and now I feel stupid, for the life of me I cannot seem to get to/find settings to set a static ip such that I can put the phone's IP in the router DMZ.
    n.b. If I open using cellular network and start playing a video and then switch over to wifi and switch off the cellular data connection Netflix will continue playing. After logging in like this over cellular I can browse via wifi but not stat a new video. If I log out completely I cannot login via wifi, in all cases netflix whirly waiting thing just goes on forever  
  • 90% success! I played about with MTU size dropping to 1464, left Auto time zone off as per that Motorola page.
    On the router in my firewall zones settings I tuned on MSS Clamping.
    Now it works, except I cannot cast to Chromecast for some reason, always something...
    So in my case MSS Clamping needed, don't know if any other setting had any effect, haven't tried to revert  the settings..