Cant delete photo from SD card with Google Photo

After update (new fw 330MB) today, i cant delete photo from SD card with Google Photo, i cant set permission for it, App has been informed:

Cant delete photo from SD card with Google Photo

huycankts huycankts
 /  edited July 2018
After update (new fw 330MB) today, i cant delete photo from SD card with Google Photo, i cant set permission for it, App has been informed: access is denied after I agree, I tried to erase the app's data and rebooted but it did not work


  • SunNic SunNic
    The same here, but I have this problem since the upgrade to Android 8. But with the last FW-update all other 3rd party apps can now write on the SD card.
  • redbriar redbriar
    ✭✭  / 

    me also i have the same problem. i cant delete picture from SD card using GOOGLE PHOTO. ACCESS DENIED appeared in the screen

  •  I'm having the same issue too. I tried to delete cache or reinstall the app but doesn't work. Hope they find a fix soon.

  • The only fix I can suggest is a factory reset to see if this resolves the issue, someone else had an issue with Duo / Calculator and this seemed to fix the issue.

    I know this is not everyones favourite solution but without access to manually clear the cache partition this is what we are left with as an option.

  • user1514984117665 user1514984117665
     /  edited July 2018
    Same problem here . Nokia please do something about this
  • Has anyone tried backing up their photos and formatting the SD card? If it is a permission issue this may clear it.

    I am lead to believe another December Oreo update will resolve this issue though from feedback on XDA.

  • Registros Registros
     /  edited March 2018


    Nothing works for me. First I tried to format the SD card (I
    tried one of 4GB and another one of 64GB) but the problem still there with both
    of them. After that I did a factory reset and nothing changes, when I try to
    delete a photo from SD card with Google photo I cant because it deny the access
    after I agree the permission.

  • huycankts huycankts
     /  edited March 2018
    I think the problem in new firmware, hope Nokia fix it, Now I have to switch to save to internal memory, please up vote the topic
  • It's apparently an issue with android security settings. Google changed some security settings in apps accessing storage in one of the security patches which messed the photos app up. There are plenty of other users on the xda forums complaining of the same issue. I guess we will have to wait till Google fixes it.
  • I dont know why? but im using Asus File Explorer, it still can delete photo from SD card, so what happen with Google Photo permission?

  • soheil baghery soheil baghery
     /  edited July 2018

     hi.I have the same problem.Please let me know if anyone could solve this problem

  • It's an issue with the latest Google Photos, not the Nokia 8.
  •  I don't think.because I've tried all old version Google photos and didn't work

  • Add me to the list.. Somethings gone crazy and now the phones default photos app (Google Photos) cant manage the phones photos. 

    Something needs tweaking at Nokia Firmware level I think as it happens even with the older versions of Google Photos. 

  •  Replying to keep this thread active as the problem is still there.

  • me too

    have same problem

    can not delete picture and video from google photo app!!!

  • Well after January security update, the problem is still there, so dissapoint
  • Nokia clearly don't read the forums. I've yet to see an answer from a Nokia/HMD staffer. 

    Report the issue by email here instead:

    You will at least get it logged by someone inside the company that way.

  • user1509097490797 user1509097490797
     /  edited February 2018
    I upgrade Android 8.1 beta today
    Fix this bug!!!
    I can use Google photo to delete my sD card photo!!!
  • sambartle sambartle
     /  edited February 2018
    Yes it is indeed fixed in the 8.1 beta. Thanks HMD.
  • Something to add to this thread, both myself and my fiancee has a Nokia 8, mine has never had this problem, hers has had it from the beginning. Mine is a few months old, as I got it when it came out and hers is about a month old. Reformatting the SD card doesn't seem to help, nor does resetting the app settings. Here's hoping for an official 8.1 release asap.

  • alexkay alexkay
    ✭✭  / 
    You can wait for release of 8.1 or get 8.1 beta. I don't experience any problem with 8.1 beta - can recommend it!
  • Android beta 8.1 solved it for me.
  • user1517840050750 user1517840050750
     /  edited February 2018

    same problem. just factory reset my Nokia 8 this evening and the same situation happens, always shows "acess denied" everytime i allow the Photo app to acess my SD card. Looking forward to seeing Nokia and Google app developers to take action 

  • user1514642333688 user1514642333688
     /  edited February 2018

     Update to Android beta 8.1 it solves this issue. Go through the steps on the nokia support page to update.

  • The beta is production quality. I've not seen a single issue with it in 3 weeks, so it's well worth signing up, although I can't see it being long before it becomes a final release anyway and rolls out to everyone.
  • It's a bit 'round the houses' but if you move the picture to the phone memory you can then delete it.
    Select the picture.
    Options top right.
    Move to....
    Put it in the phones pictures.
    It'll do until it's fixed.
  • 8.1 final Is about to start rolling out which will fix this.. 

    I just got the thanks for being part of the Beta email which comes before the rollout starts. 

Sign In or Register to comment.