Nokia 5 with latest Pie - bugs/issues

Bugs I have encountered with a fully updated Nokia 5 on Pie, as of 13 march 2019:

Nokia 5 with latest Pie - bugs/issues

Bugs I have encountered with a fully updated Nokia 5 on Pie, as of 13 march 2019:

-Mobile data dies completely occasionally, and can only be reinstated by rebooting the phone. I am not sure, but this seems to be related to the power save mode kicking in, so I stopped using it. 

-Wi-fi module "sees" and tries to connect to networks that are registrered in the phone but out of range, leaving it with no Wi-Fi connection as it will stay for a while and try to connect to a network that does not really exist in range.  The connection attempts end with "Authentication problem." This one is VERY weird. It can be mentioned that the locations where I see this "confusion" happening have WiFi routers of the same brand and model, but indeed, different MACs and SSIDs on the respective sites and if the phone misidentifies WiFi nodes because they are of the same brand and model something is seriously wrong!

-Camera refocuses periodically when filming, so the end result is much jumpier than need be. Solution - let the user focus-on-request by tapping screen. My previous budget Samsung model had it this way, much better result.

-Disconnecting wifi gives a warning message saying that the wifi connection has no internet. Absolutely not a biggie, a bug nonetheless.


Anyone else seeing those? I am especially concerned about the mobile data/wifi bugs as they seriously hamper usability of the phone.



Comments

  • Guirri Guirri
    ✭✭  / 
    try to find 

    With quickshortcut market from play store and editorial the power saving mode
  • Update:

    Resetting network settings (Settings -> System -> Advanced -> Reset options -> Reset wifi/mobile/BT ) -  seems to have solved the "Wifi Confusion" bug for me, the phone now no longer sees a network that is not there. Hope it lasts...
  • Data stone-dead today again without any Battery Saver usage in sight, so probably not connected to that. Rebooted.

    I am using Telia Sweden as operator. Have read other threads on the forum regarding other models(nokia 6.1 etc) for some reason having data connection problems with the same operator after upgrade to Pie. Some buggy code still left in this phone?

    Now set preferred data network to 3G as possible workaround... see if it stays stable (but really, that should not be needed, rather it should be fixed).

    Talk/SMS connection to the mobile network still stays fine when data has died.
  • <i><b>apps lock not available in Nokia device</b></i>
  • <b>apps lock strong security for customers</b>
  • Discovered another one which is in my opinion very bad functionality: The Nokia boot jingle plays at extremely loud volume when starting the phone, regardless if you muted the volume previously.

    Not a good surprise should the phone be mistakenly started / reboot in your pocket at a place where silence is of the essence (theatre or similar). Every other smartphone I have used - Samsung, Motorola, Sony-Ericsson have all had the option to disable the boot jingle, so fix it! (A clear step back from my nokia 6030 ca. 2005...)
  • marcolopes marcolopes
    ✭✭✭  / 
    SO, the camera FOCUS problem is BACK with PIE, after it was resolved in OREO? Bad nokia... :\
  • Wow! Not really experiencing those things on mine. Mine, is working very okay except for the low volume.
  • marcolopes marcolopes
    ✭✭✭  / 
    Omociano said:
    Wow! Not really experiencing those things on mine. Mine, is working very okay except for the low volume.
    Version? TA-1053?
  • Update:

    Used 3G preferred network on for almost two weeks now with no problem.
    So I tried to enable 4G.
    Poof. Within a few minutes network died and required restart of phone. Didn't help to set it back to 3G preferred, reboot was also required.

    Since there are threads regarding other Nokia models referring to network problems with certain Nordic operators, I suspect this problem is related. Some buggy baseband code (or even management code higher up in the system) has found its way into this series as well.

    https://community.phones.nokia.com/discussion/3736/may-update-no-mobile-data-connectivity-ta-1046


    Wifi "network confusion" problem went away with network settings reset and has not resurfaced since.

    Video camera focus needs the option of fixing it.

  • marcolopes marcolopes
    ✭✭✭  /  edited March 26
    Tobias R said:
    Update:

    Used 3G preferred network on for almost two weeks now with no problem.
    So I tried to enable 4G.
    Poof. Within a few minutes network died and required restart of phone. Didn't help to set it back to 3G preferred, reboot was also required.

    Since there are threads regarding other Nokia models referring to network problems with certain Nordic operators, I suspect this problem is related. Some buggy baseband code (or even management code higher up in the system) has found its way into this series as well.

    https://community.phones.nokia.com/discussion/3736/may-update-no-mobile-data-connectivity-ta-1046


    Wifi "network confusion" problem went away with network settings reset and has not resurfaced since.

    Video camera focus needs the option of fixing it.

    So, best option is NOT to update... I had months of annoying problems with OREO 8.1 and finally i have a more or less stable phone... not going to risk this update, unless i want to move to another phone and return this under warranty...
  • besi besi
    ✭✭  / 
    Another bug if I hold down the screen for a long time then I want to change my background image I click on it and nothing happens. that is also a bug
  • Tobias R Tobias R
     /  edited April 4
    Update:

    Resetting APN settings might have solved my "4G network dying" problem.

    (Settings -> Network & Internet -> Mobile Network -> Advanced -> Access point names -> Press the three dots and reset to defaults). Then reboot the phone.

    The settings were EXACTLY the same after resetting, so thought it'd have no effect. But the network is going on in 4G mode over five days now.
    Either some internal corruption was to blame or Nokia fixed it with a silent baseband update in the background. Or it's not fixed, and is just going on nicely right now by pure luck.
  • Another discovered problem:

    There seems to be a memory leak in the system.

    After about a week of use, Android System process grows to over a gigabyte in size, leaving room for no actual apps. So anything but the one currently active on the screen will be unloaded, leading to really slow (or really, for some purposes unusable) phone. Reboot required.

    Read around on some other forums and this does not appear to be a Nokia specific problem. Users of diverse models and brands on Pie are reporting pretty much the same thing. So some quirk has been introduced into Android's memory management. Bad, hoping for a fix before this phone is completely discontinued!
  • Azuwaza Azuwaza
     / 
    And new build Android 9 Pie MR UPDATE when?
  • Mobifon Mobifon
     / 
    Nokia 5.1 Issue with NFC Freezing after update to Pie.

    Has anyone had the issue with 5.1 handsets when upgraded to Pie after a random number of scans NFC freezes ?
Sign In or Register to comment.