The community forum

Join the conversation

Compatibility problem with Windows 10 computers

When I plug in Nokia 8 on Windows 10, the contents of phone are not displayed at all in Windows Explorer. Only Nokia 8 device and blank directory are displayed. In addition, a small partion appears as a CD/DVD drive. I have tried two different Win10 computers - the result is the same. Connecting Nokia 8 to Windows 7 PC was OK. The contents of the phone and the SD card were visible. Is compatibility problem with Windows 10 computers a wider problem?

1 person has this question

 I have the same problem. Hope it will be fixed soon.

If you see the CD icon on your PC open it and install the driver.
Doesn't help. I have tried it already. The driver doesn't install successfully.

 I got an answer from the Nokia support team which fix the problem. Here the translation of the email from German to English: 1. Open the confi menue and push the Build number several times untill you get the info "you are already developer". 2. Then choose the developer option and select USB configuration. Probably MTP is already selected. Select now charging and than MTP again. Connect the phone via USB to your W10 Computer and it will work.


1 person likes this
Yes. Now it Works... Thanks!

 I have the same problem since Android 8.0 update. The workaround works, but has to be done everytime before the phone is connected to the computer.


PLEASE FIX THIS

Rufer


1 person likes this

 Yup. This issue is rather annoying. The MTP needs to be re-activated every time.


1 person likes this

Doesnt work for me on win7.

MTP shows only disk with driver. PTP shows photos from internal memory.

Just bought a Nokia 1 for my kid, I have the problem on both Win 7 and Win 10.

Incredibly annoying that the MTP activation must be done every time (even every time the phne locks, even if connected via USB to the PC). I'm pondering sending the phone back.

Go into device manager then find the driver for your device. If your not sure unplug it from your pc or laptop then plug it back in. Delete the driver which is installed and unplug the device. Reboot windows then plug your device back in advertising hopefully it will work

Sorry GEMINI75, that doesn't work (had already tried before). The only thing that works is the trick mentioned by Johann Student (Developer mode, then MTP setting). But it's not permanent, has to be re-done every time.

Login to post a comment