The community forum

Join the conversation

Problem receiving SMS (specially OTP from bank)

Hi All,

My dad recently bought Nokia 8(Dual sim). But, there seems to be some problem with the device. Phone is not receiving OTP sms from his bank. Rest all sms are received fine, even other sms from the bank receives fine. Only the OTP sms are not coming.

Switched sim to two other different Android devices, and they receive OTP every time. (verified it multiple times). 


We tried the following to no effect:

  1. Switching sim between 1 and 2 slots.
  2. Restarting multiple times.
  3. Checking contacts and messaging app for any blacklisted contact (there's no blacklisted contact).
  4. Phone is completely stock and no third party messaging, calling, or contacts apps installed.
  5.  Contacted bank, and their system is fine (Other Andorid devices receiving OTP).
  6. Network is also fine. (Other Android devices receiving OTP).

We haven't blocked or blacklisted any contact. Neither have installed interfering apps like true caller or true messenger. This problem forced him to still use his old Lenovo Android phone.

Any help will be highly appreciated.



1 person has this question

i found solution for that Disable that existing message app and install Zero sms app from play store i tried different apps but only this Zero sms app is working fine and after installing please go into settings of battery and allow Zero sms app in white list

2 people like this

i found solution for the same problem.. just down loaded microsoft message oraganizer app from play store and marked it as default app for messages. after doing this i am able to receive all otp's from bank and all the messages.

1 person likes this

Hi all,

Thanks for the answers. Switching apps didn't work in our case as the problem was somewhere between Bank and telecom service provider. The system from the bank wasn't registering the new phone information I believe. Anyway, about two weeks after the question was posted, Bank updated/repaired their system and problem was fixed automatically.

Thanks again.

Login to post a comment