The community forum

Join the conversation

Alarm is not ALARMING

For the past few days I'm rushing to my game , the reason behind this is"MY ALARM IS NOT ALARMING" , Please suggest some possible fix.

47 people have this question

I tried two solutions I found here; settings-apps-clock-notifications: override do not disturb and : 1. Go to SETTINGS 2. Search DEVICE ADMINISTRATORS 3. Select BATTERY OPTIMISATION 4. Select ALL APPS 5. Open CLOCK 6. Select DON'T OPTIMISE, my alarm now works!

1 person likes this

 Probably broke the speaker. I have the same problem. It is a disease of new Nokia phones. :(

I have found a solution to this problem. Even my alarm and SMS weren't working. The system apps are being killed in the background and Nokia 6 doesn't have an option to NOT kill the system apps in the background. So I installed 3rd party apps like "SMS Organiser" by Microsoft (the best SMS app) and "Alarmy" (one of the decent alarm apps with very few/ no ads). Now to enable them to work in the background go to Settings->Battery->Background activity manager and enable the new apps to run in the background. Problem solved. Alarms and SMS are the last things we would want to block in the background. Faced Lotta problems while making online payments as I couldn't receive OTPs. I hope Nokia comes up with an update soon before more people get frustrated and switch to other phones.

1 person likes this
AFTER USING NOKIA 6 AND SETTING ALARM I FACED PROBLEM OF ALARM NOT ALARMING
@user1516338772630 as I have installed the app. But Nokia is not resolved the actual and very basic issue. These are the fundamentals of the any phone where many basic phones have lot of features than Nokia 6
Hi Alarm not working .
I faced the same issue. Again, because of the unnecessary battery optimisation feature. 1 search for battery optimisation in settings menu 2 select all apps and change the settings for clock and whatever other app you're facing an issue with, to 'don't optimise' 3 for alarm, keep the clock app open in the background and don't close it. Set alarms every half an hour for 6 hours (mute it if you wish) 4 now the phone will not force kill the app It definitely worked for me for SMS, alarm, whatsapp, outlook, moneycontrol etc.
My dear friends... I had the same problem. Please just stop blaming Nokia for everything you don't understand. My Alarm Clock, VPN, etc. Was not working and I figured out the problem was in the background apps activity. To save your RAM and Background Usage, Nokia developed this option to restrict background activity.. However, the solution is as simple as this Phone is, 1) Go to Settings 2) Press the search button to find 'Background Activity' 3) You will see a list of your apps restricted for background activity. 4) Switch the Apps 'ON' to allow them to be used in the Background. 5) Voila, your Alarm works fine now!! Hope it solves the problem!!

i am using the stock alarm in the home screen clock.  i simply changed the alarm sound to a different one and it's working again.  my alarm was not working in the alarm extreme app or the stock alarm.  i had deleted the app trying to figure out the problem.  i have not installed another one since the stock alarm/clock feature is working well.  i began having problems with alarm not working after upgrade to android 8.0

Login to post a comment