We're upgrading

Be a part of the all-new
Nokia phones community,
coming soon.

Looking for the forum?


While we add the finishing touches to the new community, you can still browse the forum, but not create or edit posts.

Compatibility with Android Auto solved !!

For those who are having problems with Nokia 6 not being able to connect to the car head unit using Android auto, below is the solution: 1. Please ensure all the relevant softwares are up to date 2. Use a high quality USB cable. Amazon basics. Sony. Ivoltaa cables are good enough. 3. Turn on USB debugging on your phone. 4. Go to settings - battery - battery activity manager - turn on Android auto & maps from the list below. 5 . Reboot the device and you are good to go.

Still no solution for me. I read on a Motorola forum that Oreo 8.1 has caused caused widespread USB issues (known to Google) it is just that Android Auto is most used with USB and therefore most noticed. One solution apparently is to set screen or device lock to NONE. I can't figure out how to get rid of my pattern.

I have managed to get Nokia 6 (TA1021) phone with Android Oreo 8.1 working with Android Auto.

I have followed the steps provided by user1512193358184 but it did not help. Finally I decided to switch USB configuration while in USB debug mode from MTP (Media Transfer Protocol) to Source of Sound (or similar, I do not have English version of Android) and it triggered immediate connection to my car system. No need for re-boot of mobile. Unfortunately Nokia 6 phone will not save this configuration option so you need to repeat the same steps every time you connect your Nokia 6 mobile to USB cable. Also, tried other configurations like MIDI or toggling between MIDI and MTP. It only works when Source of Sound option is selected.

The USB configuration option in English is Audio Source

Login to post a comment