The community forum

Join the conversation

double contact entries in the telephone App

I've seen in other posts that I'm not the only one having this issue and in a German Android forum there are as well several user effected. I'm going to create a topic for it to make it transparent.

What's the issue:

After installing WhatsApp you need to sync your contacts between the Android contact App and WA.
Otherwise you'll see just the number, not the name of your chat partner in WA.

After allowing WA to sync contacts it works fine but you now have double entries of these contacts in the telephone app on the contact list.

Deleting the account for WA will work for just a short period of time as WA will re-establish it with the next sync. Deactivating the sync solve it but you don't have names in WA anymore.

Via the app "duplicate contacts" you can delete them but they are coming back after the next sync.

Contacting WA support didn't offer a solution, they refer to Nokia

Contacting Google Support didn't offer a solution, they refer to Nokia as well.

Contacting Nokia Support didn't offer a solution, they refer to Google or WA as they are using pure Android.

So now I'm running in circles . . . .

Please, if you have the same issue, comment on  this topic so we might be able to make them aware that someone needs to take action.

1 person has this question

Tech Wizard

Hi, I use WhatsApp and I see my contacts being duplicated in Phone / Telephone application alone even if the contact has a single phone number.The Contact application however just displays a single entry for the contact.
I tried reaching out to the application team on Playstore, But I didn't get any response from them.

I use another chat application and see those contacts appearing as well. Its better not to mess with this contact as the other dependant applications will not work as desired.

I had this same problem after installing Whatsapp. I fixed it by editing my contact numbers  remove any '-' also after the fifth number of the contacts phone number add a blank space ' ' example: 12345 123456  this merged the  contacts  and Whatsapp numbers together for me. Could be time consuming if you have a lot of contacts though.

2 people like this

Tech Wizard

This fixed the duplicate contacts error on 'Phone' Application.Otherwise it just looks fine on the 'contacts' application.But a tedious task to even edit 100 contacts.

It maybe easier to edit on PC. But you should remember to give a space gap when entering new contacts as well ! 

Tech Wizard



Contacting WA support didn't offer a solution, they refer to Nokia

Contacting Google Support didn't offer a solution, they refer to Nokia as well.

Contacting Nokia Support didn't offer a solution, they refer to Google or WA as they are using pure Android.
Guess we have to offer the solution ourselves now!

1 person likes this

You are my hero, it works well.
Yes, it is manual effort and (having German phone numbers) doesn't make a lot of sense but it works :)

This cant be the solution,

Come on NOKIA!

im not gonna edit 441 contacts by hand! solve this stupid problem.

my carkit cant handle 441 double contacts so i dont get all phone numbers in my car phonebook.


1 person likes this

Tech Wizard

@user1513081661191 ,

This is NOT the official solution provided by Nokia. It was provided by N5user and it Works ! 

It could be one of the many solutions to this issue.

It could be the fault of 'Contacts' application as well. No one got the confirmation from any one on this matter. So it is upto the user to use the solution to fix the double / duplicate contacts issue or ignore it.

However, there are easier ways to edit large number of phone numbers by using Gmail on a PC.
***Have a BACKUP of the contacts. Not responsible for the loss of contacts****

1) Gmail > Contacts > Select all and Export them as Google CSV format ( Select ALL contacts).
2) Open the CSV file in Excel / other software and make changes to the Phone number as suggested in the N5user post.
3) Save the CSV file and Import it to google contacts ( U can delete ALL the contacts from google before importing to eliminate actual duplicates!)
4) Done.

A little question? For contact numbers like +34123456, where can we add space character? After fifth, + included? Thanks
Yes, correct +3412 3456
Great work, Modgar and Nishanth! It's annoying to have these doubled contacts! I solved it with another workaround by using Androids feature of combining contacts manually. Unfortunately Googles Contacts app doesn't offer anylonger to select which accounts to show other than from Google account. I remember that you can select if you want to see WhatsApp, Allo, ... , ... So I installed another contacts app from Play Store, combined contacts manually and removed it afterwards. I hope Google will add viewing other contacts again in future!
Hello, below worked for my Nokia 8 w/Oreo 1- Go to contact app - settings - accounts 2- Click WhatsApp account then turn off auto-sync 3- Go back to accounts page and turn off auto-sync for all accounts. You'll recieve a warning, ignore it. 4- Remove WhatsApp account 5- Check duplicate names if they are gone 6- Go to contact app - settings - accounts again 7- Click plus sign to add new account and add WhatsApp 8- Turn on auto-sync which you turned off in step 3

1 person likes this
The problem is on Telephone app not Contact app. Solved as described above
I have the same issue.. same contact displayed multiple times... Google which is editable plus WhatsApp, vodaphone caller tunes etc etc. Yes when one goes into contracts as such just one is displayed but when you go into phone or then any other app accessing contacts... It shows these multiple ones which is a huge pain, especially when adding a number or email address to a contact from WhatsApp or similar or trying to send a contact. Nokia you must do something about this urgently

It's wahtsapp related.

You must FORMAT your contacts with / without prefix.

i use TWITCH 2! to do it.

1 person likes this
Login to post a comment