We're upgrading

Be a part of the all-new
Nokia phones community,
coming soon.

Looking for the forum?

While we add the finishing touches to the new community, you can still browse the forum, but not create or edit posts.

Oreo UI/system lag

Sometimes when I unlock my phone there is massive lag system wide, animations are choppy and everything is extremely laggy. When I lock the phone and unlock it again the lag is gone and the system runs smoothly again, sometimes I need to do this a couple of times to get it to work. Are more users experiencing this? And for HMD, can you do something about this? I'm on the stable Oreo release for the Nokia 8. And I've already tried a factory reset without success. Thanks.

It seems to be caused by the glance screen, disable that and the issue will go away. This happens to me occasionally as well, sometimes locking the phone again and then unlocking it cures it, sometimes have to do this a couple of times. If you find it really annoying just disable the glance screen. Hopefully Nokia will fix this an update soon.
I've just turned off the glance screen, what a coincidence. Thanks for your reply.
Hopefully that will help, biggest annoyance for me with this phone is a WiFi bug, I get around 5-6 days uptime before the WiFi driver crashes and although it will connect if your near the router, their is no data throughput and if you move away slightly from the router the connection drops and starts using mobile data. A reboot is the only thing that gets WiFi going again, it's annoying as if I don't notice I use a ton of mobile data.
Same here! Started happening right after the Oreo update. It happens about 10 times a day and locking or unlocking the phone doesn't help. I just have to ride it through. It usually goes away after 15 minutes of use. During the 15 minutes though, it feels like a phone from 2007. Also, the NFC on this phone is a hit or miss, to the limit where I would rather pair devices through the Bluetooth settings and it will be faster.
With NFC give this a go, Oreo has an aggressive app optimiser, I'm thinking the NFC service may need white listing to stop it from being out to sleep. If you go into settings, battery and then hit the 3 dots in the top right hand corner, you should see battery optimisation, go into this and look for the NFC service, change it to do not optimise. This needs to be done with a lot of messaging apps for notifications to work reliably and I'm thinking along the same lines with the NFC service.

Yup turning off glance screen fixes the issue for some reason the support team can't believe me when i told them about this issue and the forums are dead nobody checks them 

 Happens for me as well after having updated the phone to Oreo.

Disabling the glance screen works as a workaround. But does anybody know if the issue has been resolved in the latest update (the security update for December)?

I have the December update and I'm afraid it isn't resolved. I find it tends not to happen if you unlock with your fingerprint, but will happen if the phone has literally just locked and you double tap the screen.

I run into exact the same issue. But i want not to turn off the glance screen, there is no notification led, how should i see quickly if a message arrives? 

 Hi, i have the same issue since 2 days. My phone needs up to 5 seconds to unlock. I already uninstalled serveral apps and reregister my fingerprints, but the problem is still there.

I read serveral threads about this issue (also on other phones) on the web and it seems to be a Oreo 8.1 problem (?).

Please Nokia,fix it.

I have tried a bit arround with some developer Options and one Option seems to fix it for me,it is disable Hardware overlay. When i enable this Option the phone runs smooth how it should also with enabled glance screen. i had not yet found any negative attitude enabling this Option, but cant say it exactly. but you have to enable this Option everytime you Restart your phone, cause it is disabled automatically when the phone is restarted.

I found a developer Option "disable HW overlays" which seems to fix the issue for me. You have to reset it everytime you Restart your device, but my phone feels fast again, also with enabled glance screen. i have tested it a few weeks and found no other issue caused by enabling this Option, but cant say it excatly.

This issue still exists and has a bug tracker:


The problem isn't fixed yet even though it says so.

Login to post a comment