The community forum

Join the conversation

No recovery mode model TA-1012?

Having forgotten my pattern lock. It would appear my nokia 8. (Its the single SIM version UK) is now bricked. As there is no recovery mode functionality. I can get safe mode up, but it seems there no revovery mode option. Ive tried various hardware methods to access it. Any help would be appreciated.

Try connecting it to a computer then see if you can get into recovery. If not i would agre advic advise you to contact whoever you purchased it from for a replacement.

You can wipe and reset the phone if you can't get past the lock screen - but (a) you'll lose everything on the device that's not backed up, and (b) you will have to set up the device using a Google account that was used on the phone previously.


With the phone switched off, hold the volume-up button. The phone will boot up and will leave you at a screen showing the Android robot undergoing open-heart surgery. Press the volume-up and power buttons and you'll be given a menu. Use volume-up and volume-down to move up/down to select the Factory Reset option; the power button will select. You will be asked to confirm. When done, select the reboot option from the menu. You can then set the phone up again. There are picture and video tutorials out there for the procedure.

It's REALLY picky on my UK TA1012 as well. You have to start the process without cable connected then connect to a pc at one point during the process and it does work. Someone posted a walkthrough somewhere on this forum that worked for me.

What works for me : 


When phone is on connect with USB cable to PC.

Turn phone off, immediately press volume up button after this.

Wait for the little Android to appear.

Press power + volume down to access the recovery menu. -> this might take a few tries cause you have to be really precise, but this was the same on my Nexus 5X.

Login to post a comment