The community forum

Join the conversation

Cant delete photo from SD card with Google Photo

After update (new fw 330MB) today, i cant delete photo from SD card with Google Photo, i cant set permission for it, App has been informed: access is denied after I agree, I tried to erase the app's data and rebooted but it did not work

8 people have this question

The same here, but I have this problem since the upgrade to Android 8. But with the last FW-update all other 3rd party apps can now write on the SD card.

me also i have the same problem. i cant delete picture from SD card using GOOGLE PHOTO. ACCESS DENIED appeared in the screen

 I'm having the same issue too. I tried to delete cache or reinstall the app but doesn't work. Hope they find a fix soon.

The only fix I can suggest is a factory reset to see if this resolves the issue, someone else had an issue with Duo / Calculator and this seemed to fix the issue.

I know this is not everyones favourite solution but without access to manually clear the cache partition this is what we are left with as an option.

Same problem here . Nokia please do something about this

1 person likes this

Has anyone tried backing up their photos and formatting the SD card? If it is a permission issue this may clear it.

I am lead to believe another December Oreo update will resolve this issue though from feedback on XDA.

1 person likes this


Nothing works for me. First I tried to format the SD card (I tried one of 4GB and another one of 64GB) but the problem still there with both of them. After that I did a factory reset and nothing changes, when I try to delete a photo from SD card with Google photo I cant because it deny the access after I agree the permission.

3 people like this
I think the problem in new firmware, hope Nokia fix it, Now I have to switch to save to internal memory, please up vote the topic

4 people like this
It's apparently an issue with android security settings. Google changed some security settings in apps accessing storage in one of the security patches which messed the photos app up. There are plenty of other users on the xda forums complaining of the same issue. I guess we will have to wait till Google fixes it.

I dont know why? but im using Asus File Explorer, it still can delete photo from SD card, so what happen with Google Photo permission?

 hi.I have the same problem.Please let me know if anyone could solve this problem

1 person likes this
It's an issue with the latest Google Photos, not the Nokia 8.

 I don't think.because I've tried all old version Google photos and didn't work

Login to post a comment