The community forum

Join the conversation

Pop up notifications not working

Just purchased Nokia 8 and upgraded to Oreo 8.0.0 (coming from Nexus 6 and a big fan of stock android), great phone but I have one serious issue I cannot solve. I do not get sms (or other like skype, messenger etc) notifications poping up and waking the screen, I have tried all possible settings in Settings>Apps & Notifications>Notifications etc and from inside all the relevant apps internal settings. Additionally I have tried to find a solution in forums etc. Nothing seems to work, the only time the screen wakes and pops up a notification is when I get an incoming phone call. Any help will be appreciated I am starting to get a little disappointed and thinking of returning the device.


1 person has this question

This is a Nexus/Pixel feature. Samsungs and other phones don't do it either. You might be able to get an app to do something like this from the Play Store but I can't guarantee it won't have an impact on battery life

You need to install an app such as Glimpse: https://play.google.com/store/apps/details?id=de.nullgrad.glimpse

Bizarrely I have the opposite problem. I set up notifications, specifically WhatsApp, to wake my phone and show the message. It even gives the opportunity to reply. I now want to turn it off but nothing I try works. Annoyingly, I can't remember what I did to get them in the first place but I have tried the options you describe. I have a feeling that perhaps this feature worked but has been corrupted, possibly by an update.
Being able to reply directly through notifications is just a standard feature of Android now. Are you saying you set this up through WhatsApp? As far as I know the only pop up option within WhatsApp pertains to allowing a pop up with quick reply for older phones that don’t already have the feature. I didn’t think this could wake the phone though.
As I say, I can't remember exactly how I set it up but there is an option to set up pop up notifications from within the app. Two of the the options are 'when screen is on' and 'when screen is off'. There are also further options available by going into the Android settings/apps and notifications/notifications /notifications /all apps/WhatsApp. I've set all pop ups (that I can find) to off but I'm still getting them. Not the end of the world but it annoys me that I can't undo what I did :)
Login to post a comment