The community forum

Join the conversation

update to 8.1

I have not yet received the 8.1 beta update.

Kindly look into this matter

9 people have this question

Please give some more info.

Did you register your device in Nokia Beta labs?

 And if you did register did you push the OTA?

Yes I have already registered and I have even pushed the OTA



When registering to the beta labs, please make sure that you are using IMEI1 when registering the device. If you have used IMEI2 and therefore unable to receive the beta sw, contact support.

@user1508950799260 please try to register again with IMEI1


1 person likes this

I have already registered with IMEI1 

Still not got the update

I'm also struggling with the same issue. My Nokia 8 SS (TA-1012) was updated via the BetaLabs program to Android 8.0.0 Build 4.35J, and cannot get the latest Android 8.1 based build. I've pushed Request OTA button several times, but nothing received. I've already tried to roll back, but it does not work either. Got the notification that OTA is requested, but cannot get neither rollback nor update, even after manual update search, phone restart, factory reset.
IMEI is told to be Validated:


Any hints how to proceed?
Thanks in advance.

1 person likes this
Same here
Same problem here... Did everything Wright several times but still no update


My Nokia 8 on the 3 network in the UK received the update last night and now the wi-fi hotspot (which I use for work every day) does not work, devices can connect but they have no internet access. This is identical to the issue widely reported on the Nexus5 with 8.1

I need a fix this morning because if I can't get it working (or rollback to 8.0) by midday I'll have to buy a new phone.

How do I rollback or fix this issue?

@Jaffa, that sounds unfortunate,

i did some digging and what is described here appears to be an effective solution :

Go edit your APN settings and change APN-type "default,supl" to <blank>.

Hope this works out for you!

Yes I found that page this morning and tried the blank APN but it did not work, so I tried a restart and it still did not work, when I checked the field had been refilled.

I'm trying a factory reset now.

Full "factory reset" does not resolve the tethering issue, phone has internet tethered devices do not.

I think a rollback to 8.0 would be the best option, is this possible? What is the procedure does anyone know?

Login to post a comment