The community forum

Join the conversation

How to force HD Call (VoLTE) activation?

Since few days my carrier (TIM in Italy) has enabled the Nokia 8 to call on the LTE network (VoLTE). In fact, now it appears in the list of devices supported by this technology on its network.

On my SIM I had already enabled the option to enable VoLTE, "TIM Voce 4G" (aka "TIM Voice 4G"), but even now that the Nokia 8 has been enabled, I don't see the "Enhanced 4G LTE" item in the network settings.

I also tried to install the Android 8.1 beta, but the situation doesn't change.

Within the menu *#*#4636#*#*, the "VoLTE Provisioning" is activated and the status of the IMS service (in the same menu) make available the calls via LTE.

TIM has reset the network, but there have been no results.


is there any way to force the display of that setting, even via ADB and thus be able to take advantage of calls in HD?

Otherwise what can I do?

I have a Nokia 8 TA-1004 EU6 purchased on Amazon Italia, so "no-brand". I tried the sim in both slots, but the situation does not change and this is a 4G SIM.

The build is 00WW_4_82A (Android 8.1 beta with january security patches), but the situation was the same even with the latest stable build available (00WW_4_390_SP01, Android 8.0 with january security patches).


1 person has this question

 @Guru I'm in Italy, not India, my carrier (TIM) supports VoLTE and recently has enabled the Nokia 8, but I don't have the option to enable HD calls yet (it's hidden, if I search for it, it appears in the search result, but when I tap on it, I'm redirected to the network settings where it's missing).

I am also facing the same situation. *#*#4636#*#* option tried several times and verified from network service provider,. What we have to do?

There is no "Enhanced 4G LTE" showing in my menus either but when i make a call the phone remains on 4G rather than dropping to 2 or 3G and it displays HD when on the call (UK on BT (MVNO on EE)) so VoLTE is working.

Login to post a comment