The community forum

Join the conversation

Nokia 8 Oreo 8.1 now live

Just landed on my phone. Oreo 8.1 File size is about 1570MB. Kudos HMD! Great stuff.

Well that's pretty fast, i'm still on the beta and no stable OTA, but should come in any time now i suppose.


Is the february security patch included? Is there a new camera app like on the Nokia 5 & 6?




Downloading now for me in the UK on Tesco Mobile. I've been on the beta, hoping the deep sleep issue is fixed. If this is fixed this will be a near perfect firmware for me.

1 person likes this

revieved the update last night image


image

new easter egg in 8.1

How is the battery life of your devices? Feels like it's noticably worse after this update :'(

1 person likes this

Anyone in Belgium received the update yet? I'm on the Proximus network (Vodafone).

The wakelock issue seems to be adressed, wich is a good thing.

WiFi tethering not working on Nokia 8 since 8.1 update (UK 3 Network), phone has internet connection, devices connect fine to WiFi hotspot but have no internet connection.


I use the tethering every day and it stopped working following the update yesterday.


Tried resetting various network settings (as advised by email bu Nokia) and also performed a full factory reset, the problem persists.


Since I can't do my job I'm going right now to buy a new phone with tethering function.

Tethering worked for me when I tested it on the beta, I've not had a chance to test it with the stable release. I'm on Tesco mobile in the UK. Usually when this doesn't work it has something to do with the settings your network operator has set. You may be able to adjust the access point settings to get round this, but make a backup of them before you mess with them.

You may be right, but since I don't know what setting to change and what to change it to it is still broken. It worked fine every day on 8.0 (up until yesterday) so another solution would be to restore the previous version but I don't know how to do that either.


The only option I have which will get me working in the next hour is to buy another phone with tethering. That's where I'm going now.

 

Yes, it's annoying but I have to be pragmatic, I've lost money this morning already I can't bill my customer for time spent fiddling with my phone.

Hey Jaffa, i've picked this up from another thread here, maybe try as a last resort. Basically not leaving APN type blank but type "" there instead : 


https://community.phones.nokia.com/support/discussions/topics/7000015762


 Update: it seems I made it work.


The workaround I read on Google Oreo Bug tracking board was to blank the field "APN Type" in the APN Details page (reached this way: Settings -> Network & Internet  -> Mobile Network ->  Advanced -> Access Point Name -> <your apn>  APN Type).


I read this and didn't work, because blanking made Oreo automagically fill with all of the allowed strings together.


This time, on a whim I filled the field with these two characters "" , which in programming languages are used to represent a literal empty string. Lo and behold, IT WORKED. :-) 

Anyway, it sucks that this bug is still present in the stable 8.1 Oreo version, especially since the thread i've linked above was created while the Beta was still open, so they should have fixed it.

Or maybe it's a deeper more complicated issue and google needs to fix this..

Thank you LennartB, the "" worked.


Hopefully the HMD/Nokia folk read this forum because I've been in touch with them this morning and none of their suggestions worked.


Now I just need to get to the bottom of why the bluetooth audio has also stopped working.


1 person likes this

Good to hear Jaffa, sucks about the Bluetooth, i'm currently updating mine so will see if the bluetooth works correctly.


Strange though, i contacted Nokia support chat and told them i haven't received the update yet.

They told me it was carrier-specific and depends on the provider when you will receive an update and that a factory reset wouldn't trigger an update.


What i've tried : different sim card from different provider -> nope

reset carrier services and reboot with different sim -> nope

reset carrier services and reboot with NO sim -> nope


What worked eventually was a factory reset  going through the setup with NO sim inserted, as soon as i connected to my wi-fi it trigger the update.

Login to post a comment